Skip Menu |
 

This queue is for tickets about the Perl-MinimumVersion CPAN distribution.

Report information
The Basics
Id: 88862
Status: open
Priority: 0/
Queue: Perl-MinimumVersion

People
Owner: Nobody in particular
Requestors: ether [...] cpan.org
Cc: DBOOK [...] cpan.org
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: request: remove dependency on Perl::Critic
Download (untitled) / with headers
text/plain 261b
Perl::Critic does not install under 5.19.x, and so modules upstream of it, such as this one, do not install cleanly. This has a knock-on effect on several Dist::Zilla modules and bundles. Is it possible to remove the dependency on Perl::Critic in this module?
Download (untitled) / with headers
text/plain 280b
I agree. It looks like the dependency is just Perl::Critic::Utils. Perhaps that can be forked off into a PPI::Utils (or some other name) module and stripped of the few Perl::Critic dependencies (like exceptions). Needing all of Perl::Critic just to have PPI helpers is a shame.
Subject: Re: [rt.cpan.org #88862] request: remove dependency on Perl::Critic
Date: Tue, 12 Aug 2014 08:44:37 -0700
To: David Golden via RT <bug-Perl-MinimumVersion [...] rt.cpan.org>
From: Karen Etheridge <ether [...] cpan.org>
Download (untitled) / with headers
text/plain 343b
On Tue, Aug 12, 2014 at 09:47:13AM -0400, David Golden via RT wrote: Show quoted text
> I agree. It looks like the dependency is just Perl::Critic::Utils. Perhaps that can be forked off into a PPI::Utils (or some other name) module and stripped of the few Perl::Critic dependencies (like exceptions).
see also: https://github.com/adamkennedy/PPI/issues/78


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.