Skip Menu |
 

This queue is for tickets about the Math-GSL CPAN distribution.

Report information
The Basics
Id: 88583
Status: rejected
Priority: 0/
Queue: Math-GSL

People
Owner: Nobody in particular
Requestors: justin.gardin [...] gmail.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: compile error
Date: Tue, 10 Sep 2013 11:33:19 -0400
To: bug-Math-Gsl [...] rt.cpan.org
From: Justin Gardin <justin.gardin [...] gmail.com>
Download (untitled) / with headers
text/plain 1.7k
*When attempting to install GSL::Math version 0.27 I receive the following error* Checking for GSL... *** *** You need to have GSL 1.11 or greater installed. (You have 1.9). *** Get GSL at http://www.gnu.org/software/gsl *After changing the line of code in ./Build.PL from* my $MIN_GSL_VERSION = "1.1"; *to* * *my $MIN_GSL_VERSION = "1.9"; *The error message disappears however this does not address the problem. Continuing forward with the install after this change in Build.PL* jgardin@jgardin-MacBookPro:~/programs/Math-GSL-0.27$ sudo perl Build.PL Checking for GSL.. Found GSL 1.9 (via gsl-config) installed in /usr/local, CFLAGS=-I/usr/local/include, -L/usr/local/lib -lgsl -lgslcblas -lm Asking ExtUtils::PkgConfig with ENV{PKG_CONFIG_PATH}=/usr/pkgconfig:/usr/lib/pkgconfig:/usr/local/lib/pkgconfig:/usr/local/pkgconfig:/usr/libdata/pkgconfig:/usr/local/libdata/pkgconfig:/opt/pkgconfig: Checking if cc supports "-Wall"...yes Checking if cc supports "-Wno-unused-function"...yes Checking if cc supports "-Wno-unused-value"...yes Checking if cc supports "-Wno-unused-function"...yes Checking if cc supports "-Wno-unused-variable"...yes Checking if cc supports "-g"...yes Created MYMETA.yml and MYMETA.json Creating new 'Build' script for 'Math-GSL' version '0.27' Have a great day! jgardin@jgardin-MacBookPro:~/programs/Math-GSL-0.27$ ./Build Building Math-GSL Can't find appropriate bindings version, check 'xs' directory, it should contains bindings with version <= current GSL version (1.9) at inc/GSLBuilder.pm line 72. *After perusing the internet, I found that swiq was required for this perl file. I installed swig 2.0.7. After deleting Build I ran Build.PL again, receiving identical output from Build.pl and ./Build. Now I am stuck and I do not know how to continue.* * * * * * * *Justin*
The problem is that Math::GSL did not support GSL 1.9 at the time of this bug, only as far back as GSL 1.11. Please give a recent GSL/Math::GSL a try. On Tue Sep 10 11:33:36 2013, justin.gardin@gmail.com wrote: Show quoted text
> *When attempting to install GSL::Math version 0.27 I receive the > following > error* > > Checking for GSL... > *** > *** You need to have GSL 1.11 or greater installed. (You have 1.9). > *** Get GSL at http://www.gnu.org/software/gsl > > > *After changing the line of code in ./Build.PL from* > my $MIN_GSL_VERSION = "1.1"; > > *to* > * > *my $MIN_GSL_VERSION = "1.9"; > > *The error message disappears however this does not address the > problem. > Continuing forward with the install after this change in Build.PL* > > jgardin@jgardin-MacBookPro:~/programs/Math-GSL-0.27$ sudo perl > Build.PL > Checking for GSL.. > Found GSL 1.9 (via gsl-config) installed in /usr/local, > CFLAGS=-I/usr/local/include, -L/usr/local/lib -lgsl -lgslcblas -lm > Asking ExtUtils::PkgConfig with > ENV{PKG_CONFIG_PATH}=/usr/pkgconfig:/usr/lib/pkgconfig:/usr/local/lib/pkgconfig:/usr/local/pkgconfig:/usr/libdata/pkgconfig:/usr/local/libdata/pkgconfig:/opt/pkgconfig: > > Checking if cc supports "-Wall"...yes > Checking if cc supports "-Wno-unused-function"...yes > Checking if cc supports "-Wno-unused-value"...yes > Checking if cc supports "-Wno-unused-function"...yes > Checking if cc supports "-Wno-unused-variable"...yes > Checking if cc supports "-g"...yes > Created MYMETA.yml and MYMETA.json > Creating new 'Build' script for 'Math-GSL' version '0.27' > Have a great day! > jgardin@jgardin-MacBookPro:~/programs/Math-GSL-0.27$ ./Build > Building Math-GSL > Can't find appropriate bindings version, check 'xs' directory, it > should > contains bindings with version <= current GSL version (1.9) at > inc/GSLBuilder.pm line 72. > > *After perusing the internet, I found that swiq was required for this > perl > file. I installed swig 2.0.7. After deleting Build I ran Build.PL > again, > receiving identical output from Build.pl and ./Build. Now I am stuck > and I > do not know how to continue.* > * > * > * > * > * > * > *Justin*


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.