Skip Menu |
 

This queue is for tickets about the XML-LibXML CPAN distribution.

Report information
The Basics
Id: 88060
Status: resolved
Priority: 0/
Queue: XML-LibXML

People
Owner: Nobody in particular
Requestors: gortan [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Unimportant
Broken in: 2.0103
Fixed in: (no value)



Subject: Use quoted version number in synopsis
Download (untitled) / with headers
text/plain 342b
The Synopsis for the Parser class states: use XML::LibXML 1.70; (see https://metacpan.org/module/XML::LibXML::Parser#SYNOPSIS) Using the unquoted version number in "use" results in an incorrect error message: XML::LibXML version 1.7 required--this is only version 1.64 at ... Therefore, please quote the version number in the example files.
Download (untitled) / with headers
text/plain 618b
Hi Philipp, On Fri Aug 23 09:59:02 2013, GORTAN wrote: Show quoted text
> The Synopsis for the Parser class states: > use XML::LibXML 1.70; > (see https://metacpan.org/module/XML::LibXML::Parser#SYNOPSIS) > > Using the unquoted version number in "use" results in an incorrect > error message: > XML::LibXML version 1.7 required--this is only version 1.64 at ... > > Therefore, please quote the version number in the example files.
thanks for the report. This was fixed in commit 88340f9789241bf6c8797ca9cfc4787b60908449 and will be uploaded to CPAN after I deal with some other pending issues. Resolving. Regards, -- Shlomi Fish


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.