Skip Menu |
 

This queue is for tickets about the Perl-MinimumVersion CPAN distribution.

Report information
The Basics
Id: 87884
Status: new
Priority: 0/
Queue: Perl-MinimumVersion

People
Owner: Nobody in particular
Requestors: ether [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: (no value)
Fixed in: (no value)



Subject: 'use mro' should not trigger a 5.10 dependency if MRO::Compat is also in use
Download (untitled) / with headers
text/plain 466b
MRO::Compat exists to make 'use mro' work on perls earlier than 5.010, so using these two things together should not result in a 5.10 dependency being triggered. example: t/cmop/Class_C3_compatibility.t in the Moose distribution. (If it would help to explicitly 'use MRO::Compat' in every file where 'use mro' is also used, we could do that - as currently the two usages are in different bits of code and it will probably be challenging to correlate them via PPI.)
Download (untitled) / with headers
text/plain 551b
On 2013-08-15 11:38:07, ETHER wrote: Show quoted text
> MRO::Compat exists to make 'use mro' work on perls earlier than 5.010, > so using these two things together should not result in a 5.10 > dependency being triggered. > > example: t/cmop/Class_C3_compatibility.t in the Moose distribution. > > (If it would help to explicitly 'use MRO::Compat' in every file where > 'use mro' is also used, we could do that - as currently the two usages > are in different bits of code and it will probably be challenging to > correlate them via PPI.)
Any ideas about this one?


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.