Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the Perl-Critic CPAN distribution.

Report information
The Basics
Id:
87822
Status:
open
Priority:
Low/Low
Queue:

People
Owner:
Nobody in particular
Requestors:
paul.a.liebert [...] hp.com
Cc:
AdminCc:

BugTracker
Severity:
(no value)
Broken in:
1.118
Fixed in:
(no value)



Subject: Miscellanea::RequireRcsKeywords is advertised, but missing.
The policy Miscellanea::RequireRcsKeywords was distributed in previous versions (before 1.118), but appears to be missing from 1.118. The policy is still advertised as part of the core distribution, and is not available as a standalone CPAN package, so it seems likely that it accidentally got dropped from 1.118. As a check I tested all the other advertised policies and found all of them to exist, only Miscellanea::RequireRcsKeywords was missing.
On Tue Aug 13 09:35:53 2013, paauull wrote: Hi Paul- Sorry for the slow reply. RequireRcsKeywords was intentionally removed the core. After much debate, it was decided that this rule is outside of Perl::Critic's purview. And since not everyone uses a version control system that supports RCS-style keywords, it just created a lot of false positives. RequireRcsKeywords will be shipped in the next release of Perl-Critic-More. I should have released that immediately after removing it from the core, but alas, I forgot. I'll try to do that as soon as possible. I will leave this ticket open until then. -Jeff
BTW, I don't see any mention of RequireRcsKeywords in the documentation since version 1.118. So if you do see it advertised as part of the Perl::Critic core, then please show me where.
Subject: RE: [rt.cpan.org #87822] Miscellanea::RequireRcsKeywords is advertised, but missing.
Date: Fri, 27 Sep 2013 15:35:29 +0000
To: "bug-Perl-Critic@rt.cpan.org" <bug-Perl-Critic@rt.cpan.org>
From: "Liebert, Paul A" <paul.a.liebert@hp.com>
Hi Jeffrey
Show quoted text
> Sorry for the slow reply.
No apologies! Thank you for making this work available. I understand about false positives. I simply pulled the RequireRcsKeywords out of a 1.17 distro and pasted it into our 1.18 installation. In your other message you asked where I found it to be "advertised". I believe I saw it in the rendered POD on one of the CPAN pages, but I am unable to find it now. Best Regards -Paul
Show quoted text
-----Original Message----- From: Jeffrey Ryan Thalhammer via RT [mailto:bug-Perl-Critic@rt.cpan.org] Sent: Thursday, September 26, 2013 9:44 PM To: Liebert, Paul A Subject: [rt.cpan.org #87822] Miscellanea::RequireRcsKeywords is advertised, but missing. <URL: https://rt.cpan.org/Ticket/Display.html?id=87822 > On Tue Aug 13 09:35:53 2013, paauull wrote: Hi Paul- Sorry for the slow reply. RequireRcsKeywords was intentionally removed the core. After much debate, it was decided that this rule is outside of Perl::Critic's purview. And since not everyone uses a version control system that supports RCS-style keywords, it just created a lot of false positives. RequireRcsKeywords will be shipped in the next release of Perl-Critic-More. I should have released that immediately after removing it from the core, but alas, I forgot. I'll try to do that as soon as possible. I will leave this ticket open until then. -Jeff


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.