Skip Menu |
 

This queue is for tickets about the CPAN-Mini-Inject CPAN distribution.

Report information
The Basics
Id: 87676
Status: new
Priority: 0/
Queue: CPAN-Mini-Inject

People
Owner: Nobody in particular
Requestors: FGA [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: HTTP::Server::Simple is a hard dependency
Download (untitled) / with headers
text/plain 501b
Hi, It seems that HTTP::Server::Simple is not supposed to be mandatory; according to a quick rgrep it's only ever required by tests and test helpers, and even those can be skipped if they detect that HTTP::Server::Simple is not available. The build script, however, specifies that HTTP::Server::Simple is a required dependency. This is not a huge problem, but at $work we only ever use CPAN-Mini-Inject to inject curated tarballs into our minicpan, so many of these dependencies are useless for us.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.