Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the CPAN-Reporter CPAN distribution.

Report information
The Basics
Id: 87497
Status: resolved
Priority: 0/
Queue: CPAN-Reporter

People
Owner: Nobody in particular
Requestors: dolmen [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: use CPAN::Meta::Check in CPAN::Reporter::PrereqCheck
Download (untitled) / with headers
text/plain 190b
Despites adding a few more dependencies, it would be safer to use CPAN::Meta::Check for the implementation of CPAN::Reporter::PrereqCheck. -- Olivier Mengué - http://perlresume.org/DOLMEN
Subject: Re: [rt.cpan.org #87497] use CPAN::Meta::Check in CPAN::Reporter::PrereqCheck
Date: Wed, 31 Jul 2013 16:54:03 -0400
To: bug-CPAN-Reporter <bug-CPAN-Reporter [...] rt.cpan.org>
From: David Golden <dagolden [...] cpan.org>
Download (untitled) / with headers
text/plain 829b
What do you mean by "safer"? On Wed, Jul 31, 2013 at 4:44 PM, Olivier Mengué via RT <bug-CPAN-Reporter@rt.cpan.org> wrote: Show quoted text
> Wed Jul 31 16:44:12 2013: Request 87497 was acted upon. > Transaction: Ticket created by DOLMEN > Queue: CPAN-Reporter > Subject: use CPAN::Meta::Check in CPAN::Reporter::PrereqCheck > Broken in: (no value) > Severity: (no value) > Owner: Nobody > Requestors: dolmen@cpan.org > Status: new > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=87497 > > > > Despites adding a few more dependencies, it would be safer to use CPAN::Meta::Check for the implementation of CPAN::Reporter::PrereqCheck. > > -- > Olivier Mengué - http://perlresume.org/DOLMEN
-- David Golden <dagolden@cpan.org> Take back your inbox! → http://www.bunchmail.com/ Twitter/IRC: @xdg
CC: Leon Timmermans <leont [...] cpan.org>
Subject: Re: [rt.cpan.org #87497] use CPAN::Meta::Check in CPAN::Reporter::PrereqCheck
Date: Wed, 31 Jul 2013 16:59:34 -0400
To: bug-CPAN-Reporter <bug-CPAN-Reporter [...] rt.cpan.org>
From: David Golden <dagolden [...] cpan.org>
Download (untitled) / with headers
text/plain 1.5k
Correction: CPAN::Meta::Check is *NOT* safer for the purposes of CPAN::Testers. C::R::PC ensures that the dependent module is *loadable*, not just that it has the right version. We have seen problems before where "Foo" has "use Bar 1.23" but Bar can't be loaded or has a too-old version, causing Foo to fail to compile. Even though Foo is *installed*, it is in a broken state and we MUST NOT send failure reports if a prerequisite is in a broken state. Unless I'm missing something, CPAN::Meta::Check is not sufficient as currently written for this purpose. David On Wed, Jul 31, 2013 at 4:54 PM, David Golden <dagolden@cpan.org> wrote: Show quoted text
> What do you mean by "safer"? > > On Wed, Jul 31, 2013 at 4:44 PM, Olivier Mengué via RT > <bug-CPAN-Reporter@rt.cpan.org> wrote:
>> Wed Jul 31 16:44:12 2013: Request 87497 was acted upon. >> Transaction: Ticket created by DOLMEN >> Queue: CPAN-Reporter >> Subject: use CPAN::Meta::Check in CPAN::Reporter::PrereqCheck >> Broken in: (no value) >> Severity: (no value) >> Owner: Nobody >> Requestors: dolmen@cpan.org >> Status: new >> Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=87497 > >> >> >> Despites adding a few more dependencies, it would be safer to use CPAN::Meta::Check for the implementation of CPAN::Reporter::PrereqCheck. >> >> -- >> Olivier Mengué - http://perlresume.org/DOLMEN
> > > > -- > David Golden <dagolden@cpan.org> > Take back your inbox! → http://www.bunchmail.com/ > Twitter/IRC: @xdg
-- David Golden <dagolden@cpan.org> Take back your inbox! → http://www.bunchmail.com/ Twitter/IRC: @xdg


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.