This queue is for tickets about the Dist-Zilla-Plugin-ReportVersions-Tiny CPAN distribution.

Maintainer(s)' notes

This module is deprecated!

This distribution has reached end-of-life now that better alternatives exist.

The recommended alternative is Dist::Zilla::Plugin::Test::ReportPrereqs.

Report information
The Basics
Id:
87364
Status:
open
Priority:
Low/Low

People
Owner:
Nobody in particular
Requestors:
ether [...] cpan.org
Cc:
AdminCc:

BugTracker
Severity:
Important
Broken in:
1.08
Fixed in:
(no value)



Subject: does not handle ranges in prereq entries
When I create a prereq entry like this: [Prereqs / DevelopConflicts] Dist::Zilla::Plugin::Conflicts = == 0.11 I get this out of 'dzil test': Invalid version format (non-numeric data) at /Users/ether/.perlbrew/libs/19.1@std/lib/perl5/Dist/Zilla/Plugin/ReportVersions/Tiny.pm line 103. Version ranges are legal: https://metacpan.org/module/CPAN::Meta::Spec#Version-Ranges You should be using CPAN::Meta::Requirements to examine the prereq data, rather than parsing directly... see the code in CPAN::Meta::Check for examples.
Incompatibility documented in the CAVEATS section in 1.09. -- Olivier Mengué - http://perlresume.org/DOLMEN
Le 2013-07-26 23:33:06, ETHER a écrit :
Show quoted text
> When I create a prereq entry like this: > > [Prereqs / DevelopConflicts] > Dist::Zilla::Plugin::Conflicts = == 0.11
TODO: steal code from Dist::Zilla::App::Command::listdeps::extract_dependencies -- Olivier Mengué - http://perlresume.org/DOLMEN
I don't plan to fix this.
Instead I'm deprecating this module and recommends Dist::Zilla::Plugin::Test::ReportPrereqs instead.

-- 
Olivier Mengué - http://perlresume.org/DOLMEN - https://gratipay.com/dolmen/


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.