Skip Menu |
 

This queue is for tickets about the HTML-WikiConverter CPAN distribution.

Report information
The Basics
Id: 87296
Status: open
Priority: 0/
Queue: HTML-WikiConverter

People
Owner: Nobody in particular
Requestors: lxp [...] cpan.org
ppisar [...] redhat.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 0.68
Fixed in: (no value)



Subject: t/pod-coverage.t fails on HTML::WikiConverter::WebApp
Download (untitled) / with headers
text/plain 426b
0.68 version fails t/pod-coverage.t test with Pod-Coverage-0.23: t/pod-coverage.t ...... 1/3 # Failed test 'Pod coverage on HTML::WikiConverter::WebApp' # at /usr/share/perl5/vendor_perl/Test/Pod/Coverage.pm line 126. # HTML::WikiConverter::WebApp: requiring 'HTML::WikiConverter::WebApp' failed # Looks like you failed 1 test of 3. t/pod-coverage.t ...... Dubious, test returned 1 (wstat 256, 0x100) Failed 1/3 subtests
From: fschlich [...] zedat.fu-berlin.de
Download (untitled) / with headers
text/plain 166b
POD coverage testing should only be done by authors. Please SKIP them unless AUTHOR_TESTING or RELEASE_TESTING is set in the environment (or put those tests into xt/)
I am also affected by this issue and am looking forward to a fix being released.
From: fschlich [...] cis.fu-berlin.de
Download (untitled) / with headers
text/plain 209b
The reason behind the test failure may actually be that HTML::WikiConverter::WebApp depends on modules not mentioned in META and thus potentially not installed: CGI::Application, Tie::IxHash, and XML::Writer
Subject: Re: [rt.cpan.org #87296] t/pod-coverage.t fails on HTML::WikiConverter::WebApp
Date: Tue, 7 Jul 2015 12:21:00 +0200
To: Florian via RT <bug-HTML-WikiConverter [...] rt.cpan.org>
From: Petr Pisar <ppisar [...] redhat.com>
Download (untitled) / with headers
text/plain 403b
On Fri, Jul 03, 2015 at 01:26:20PM -0400, Florian via RT wrote: Show quoted text
> The reason behind the test failure may actually be that > HTML::WikiConverter::WebApp depends on modules not mentioned in META and > thus potentially not installed: CGI::Application, Tie::IxHash, and > XML::Writer >
Indeed. The test is the only one which exhibits lib/HTML/WikiConverter/WebApp.pm which requires these modules. -- Petr


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.