Skip Menu |

This queue is for tickets about the WebService-Google-Reader CPAN distribution.

Report information
The Basics
Id: 87211
Status: resolved
Priority: 0/
Queue: WebService-Google-Reader

Owner: Nobody in particular
Requestors: rurban [...]

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)


Subject: [PATCH] wrong return precedence
Download (untitled) / with headers
text/plain 167b
Please announce end of live, and returns binds stronger than or, so the expressions after or are ignored. See
Subject: WebService-Google-Reader-0.21-returnor.patch
diff -bu WebService-Google-Reader-0.21-WtGY4H/lib/WebService/Google/ WebService-Google-Reader-0.21-WtGY4H/lib/WebService/Google/ --- WebService-Google-Reader-0.21-WtGY4H/lib/WebService/Google/ 2011-12-03 00:54:14.000000000 -0600 +++ WebService-Google-Reader-0.21-WtGY4H/lib/WebService/Google/ 2013-07-23 12:36:52.976898907 -0500 @@ -485,7 +485,7 @@ } sub _public { - return not $_[0]->username or not $_[0]->password; + return (not $_[0]->username or not $_[0]->password); } sub _encode_type {
Download (untitled) / with headers
text/plain 479b
On Tue Jul 23 13:39:41 2013, wrote: Show quoted text
> Please announce end of live, and
A few services claimed they would release apis compatible with google reader, so the module itself may not be end of life. I don't believe it's necessary to publish a separate release just to update the docs to state the obvious that the webservice has been discontinued. Show quoted text
> returns binds stronger than or, so the expressions after or are ignored.
Thanks, pushed a fix to the github repo.

This service is sponsored and maintained by Best Practical Solutions and runs on infrastructure.

Please report any issues with to