Skip Menu |
 

This queue is for tickets about the Catalyst-Plugin-C3 CPAN distribution.

Report information
The Basics
Id: 87090
Status: open
Priority: 0/
Queue: Catalyst-Plugin-C3

People
Owner: Nobody in particular
Requestors: ANDK [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 0.03
Fixed in: (no value)



Subject: Fails if Test::Kwalitee 1.09 is installed
Download (untitled) / with headers
text/plain 1.8k
As per subject, cpantesters infrastructure does not work very well at the moment, so I copy and paste the test result I just saw: # Failed test 'metayml_conforms_to_known_spec' # at /home/sand/src/perl/repoperls/installed-perls/perl/v5.16.3/a2da/lib/site_perl/5.16.3/Test/Kwalitee.pm line 72. # Error: META.yml does not conform to any recognised META.yml Spec. See 'metayml' in the dist error view for more info. # Details: 1.3 # Expected a list structure (author) [Validation: 1.3] # Remedy: Take a look at the META.yml Spec at http://module-build.sourceforge.net/META-spec-current.html and change your META.yml accordingly # Failed test 'has_better_auto_install' # at /home/sand/src/perl/repoperls/installed-perls/perl/v5.16.3/a2da/lib/site_perl/5.16.3/Test/Kwalitee.pm line 72. # Error: This package uses an old version of Module::Install. Versions of Module::Install prior to 0.89 Does not detect correcty that CPAN/CPANPLUS shell is used. # Remedy: Upgrade the bundled version of Module::Install to at least 0.89, but preferably to the most current release. Alternatively, you can switch to another build system / installer that does not suffer from this problem. (ExtUtils::MakeMaker, Module::Build both of which have their own set of problems.) # Failed test 'has_humanreadable_license' # at /home/sand/src/perl/repoperls/installed-perls/perl/v5.16.3/a2da/lib/site_perl/5.16.3/Test/Kwalitee.pm line 72. # Error: This distribution does not have a license defined in the documentation or in a file called LICENSE # Remedy: Add a section called 'LICENSE' to the documentation, or add a file named LICENSE to the distribution. # Looks like you failed 3 tests of 19. t/04kwalitee.t ..... Dubious, test returned 3 (wstat 768, 0x300) Failed 3/19 subtests It would probably be a good idea to make kwalitee tests author tests, they make user installs fail unnecessarily. HTH && Regards,
Download (untitled) / with headers
text/plain 266b
I wonder if this dist should even exist anymore... it is marked as highly experimental, and the last release was in 2007. Is Brandon Black still around? The only user (on the CPAN) is https://metacpan.org/release/Catalyst-Plugin-LeakTracker, last released in 2010.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.