Skip Menu |
 

This queue is for tickets about the Module-CPANTS-Analyse CPAN distribution.

Report information
The Basics
Id: 86952
Status: rejected
Priority: 0/
Queue: Module-CPANTS-Analyse

People
Owner: Nobody in particular
Requestors: ether [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Critical
Broken in: 0.87
Fixed in: (no value)



Subject: Next release must contain a conflicts/breaks entry for Test::Kwalitee 1.07 and lower
Download (untitled) / with headers
text/plain 903b
Test::Kwalitee 1.08 has been released, which resolves the issues described here: https://github.com/karenetheridge/Test-Kwalitee/pull/4 It is quite important that the next Module::CPANTS::Analyse release (where many metrics are removed or changed) contains a 'conflicts' entry in its metadata which indicates that Test::Kwalitee versions earlier than 1.08 is broken (that is, the entry should say: breaks => { "Test::Kwalitee => "1.07" }). This can be done with Dist::CheckConflicts, and inserting some metadata and code into your Build.PL. (This can also be done automatically with Dist::Zilla::Plugin::Conflicts -- see that plugin's code to see what code it inserts into Build.PL to check for conflicts at install time.) For more information about recording conflicts in metadata, see https://github.com/Perl-Toolchain-Gang/toolchain-site/blob/master/lancaster-consensus.md#improving-on-conflicts
Download (untitled) / with headers
text/plain 1.1k
On 2013-07-15 18:13:51, ETHER wrote: Show quoted text
> Test::Kwalitee 1.08 has been released, which resolves the issues > described here: > > https://github.com/karenetheridge/Test-Kwalitee/pull/4 > > It is quite important that the next Module::CPANTS::Analyse release > (where many metrics are removed or changed) contains a 'conflicts' > entry in its metadata which indicates that Test::Kwalitee versions > earlier than 1.08 is broken (that is, the entry should say: breaks => > { "Test::Kwalitee => "1.07" }). > > This can be done with Dist::CheckConflicts, and inserting some > metadata and code into your Build.PL. (This can also be done > automatically with Dist::Zilla::Plugin::Conflicts -- see that plugin's > code to see what code it inserts into Build.PL to check for conflicts > at install time.) > > For more information about recording conflicts in metadata, see > https://github.com/Perl-Toolchain-Gang/toolchain- > site/blob/master/lancaster-consensus.md#improving-on-conflicts
This is still very important to contain in the release!!!! I expect to see lots of new bug reports and complaints rolling in for Test::Kwalitee now that the underlying metrics have changed, and earlier TK does not handle this cleanly.
Download (untitled) / with headers
text/plain 470b
Please also include conflicts entries for Test::Kwalitee up to and including 1.11, as the changed metrics in 0.88 cause TK's own tests to fail (see https://rt.cpan.org/Ticket/Display.html?id=87518). In dist.ini you can add this metadata thusly: [Prereqs / RuntimeConflicts] Test::Kwalitee = <= 1.11 ...but also having a check in Makefile.PL (which Dist::Zilla::Plugin::Conflicts adds, or manually via Dist::CheckConflicts) would ensure greater visibility to the user.
Download (untitled) / with headers
text/plain 947b
Ah, finally got it. It's not Test::Kwalitee itself but tests for your versions of Test::Kwalitee that have been broken. Fix your fragile tests. Test::Kwalitee 1.01 (by chromatic) still works fine (and passes its tests) with the latest MCA. Test::Kwalitee 1.02-1.11 also work fine. Only their tests are broken due to the recent changes (and will be broken again if newer versions of MCA change something). On Fri Aug 02 04:15:23 2013, ETHER wrote: Show quoted text
> Please also include conflicts entries for Test::Kwalitee up to and > including 1.11, as the changed metrics in 0.88 cause TK's own tests to > fail (see https://rt.cpan.org/Ticket/Display.html?id=87518). > > In dist.ini you can add this metadata thusly: > > [Prereqs / RuntimeConflicts] > Test::Kwalitee = <= 1.11 > > ...but also having a check in Makefile.PL (which > Dist::Zilla::Plugin::Conflicts adds, or manually via > Dist::CheckConflicts) would ensure greater visibility to the user.
Subject: Re: [rt.cpan.org #86952] Next release must contain a conflicts/breaks entry for Test::Kwalitee 1.07 and lower
Date: Thu, 1 Aug 2013 13:20:41 -0700
To: Kenichi Ishigaki via RT <bug-Module-CPANTS-Analyse [...] rt.cpan.org>
From: Karen Etheridge <ether [...] cpan.org>
Download (untitled) / with headers
text/plain 1.2k
On Thu, Aug 01, 2013 at 04:03:48PM -0400, Kenichi Ishigaki via RT wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=86952 > > > Ah, finally got it. It's not Test::Kwalitee itself but tests for your versions of Test::Kwalitee that have been broken. > Test::Kwalitee 1.02-1.11 also work fine. Only their tests are broken due to the recent changes (and will be broken again if newer versions of MCA change something).
No, it's not just TK's tests that are failing. The issue that this ticket was originally addressing was indeed problems with the metrics that TK was expecting, vs. what MCA was actually providing (you opened a few PRs in github regarding those). Show quoted text
> Fix your fragile tests. Test::Kwalitee 1.01 (by chromatic) still works fine (and passes its tests) with the latest MCA.
v1.01 still passes its tests because it wasn't really testing anything :) I don't think it would pass its tests against MCA 0.88 because of the number of metrics that were added and removed (again what you referred to in the github PRs). I'll be further amending TK's tests to be more flexible as to what MCA provides, but it needs to make *some* assumptions regarding what metrics are available, so it can check that some metrics actually ran properly.
Download (untitled) / with headers
text/plain 1.9k
On Fri Aug 02 05:20:56 2013, ETHER wrote: Show quoted text
> On Thu, Aug 01, 2013 at 04:03:48PM -0400, Kenichi Ishigaki via RT > wrote:
> > <URL: https://rt.cpan.org/Ticket/Display.html?id=86952 > > > > > Ah, finally got it. It's not Test::Kwalitee itself but tests for your > > versions of Test::Kwalitee that have been broken. > > Test::Kwalitee 1.02-1.11 also work fine. Only their tests are broken > > due to the recent changes (and will be broken again if newer versions > > of MCA change something).
> > No, it's not just TK's tests that are failing. The issue that this > ticket > was originally addressing was indeed problems with the metrics that TK > was > expecting, vs. what MCA was actually providing (you opened a few PRs > in > github regarding those). >
> > Fix your fragile tests. Test::Kwalitee 1.01 (by chromatic) still > > works fine (and passes its tests) with the latest MCA.
> > v1.01 still passes its tests because it wasn't really testing anything > :) > I don't think it would pass its tests against MCA 0.88 because of the > number of metrics that were added and removed (again what you referred > to > in the github PRs). > > I'll be further amending TK's tests to be more flexible as to what MCA > provides, but it needs to make *some* assumptions regarding what > metrics > are available, so it can check that some metrics actually ran > properly.
TK shouldn't expect anything. Partly because Module::CPANTS::Kwalitee is pluggable, and partly because it is not TK who should decide which metric is core and which is extra etc. Anyway, I reject this ticket because MCA should continue to work with all the installed versions of TK. If MCA 0.88+ doesn't work with installed versions of TK, that's a bug and should be fixed. It's another story that some of the older versions of TK now fail their tests. That's their issues, and is now (hopefully) fixed in the latest version. If someone does need to install older versions of TK for whatever reasons, skip tests, and it should work.
Subject: Re: [rt.cpan.org #86952] Next release must contain a conflicts/breaks entry for Test::Kwalitee 1.07 and lower
Date: Sat, 3 Aug 2013 10:42:18 -0700
To: Kenichi Ishigaki via RT <bug-Module-CPANTS-Analyse [...] rt.cpan.org>
From: Karen Etheridge <ether [...] cpan.org>
Download (untitled) / with headers
text/plain 554b
On Sat, Aug 03, 2013 at 02:56:41AM -0400, Kenichi Ishigaki via RT wrote: Show quoted text
> It's another story that some of the older versions of TK now fail their tests. That's their issues, and is now (hopefully) fixed in the latest version. If someone does need to install older versions of TK for whatever reasons, skip tests, and it should work.
That's exactly what the [Conflicts] plugin is for -- to say "these versions of modules that use my dist are now broken"!!! It's helpful to tell users that - that when they upgrade MCA they need to upgrade TK as well.
Download (untitled) / with headers
text/plain 840b
No. You misunderstand what a conflict is for. This is not a conflict as newer MCA doesn't (and shouldn't) break installed TK. It's not related to the tests of older TK at all (as it's already installed anyway). On Sun Aug 04 02:42:30 2013, ETHER wrote: Show quoted text
> On Sat, Aug 03, 2013 at 02:56:41AM -0400, Kenichi Ishigaki via RT > wrote:
> > It's another story that some of the older versions of TK now fail > > their tests. That's their issues, and is now (hopefully) fixed in the > > latest version. If someone does need to install older versions of TK > > for whatever reasons, skip tests, and it should work.
> > That's exactly what the [Conflicts] plugin is for -- to say "these > versions > of modules that use my dist are now broken"!!! It's helpful to tell > users > that - that when they upgrade MCA they need to upgrade TK as well.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.