Skip Menu |
 

This queue is for tickets about the Tkx CPAN distribution.

Report information
The Basics
Id: 86681
Status: open
Priority: 0/
Queue: Tkx

People
Owner: Nobody in particular
Requestors: kw [...] codebykevin.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Tk update breaks Tkx
Date: Wed, 03 Jul 2013 13:05:40 -0400
To: bug-Tkx [...] rt.cpan.org
From: Kevin Walzer <kw [...] codebykevin.com>
Download (untitled) / with headers
text/plain 668b
I recently did a minor version update of my Tcl/Tk installation, from 8.5.12 to 8.5.13, and now Tkx refuses to load when I try to run a Perl script making use of the module. Here is the error output: attempt to provide package Tk 8.5.12 failed: package Tk 8.5.13 provided instead at hello.pl line 7. Tkx was, I believe, built against 8.5.12 on my system, but I do not believe that a minor version rev of my Tk installation should break Tkx. Any suggestions for a workaround or a fix? I am running Perl 5.16.1 on Mac OS X 10.7.5. Thank you, Kevin -- Kevin Walzer Code by Kevin/Mobile Code by Kevin http://www.codebykevin.com http://www.wtmobilesoftware.com
Tkx doesn't care what version of Tk you have available.  My guess is that you just need to keep the Tcl and Tk packages in sync.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.