Skip Menu |
 

This queue is for tickets about the Net-SSLeay CPAN distribution.

Report information
The Basics
Id: 86573
Status: resolved
Worked: 10 min
Priority: 0/
Queue: Net-SSLeay

People
Owner: Nobody in particular
Requestors: admin [...] vonitsanet.gr
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Issue with SSLeay, mismached API version.
Date: Sun, 30 Jun 2013 17:38:38 +0300
To: bug-Net-SSLeay [...] rt.cpan.org
From: "Dionisios K." <admin [...] vonitsanet.gr>
Download (untitled) / with headers
text/plain 519b
The issue is the following: [root@box ~]# perl -e 'use Net::SSLeay' Perl API version v5.16.0 of Net::SSLeay does not match v5.18.0 at /usr/lib/perl5/site_perl/Net/SSLeay.pm line 370. Compilation failed in require at -e line 1. BEGIN failed--compilation aborted at -e line 1. [root@box ~]# Package: perl-net-ssleay-1.55-1 Operating System: 3.9.8-1-ARCH #1 SMP PREEMPT Thu Jun 27 21:37:31 CEST 2013 x86_64 GNU/Linux Perl Version: This is perl 5, version 18, subversion 0 (v5.18.0) built for x86_64-linux-thread-multi
Subject: Re: [rt.cpan.org #86573] Issue with SSLeay, mismached API version.
Date: Mon, 01 Jul 2013 08:41:51 +1000
To: bug-Net-SSLeay [...] rt.cpan.org
From: Mike McCauley <mikem [...] airspayce.com>
Download (untitled) / with headers
text/plain 1.4k
Hello, It looks like you have 2 different Net-SSLeay installs and they are interfering with each other. I dont think this is a Net-SSLeay problem. Try deleting all existing installs of Net-SSLeay and then rebuilding it from scratch. Cheers. On Sunday, June 30, 2013 10:39:19 AM you wrote: Show quoted text
> Sun Jun 30 10:39:18 2013: Request 86573 was acted upon. > Transaction: Ticket created by admin@vonitsanet.gr > Queue: Net-SSLeay > Subject: Issue with SSLeay, mismached API version. > Broken in: (no value) > Severity: (no value) > Owner: Nobody > Requestors: admin@vonitsanet.gr > Status: new > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=86573 > > > > The issue is the following: > > [root@box ~]# perl -e 'use Net::SSLeay' > Perl API version v5.16.0 of Net::SSLeay does not match v5.18.0 at > /usr/lib/perl5/site_perl/Net/SSLeay.pm line 370. > Compilation failed in require at -e line 1. > BEGIN failed--compilation aborted at -e line 1. > [root@box ~]# > > Package: perl-net-ssleay-1.55-1 > > Operating System: 3.9.8-1-ARCH #1 SMP PREEMPT Thu Jun 27 21:37:31 CEST > 2013 x86_64 GNU/Linux > > Perl Version: This is perl 5, version 18, subversion 0 (v5.18.0) built > for x86_64-linux-thread-multi
-- Mike McCauley mikem@airspayce.com Airspayce Pty Ltd 9 Bulbul Place Currumbin Waters QLD 4223 Australia http://www.airspayce.com Phone +61 7 5598-7474 Fax +61 7 5598-7070
Subject: Re: [rt.cpan.org #86573] Issue with SSLeay, mismached API version.
Date: Mon, 1 Jul 2013 02:01:38 +0300
To: bug-Net-SSLeay [...] rt.cpan.org
From: "Dionisios K." <admin [...] vonitsanet.gr>
Download (untitled) / with headers
text/plain 1.8k
No I don't, its a pretty new setup and only this package is installed: [root@box ~]# pacman -Q perl-net-ssleay perl-net-ssleay 1.55-1 [root@box ~]# Is there any other way to detect if there is any other instance? Just in case.. On Mon, Jul 1, 2013 at 1:42 AM, Mike McCauley via RT <bug-Net-SSLeay@rt.cpan.org> wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=86573 > > > Hello, > > It looks like you have 2 different Net-SSLeay installs and they are interfering > with each other. > I dont think this is a Net-SSLeay problem. > > Try deleting all existing installs of Net-SSLeay and then rebuilding it from > scratch. > > Cheers. > > On Sunday, June 30, 2013 10:39:19 AM you wrote:
>> Sun Jun 30 10:39:18 2013: Request 86573 was acted upon. >> Transaction: Ticket created by admin@vonitsanet.gr >> Queue: Net-SSLeay >> Subject: Issue with SSLeay, mismached API version. >> Broken in: (no value) >> Severity: (no value) >> Owner: Nobody >> Requestors: admin@vonitsanet.gr >> Status: new >> Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=86573 > >> >> >> The issue is the following: >> >> [root@box ~]# perl -e 'use Net::SSLeay' >> Perl API version v5.16.0 of Net::SSLeay does not match v5.18.0 at >> /usr/lib/perl5/site_perl/Net/SSLeay.pm line 370. >> Compilation failed in require at -e line 1. >> BEGIN failed--compilation aborted at -e line 1. >> [root@box ~]# >> >> Package: perl-net-ssleay-1.55-1 >> >> Operating System: 3.9.8-1-ARCH #1 SMP PREEMPT Thu Jun 27 21:37:31 CEST >> 2013 x86_64 GNU/Linux >> >> Perl Version: This is perl 5, version 18, subversion 0 (v5.18.0) built >> for x86_64-linux-thread-multi
> -- > Mike McCauley mikem@airspayce.com > Airspayce Pty Ltd 9 Bulbul Place Currumbin Waters QLD 4223 Australia > http://www.airspayce.com > Phone +61 7 5598-7474 Fax +61 7 5598-7070 > >
Subject: Re: [rt.cpan.org #86573] Issue with SSLeay, mismached API version.
Date: Mon, 01 Jul 2013 10:46:46 +1000
To: bug-Net-SSLeay [...] rt.cpan.org
From: Mike McCauley <mikem [...] airspayce.com>
Download (untitled) / with headers
text/plain 2.6k
Hi, On Sunday, June 30, 2013 07:02:18 PM you wrote: Show quoted text
> Queue: Net-SSLeay > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=86573 > > > No I don't, its a pretty new setup and only this package is installed: > > [root@box ~]# pacman -Q perl-net-ssleay > perl-net-ssleay 1.55-1 > [root@box ~]#
OK, looks like pacman has installed Net-SSleay for perl 5.16, but you have perl 5.18 installed. You could find installed Net-SSLeays with somethinglike: find /usr/lib -name SSLeay.pm Cheers. Show quoted text
> > Is there any other way to detect if there is any other instance? Just in > case.. > > On Mon, Jul 1, 2013 at 1:42 AM, Mike McCauley via RT > > <bug-Net-SSLeay@rt.cpan.org> wrote:
> > <URL: https://rt.cpan.org/Ticket/Display.html?id=86573 > > > > > Hello, > > > > It looks like you have 2 different Net-SSLeay installs and they are > > interfering with each other. > > I dont think this is a Net-SSLeay problem. > > > > Try deleting all existing installs of Net-SSLeay and then rebuilding it > > from scratch. > > > > Cheers. > > > > On Sunday, June 30, 2013 10:39:19 AM you wrote:
> >> Sun Jun 30 10:39:18 2013: Request 86573 was acted upon. > >> Transaction: Ticket created by admin@vonitsanet.gr > >> > >> Queue: Net-SSLeay > >> > >> Subject: Issue with SSLeay, mismached API version. > >> > >> Broken in: (no value) > >> > >> Severity: (no value) > >> > >> Owner: Nobody > >> > >> Requestors: admin@vonitsanet.gr > >> > >> Status: new > >> > >> Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=86573 > > >> > >> The issue is the following: > >> > >> [root@box ~]# perl -e 'use Net::SSLeay' > >> Perl API version v5.16.0 of Net::SSLeay does not match v5.18.0 at > >> /usr/lib/perl5/site_perl/Net/SSLeay.pm line 370. > >> Compilation failed in require at -e line 1. > >> BEGIN failed--compilation aborted at -e line 1. > >> [root@box ~]# > >> > >> Package: perl-net-ssleay-1.55-1 > >> > >> Operating System: 3.9.8-1-ARCH #1 SMP PREEMPT Thu Jun 27 21:37:31 CEST > >> 2013 x86_64 GNU/Linux > >> > >> Perl Version: This is perl 5, version 18, subversion 0 (v5.18.0) built > >> for x86_64-linux-thread-multi
> > > > -- > > Mike McCauley mikem@airspayce.com > > Airspayce Pty Ltd 9 Bulbul Place Currumbin Waters QLD 4223 Australia > > http://www.airspayce.com > > Phone +61 7 5598-7474 Fax +61 7 5598-7070
-- Mike McCauley mikem@airspayce.com Airspayce Pty Ltd 9 Bulbul Place Currumbin Waters QLD 4223 Australia http://www.airspayce.com Phone +61 7 5598-7474 Fax +61 7 5598-7070
Subject: Re: [rt.cpan.org #86573] Issue with SSLeay, mismached API version.
Date: Mon, 1 Jul 2013 11:22:23 +0300
To: bug-Net-SSLeay [...] rt.cpan.org
From: "Dionisios K." <admin [...] vonitsanet.gr>
Download (untitled) / with headers
text/plain 3.1k
I think I found it. Arch came with perl and SSLeay preinstalled inside /usr/lib/perl5/site_perl. However, the perl-net-ssleay 1.55-1 got installed in /usr/lib/perl5/vendor_perl By removing related SSLeay entries inside site_perl, it worked just fine. Thanks for your help :D You can close this. On Mon, Jul 1, 2013 at 3:47 AM, Mike McCauley via RT <bug-Net-SSLeay@rt.cpan.org> wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=86573 > > > Hi, > > On Sunday, June 30, 2013 07:02:18 PM you wrote:
>> Queue: Net-SSLeay >> Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=86573 > >> >> No I don't, its a pretty new setup and only this package is installed: >> >> [root@box ~]# pacman -Q perl-net-ssleay >> perl-net-ssleay 1.55-1 >> [root@box ~]#
> > OK, looks like pacman has installed Net-SSleay for perl 5.16, but you have > perl 5.18 installed. > > You could find installed Net-SSLeays with somethinglike: > > find /usr/lib -name SSLeay.pm > > Cheers. > >
>> >> Is there any other way to detect if there is any other instance? Just in >> case.. >> >> On Mon, Jul 1, 2013 at 1:42 AM, Mike McCauley via RT >> >> <bug-Net-SSLeay@rt.cpan.org> wrote:
>> > <URL: https://rt.cpan.org/Ticket/Display.html?id=86573 > >> > >> > Hello, >> > >> > It looks like you have 2 different Net-SSLeay installs and they are >> > interfering with each other. >> > I dont think this is a Net-SSLeay problem. >> > >> > Try deleting all existing installs of Net-SSLeay and then rebuilding it >> > from scratch. >> > >> > Cheers. >> > >> > On Sunday, June 30, 2013 10:39:19 AM you wrote:
>> >> Sun Jun 30 10:39:18 2013: Request 86573 was acted upon. >> >> Transaction: Ticket created by admin@vonitsanet.gr >> >> >> >> Queue: Net-SSLeay >> >> >> >> Subject: Issue with SSLeay, mismached API version. >> >> >> >> Broken in: (no value) >> >> >> >> Severity: (no value) >> >> >> >> Owner: Nobody >> >> >> >> Requestors: admin@vonitsanet.gr >> >> >> >> Status: new >> >> >> >> Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=86573 > >> >> >> >> The issue is the following: >> >> >> >> [root@box ~]# perl -e 'use Net::SSLeay' >> >> Perl API version v5.16.0 of Net::SSLeay does not match v5.18.0 at >> >> /usr/lib/perl5/site_perl/Net/SSLeay.pm line 370. >> >> Compilation failed in require at -e line 1. >> >> BEGIN failed--compilation aborted at -e line 1. >> >> [root@box ~]# >> >> >> >> Package: perl-net-ssleay-1.55-1 >> >> >> >> Operating System: 3.9.8-1-ARCH #1 SMP PREEMPT Thu Jun 27 21:37:31 CEST >> >> 2013 x86_64 GNU/Linux >> >> >> >> Perl Version: This is perl 5, version 18, subversion 0 (v5.18.0) built >> >> for x86_64-linux-thread-multi
>> > >> > -- >> > Mike McCauley mikem@airspayce.com >> > Airspayce Pty Ltd 9 Bulbul Place Currumbin Waters QLD 4223 Australia >> > http://www.airspayce.com >> > Phone +61 7 5598-7474 Fax +61 7 5598-7070
> -- > Mike McCauley mikem@airspayce.com > Airspayce Pty Ltd 9 Bulbul Place Currumbin Waters QLD 4223 Australia > http://www.airspayce.com > Phone +61 7 5598-7474 Fax +61 7 5598-7070 > >


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.