Skip Menu |
 

This queue is for tickets about the autodie CPAN distribution.

Report information
The Basics
Id: 85801
Status: resolved
Priority: 0/
Queue: autodie

People
Owner: Nobody in particular
Requestors: ether [...] cpan.org
sisyphus [...] cpan.org
Cc: CHORNY [...] cpan.org
AdminCc:

Bug Information
Severity: Important
Broken in:
  • 2.19
  • 2.28
Fixed in: (no value)



Subject: why do people want to use autodie .... (sigh)
Download (untitled) / with headers
text/plain 1.1k
Hi Paul, Tonight, I've struck a module (PDL::GSL::Randist) that wants to use autodie (for reasons that are beyond my understanding). No real problems with that, except that I had to install autodie on 5.10 as apparently, at that time, autodie was not part of core ... so I installed 2.19. However, that seems to have not been good enough - because now I get the following diagnostic during the running of the PDL::GSL::Randist test suite: <quote> The autodie pragma uses an updated version of Fatal to do its heavy lifting. We seem to have loaded Fatal version 1.05, which is probably the version that came with your version of Perl. However autodie needs version 2.19, which would have come bundled with autodie. </quote> Well .. yeah, that appears to be right. But it's not much good if Fatal-2.19 gets installed into $INC[1], leaving the crappy old version of Fatal that's in $INC[0] to be loaded anyway. Then again, I guess it's not your fault that 5.10 puts perl/lib ahead of perl/site/lib in @INC for perl-5.10 on Windows. I should, of course, file a bug report at https://rt.cpan.org/Public/Dist/Display.html?Name=PDL-GSL-Randist but that link just errors out .... :-( Cheers, Rob
On Sun Jun 02 11:55:19 2013, SISYPHUS wrote: Show quoted text
> The autodie pragma uses an updated version of Fatal to do its > heavy lifting. We seem to have loaded Fatal version 1.05, which is > probably the version that came with your version of Perl. However > autodie needs version 2.19, which would have come bundled with > autodie.
Well, I'm glad to see autodie is doing its version checks correctly! Show quoted text
> Then again, I guess it's not your fault that 5.10 puts perl/lib ahead > of perl/site/lib in @INC for perl-5.10 on Windows.
Unfortunately, that's the gotcha. Anything that puts perl/lib first is not going to let you upgrade any core module, which affects all dual-life modules, not just autodie. I'm guessing that upgrading to a more recent Perl isn't an option? If so, then that solves the problem with autodie, and *may* solve the path issue. Otherwise, if I had encountered this, I'd consider setting the PERL5LIB environment variable to include perl/site/lib. Since it gets searched *before* the standard paths in @INC, it should get perl to load installed modules before those bundled with perl. Paul
Download (untitled) / with headers
text/plain 342b
On Sun Jun 02 22:27:02 2013, PJF wrote: Show quoted text
> Unfortunately, that's the gotcha. Anything that puts perl/lib first is > not going to let you upgrade any core module, which affects all dual- > life modules, not just autodie.
use INSTALLDIRS in Makefile.PL. INSTALLDIRS => ($] < 5.011) ? 'perl' : 'site', -- Alexandr Ciornii, http://chorny.net
Download (untitled) / with headers
text/plain 567b
On 2015-07-01 11:14:50, CHORNY wrote: Show quoted text
> On Sun Jun 02 22:27:02 2013, PJF wrote: >
> > Unfortunately, that's the gotcha. Anything that puts perl/lib first is > > not going to let you upgrade any core module, which affects all dual- > > life modules, not just autodie.
> > use INSTALLDIRS in Makefile.PL. > > INSTALLDIRS => ($] < 5.011) ? 'perl' : 'site', >
Please could this get fixed? It is causing problems on cpantesters smoker systems, as anything that requires and upgrades autodie is finding the wrong version of Fatal.pm first and then failing to install.
Download (untitled) / with headers
text/plain 731b
On 2015-07-06 08:36:47, ETHER wrote: Show quoted text
> On 2015-07-01 11:14:50, CHORNY wrote:
> > On Sun Jun 02 22:27:02 2013, PJF wrote: > >
> > > Unfortunately, that's the gotcha. Anything that puts perl/lib first > > > is > > > not going to let you upgrade any core module, which affects all > > > dual- > > > life modules, not just autodie.
> > > > use INSTALLDIRS in Makefile.PL. > > > > INSTALLDIRS => ($] < 5.011) ? 'perl' : 'site', > >
> > > Please could this get fixed? It is causing problems on cpantesters > smoker systems, as anything that requires and upgrades autodie is > finding the wrong version of Fatal.pm first and then failing to > install.
I've created a pull request for this fix at https://github.com/pjf/autodie/pull/68
Download (untitled) / with headers
text/plain 335b
On 2015-07-06 08:50:12, ETHER wrote: Show quoted text
> > I've created a pull request for this fix at > https://github.com/pjf/autodie/pull/68
Hi! I saw this got merged already. Would it be possible for this to be released soon? I think it will help resolve this issue: http://www.nntp.perl.org/group/perl.cpan.testers.discuss/2015/07/msg3663.html
Download (untitled) / with headers
text/plain 420b
On 2015-07-07 16:57:25, ETHER wrote: Show quoted text
> On 2015-07-06 08:50:12, ETHER wrote: >
> > > > I've created a pull request for this fix at > > https://github.com/pjf/autodie/pull/68
> > > Hi! I saw this got merged already. > > Would it be possible for this to be released soon? I think it will > help resolve this issue: > http://www.nntp.perl.org/group/perl.cpan.testers.discuss/2015/07/msg3663.html
Hi, was this released?
Subject: Re: [rt.cpan.org #85801] Autodie path issues on Perl 5.10.0 / Win32
Date: Tue, 21 Jul 2015 21:27:21 +0200
To: bug-autodie [...] rt.cpan.org
From: Niels Thykier <niels [...] thykier.net>
Download (untitled) / with headers
text/plain 681b
On 2015-07-21 21:20, Karen Etheridge via RT wrote: Show quoted text
> Queue: autodie > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=85801 > > > On 2015-07-07 16:57:25, ETHER wrote:
>> On 2015-07-06 08:50:12, ETHER wrote: >>
>>> >>> I've created a pull request for this fix at >>> https://github.com/pjf/autodie/pull/68
>> >> >> Hi! I saw this got merged already. >> >> Would it be possible for this to be released soon? I think it will >> help resolve this issue: >> http://www.nntp.perl.org/group/perl.cpan.testers.discuss/2015/07/msg3663.html
> > > Hi, > was this released? >
Hi Karen, Yes, this was released in 2.29 (kudos to PJF for uploading it). :) Thanks, ~Niels
Download (untitled) / with headers
text/plain 248b
On 2015-07-21 12:27:37, niels@thykier.net wrote: Show quoted text
> > Hi, > > was this released? > >
> > Hi Karen, > > Yes, this was released in 2.29 (kudos to PJF for uploading it). :) > > Thanks, > ~Niels
In that case could the ticket be marked resolved? :D
Oh! For some reason I thought it had been! :) Resolving with great thanks!


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.