Skip Menu |
 

This queue is for tickets about the IO-Socket-SSL CPAN distribution.

Report information
The Basics
Id: 85778
Status: resolved
Priority: 0/
Queue: IO-Socket-SSL

People
Owner: Nobody in particular
Requestors: jaryd [...] duckduckgo.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject:
Date: Fri, 31 May 2013 13:38:34 -0700
To: bug-IO-Socket-SSL [...] rt.cpan.org
From: Jaryd Malbin <jaryd [...] duckduckgo.com>
Download (untitled) / with headers
text/plain 511b
Since the update to IO::Socket::SSL on May 30, the module has not installed correctly on my vanilla Ubuntu 12.04 system on Amazon EC2. Error in build.log: Configuring IO-Socket-SSL-1.93 Running Makefile.PL minimal required version for OpenSSL is 0.9.8 at Makefile.PL line 55. OpenSSL is at version 1.0.1: Show quoted text
OpenSSL> version
OpenSSL 1.0.1 14 Mar 2012 Perl version: ubuntu@host $ perl -v This is perl 5, version 16, subversion 3 (v5.16.3) built for x86_64-linux-thread-multi Thanks for your help! Jaryd Malbin
Download (untitled) / with headers
text/plain 575b
Am Fr 31. Mai 2013, 16:39:21, jaryd@duckduckgo.com schrieb: Show quoted text
> Since the update to IO::Socket::SSL on May 30, the module has not installed > correctly on my vanilla Ubuntu 12.04 system on Amazon EC2. > > Error in build.log: > Configuring IO-Socket-SSL-1.93 > Running Makefile.PL > minimal required version for OpenSSL is 0.9.8 at Makefile.PL line 55. > > OpenSSL is at version 1.0.1:
> OpenSSL> version
> OpenSSL 1.0.1 14 Mar 2012
1.93 reported wrong version of openssl if the dependency Net::SSLeay was not installed. Now (1.94) it reports the missing dependency instead.
fixed in 1.94


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.