Skip Menu |
 

This queue is for tickets about the IO-Socket-SSL CPAN distribution.

Report information
The Basics
Id: 85768
Status: rejected
Priority: 0/
Queue: IO-Socket-SSL

People
Owner: Nobody in particular
Requestors: rbrown [...] brainboxdigital.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: openssl version
Date: Fri, 31 May 2013 14:40:16 +0100
To: <bug-IO-Socket-SSL [...] rt.cpan.org>
From: Robert Brown <rbrown [...] brainboxdigital.com>
Download (untitled) / with headers
text/plain 601b
When installing on a fresh build of CentOS6.4 this module now fails to install (worked yesterday), even tho OpenSSL 1.0.0-fips is installed... Unpacking IO-Socket-SSL-1.93.tar.gz Entering IO-Socket-SSL-1.93 Checking configure dependencies from META.yml Checking if you have ExtUtils::MakeMaker 0 ... Yes (6.63_02) Configuring IO-Socket-SSL-1.93 Running Makefile.PL minimal required version for OpenSSL is 0.9.8 at Makefile.PL line 55. -> N/A -> FAIL Configure failed for IO-Socket-SSL-1.93. See /home/s123/.cpanm/build.log for details. [s123@d63 ~]$ openssl version OpenSSL 1.0.0-fips 29 Mar 2010
Download (untitled) / with headers
text/plain 1.2k
Hi, I cannot reproduce your problem. I've downloaded a CentOS6.4 minimal iso and installed it into a VM, installed the necessary tools, installed Net-SSLeay 1.46 (CentOS6.4 comes with Net::SSLeay 1.35, which is no longer supported with IO::Socket::SSL) and had no problem to install IO::Socket::SSL 1.93 afterwards. What does perl -MNet::SSLeay -e 'printf "0x%08x\n", Net::SSLeay::OPENSSL_VERSION_NUMBER()' gives you? It should give you 0x10000003, if not then something is wrong with your installation of Net::SSLeay. Steffen Am Fr 31. Mai 2013, 09:40:44, rbrown@brainboxdigital.com schrieb: Show quoted text
> When installing on a fresh build of CentOS6.4 this module now fails to > install (worked yesterday), even tho OpenSSL 1.0.0-fips is installed... > > Unpacking IO-Socket-SSL-1.93.tar.gz > Entering IO-Socket-SSL-1.93 > Checking configure dependencies from META.yml > Checking if you have ExtUtils::MakeMaker 0 ... Yes (6.63_02) > Configuring IO-Socket-SSL-1.93 > Running Makefile.PL > minimal required version for OpenSSL is 0.9.8 at Makefile.PL line 55. > -> N/A > -> FAIL Configure failed for IO-Socket-SSL-1.93. See > /home/s123/.cpanm/build.log for details. > [s123@d63 ~]$ openssl version > OpenSSL 1.0.0-fips 29 Mar 2010 >
Subject: Re: [rt.cpan.org #85768] openssl version
Date: Fri, 31 May 2013 17:57:14 +0100
To: "<bug-IO-Socket-SSL [...] rt.cpan.org>" <bug-IO-Socket-SSL [...] rt.cpan.org>
From: Rob Brown <rbrown [...] brainboxdigital.com>
Download (untitled) / with headers
text/plain 1.5k
I'll check that on a new build, had to go with previous version to get running. If it makes a difference, it's 64bit, minimal iso, Perlbrew 5.16.0 Sent from my iPhone On 31 May 2013, at 16:30, Steffen Ullrich via RT <bug-IO-Socket-SSL@rt.cpan.org> wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=85768 > > > Hi, > > I cannot reproduce your problem. > I've downloaded a CentOS6.4 minimal iso and installed it into a VM, installed the necessary tools, installed Net-SSLeay 1.46 (CentOS6.4 comes with Net::SSLeay 1.35, which is no longer supported with > IO::Socket::SSL) and had no problem to install IO::Socket::SSL 1.93 afterwards. > > What does > perl -MNet::SSLeay -e 'printf "0x%08x\n", Net::SSLeay::OPENSSL_VERSION_NUMBER()' > gives you? > > It should give you 0x10000003, if not then something is wrong with your installation of Net::SSLeay. > > Steffen > > > Am Fr 31. Mai 2013, 09:40:44, rbrown@brainboxdigital.com schrieb:
>> When installing on a fresh build of CentOS6.4 this module now fails to >> install (worked yesterday), even tho OpenSSL 1.0.0-fips is installed... >> >> Unpacking IO-Socket-SSL-1.93.tar.gz >> Entering IO-Socket-SSL-1.93 >> Checking configure dependencies from META.yml >> Checking if you have ExtUtils::MakeMaker 0 ... Yes (6.63_02) >> Configuring IO-Socket-SSL-1.93 >> Running Makefile.PL >> minimal required version for OpenSSL is 0.9.8 at Makefile.PL line 55. >> -> N/A >> -> FAIL Configure failed for IO-Socket-SSL-1.93. See >> /home/s123/.cpanm/build.log for details. >> [s123@d63 ~]$ openssl version >> OpenSSL 1.0.0-fips 29 Mar 2010 >>
> > >


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.