Skip Menu |
 

This queue is for tickets about the IO-Socket-SSL CPAN distribution.

Report information
The Basics
Id: 85739
Status: resolved
Priority: 0/
Queue: IO-Socket-SSL

People
Owner: Nobody in particular
Requestors: paul [...] city-fan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 1.91
Fixed in: (no value)



Subject: ExtUtils::MakeMaker version requirement should be 6.57_02
Download (untitled) / with headers
text/plain 2.5k
Makefile.PL has a version requirement of ExtUtils::MakeMaker 6.46 but support for the use of an arrayref for AUTHOR as used in IO::Socket::SSL 1.91 was only introduced in ExtUtils::MakeMaker version 6.57_02. As there were AUTHOR-related bugs fixed after that point, it might be wise to require version 6.58. Using an older version results in this: $ perl Makefile.PL INSTALLDIRS=vendor WARNING: AUTHOR takes a string/number not a ARRAY reference. Please inform the author. Checking if your kit is complete... Looks good only nested arrays of non-refs are supported at /usr/share/perl5/ExtUtils/MakeMaker.pm line 684 That was with ExtUtils::MakeMaker version 6.56. The version requirement should also be specified in META.yml. I also came across an issue with ancient versions of openssl: $ make test PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t t/01loadmodule.............ok t/02settings...............ok t/acceptSSL-timeout........ok t/auto_verify_hostname.....ok t/cert_no_file.............ok t/compatibility............ok t/connectSSL-timeout.......ok t/core.....................ok t/dhe......................ok t/io-socket-inet6..........ok t/io-socket-ip.............skipped all skipped: no IO::Socket::IP 0.20 available t/memleak_bad_handshake....ok t/mitm.....................failed to add entry for commonName at /builddir/build/BUILD/IO-Socket-SSL-1.91/blib/lib/IO/Socket/SSL/Intercept.pm line 88 FAILED tests 6-8 Failed 3/8 tests, 62.50% okay t/nonblock.................ok t/npn......................skipped all skipped: NPN not available in Net::SSLeay t/readline.................ok t/sessions.................ok t/signal-readline..........ok t/sni......................skipped all skipped: because no server side SNI support - openssl/Net::SSleay too old t/start-stopssl............ok t/startssl-failed..........ok t/startssl.................ok t/sysread_write............ok t/verify_hostname..........ok Failed 1/24 test scripts, 95.83% okay. 3/327 subtests failed, 99.08% okay. Failed Test Stat Wstat Total Fail Failed List of Failed ------------------------------------------------------------------------------- t/mitm.t 8 3 37.50% 6-8 3 tests skipped. make: *** [test_dynamic] Error 255 That was with openssl 0.9.7f. The oldest version I have that works is 0.9.8a, so whatever problem that caused that failure was fixed somewhere between those two versions. I suspect there aren't many people running a fairly modern Net::SSLeay and old openssl though.
Download (untitled) / with headers
text/plain 548b
Show quoted text
> ... > That was with ExtUtils::MakeMaker version 6.56.
Thanks for reporting the problem. With 1.93 I changed the AUTHOR back to being a string so that users with perl5.8.9 don't need to upgrade ExtUtils::MakeMaker just to use IO::Socket::SSL. Show quoted text
> > I also came across an issue with ancient versions of openssl:
With 1.93 I made openssl>=0.9.8 a hard requirement and could this way also remove some work arounds for older versions. Because last 0.9.7 was released 6 years ago I think this requirement is reasonable. Thanks for testing, Steffen


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.