Skip Menu |
 

This queue is for tickets about the File-Listing CPAN distribution.

Report information
The Basics
Id: 85100
Status: new
Priority: 0/
Queue: File-Listing

People
Owner: Nobody in particular
Requestors: mjp [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Unimportant
Broken in: 6.04
Fixed in: (no value)



Subject: Document BUILD_REQUIRES, PREREQ_PM
Download (untitled) / with headers
text/plain 929b
6.04's Makefile.PL does not enumerate its dependencies in Makefile.PL, making packaging more difficult for the system integrator, who cannot simply (and automatically) inspect the "make dist"d META.yml to figure out what is needed. Patch: diff -up File-Listing-6.04/Makefile.PL.orig File-Listing-6.04/Makefile.PL --- File-Listing-6.04/Makefile.PL.orig 2012-02-15 15:32:26.000000000 -0600 +++ File-Listing-6.04/Makefile.PL 2013-05-03 16:50:20.937047453 -0500 @@ -11,8 +11,15 @@ WriteMakefile( LICENSE => "perl", MIN_PERL_VERSION => 5.006002, PREREQ_PM => { + 'Carp' => 0, 'HTTP::Date' => 6, }, + ( eval { ExtUtils::MakeMaker->VERSION(6.5501) } ? ( + BUILD_REQUIRES => { 'ExtUtils::MakeMaker' => 0, + 'Test::More' => 0 }, + ) + : () + ), META_MERGE => { resources => { repository => 'http://github.com/gisle/libwww-perl/tree/File-Listing/master',
Sorry, 'Exporter' and 'Time::Local' are also PREREQ_PM. -Mike On Mon May 06 16:30:29 2013, MJP wrote: Show quoted text
> 6.04's Makefile.PL does not enumerate its dependencies in Makefile.PL, > making packaging more difficult for the system integrator, who > cannot simply (and automatically) inspect the "make dist"d META.yml > to figure out what is needed. > > Patch: > > diff -up File-Listing-6.04/Makefile.PL.orig File-Listing- > 6.04/Makefile.PL > --- File-Listing-6.04/Makefile.PL.orig 2012-02-15 15:32:26.000000000 > -0600 > +++ File-Listing-6.04/Makefile.PL 2013-05-03 16:50:20.937047453 -0500 > @@ -11,8 +11,15 @@ WriteMakefile( > LICENSE => "perl", > MIN_PERL_VERSION => 5.006002, > PREREQ_PM => { > + 'Carp' => 0, > 'HTTP::Date' => 6, > }, > + ( eval { ExtUtils::MakeMaker->VERSION(6.5501) } ? ( > + BUILD_REQUIRES => { 'ExtUtils::MakeMaker' => 0, > + 'Test::More' => 0 }, > + ) > + : () > + ), > META_MERGE => { > resources => { > repository => 'http://github.com/gisle/libwww- > perl/tree/File-Listing/master',


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.