Skip Menu |
 

This queue is for tickets about the Module-Build CPAN distribution.

Report information
The Basics
Id: 84648
Status: resolved
Priority: 0/
Queue: Module-Build

People
Owner: Nobody in particular
Requestors: davidnmfarrell [...] gmail.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Version bug with 4.004
Date: Mon, 15 Apr 2013 15:29:03 -0400
To: bug-Module-Build [...] rt.cpan.org
From: David Farrell <davidnmfarrell [...] gmail.com>
Download (untitled) / with headers
text/plain 3.8k
Hi, I'm running a vanilla install of 5.16.3 via perlbrew on fedora 17. When installing Module::Build 0.4004 via cpan, it installs fine, but the version remains at 0.391. Output is below. Many thanks, David ~ cpan Module::Build Reading '/home/sillymoose/.cpan/Metadata' Database was generated on Mon, 15 Apr 2013 01:41:03 GMT Running install for module 'Module::Build' Running make for L/LE/LEONT/Module-Build-0.4004.tar.gz Checksum for /home/sillymoose/.cpan/sources/authors/id/L/LE/LEONT/Module-Build-0.4004.tar.gz ok CPAN.pm: Building L/LE/LEONT/Module-Build-0.4004.tar.gz Created MYMETA.yml and MYMETA.json Creating new 'Build' script for 'Module-Build' version '0.4004' Building Module-Build LEONT/Module-Build-0.4004.tar.gz ./Build -- OK 'YAML' not installed, will not store persistent state Running Build test t/00-compile.t ................. ok t/PL_files.t ................... ok t/actions/installdeps.t ........ ok t/actions/manifest_skip.t ...... ok t/add_property.t ............... ok t/basic.t ...................... ok t/bundle_inc.t ................. skipped: $ENV{MB_TEST_EXPERIMENTAL} is not set t/compat.t ..................... ok t/compat/exit.t ................ ok t/debug.t ...................... ok t/destinations.t ............... ok t/ext.t ........................ ok t/extend.t ..................... ok t/files.t ...................... ok t/help.t ....................... ok t/install.t .................... ok t/install_extra_target.t ....... ok t/manifypods.t ................. ok t/metadata.t ................... ok t/metadata2.t .................. ok t/mymeta.t ..................... ok t/new_from_context.t ........... ok t/notes.t ...................... ok t/par.t ........................ skipped: PAR::Dist 0.17 or up not installed to check .par's. t/parents.t .................... ok t/perl_mb_opt.t ................ ok t/pod_parser.t ................. ok t/ppm.t ........................ ok t/properties/dist_suffix.t ..... ok t/properties/license.t ......... ok t/properties/module_name.t ..... ok t/properties/needs_compiler.t .. ok t/properties/release_status.t .. ok t/properties/requires.t ........ ok t/properties/share_dir.t ....... ok t/resume.t ..................... ok t/runthrough.t ................. ok t/sample.t ..................... ok t/script_dist.t ................ ok t/signature.t .................. ok t/test_file_exts.t ............. ok t/test_type.t .................. ok t/test_types.t ................. ok t/tilde.t ...................... ok t/use_tap_harness.t ............ ok t/versions.t ................... ok t/write_default_maniskip.t ..... ok t/xs.t ......................... ok All tests successful. Files=48, Tests=1155, 59 wallclock secs ( 0.54 usr 0.11 sys + 47.29 cusr 10.15 csys = 58.09 CPU) Result: PASS LEONT/Module-Build-0.4004.tar.gz ./Build test -- OK Running Build install Building Module-Build LEONT/Module-Build-0.4004.tar.gz ./Build install -- OK ~ cpan -D Module::Build Reading '/home/sillymoose/.cpan/Metadata' Database was generated on Mon, 15 Apr 2013 01:41:03 GMT Module::Build ------------------------------------------------------------------------- Build, test, and install Perl modules L/LE/LEONT/Module-Build-0.4004.tar.gz /home/sillymoose/perl5/perlbrew/perls/perl-5.16.3/lib/5.16.3/Module/Build.pm Installed: 0.39_01 CPAN: 0.4004 Not up to date Ken Williams (KWILLIAMS) kwilliams@cpan.org ~ perldoc -m Module::Build | grep VERSION use vars qw($VERSION @ISA); $VERSION = '0.39_01'; $VERSION = eval $VERSION; ~ which perl ~/perl5/perlbrew/perls/perl-5.16.3/bin/perl ~ which cpan ~/perl5/perlbrew/perls/perl-5.16.3/bin/cpan ~ which perldoc ~/perl5/perlbrew/perls/perl-5.16.3/bin/perldoc
Subject: Re: [rt.cpan.org #84648] AutoReply: Version bug with 4.004
Date: Mon, 15 Apr 2013 15:40:15 -0400
To: bug-Module-Build [...] rt.cpan.org
From: David Farrell <davidnmfarrell [...] gmail.com>
Download (untitled) / with headers
text/plain 4.9k
Quick update: manual download and build/install worked fine. On Mon, 2013-04-15 at 15:29 -0400, Bugs in Module-Build via RT wrote: Show quoted text
> Greetings, > > This message has been automatically generated in response to the > creation of a trouble ticket regarding: > "Version bug with 4.004", > a summary of which appears below. > > There is no need to reply to this message right now. Your ticket has been > assigned an ID of [rt.cpan.org #84648]. Your ticket is accessible > on the web at: > > https://rt.cpan.org/Ticket/Display.html?id=84648 > > Please include the string: > > [rt.cpan.org #84648] > > in the subject line of all future correspondence about this issue. To do so, > you may reply to this message. > > Thank you, > bug-Module-Build@rt.cpan.org > > ------------------------------------------------------------------------- > Hi, > > I'm running a vanilla install of 5.16.3 via perlbrew on fedora 17. When > installing Module::Build 0.4004 via cpan, it installs fine, but the > version remains at 0.391. > > Output is below. > > Many thanks, > > David > > > ~ cpan Module::Build > Reading '/home/sillymoose/.cpan/Metadata' > Database was generated on Mon, 15 Apr 2013 01:41:03 GMT > Running install for module 'Module::Build' > Running make for L/LE/LEONT/Module-Build-0.4004.tar.gz > Checksum > for /home/sillymoose/.cpan/sources/authors/id/L/LE/LEONT/Module-Build-0.4004.tar.gz ok > > CPAN.pm: Building L/LE/LEONT/Module-Build-0.4004.tar.gz > > Created MYMETA.yml and MYMETA.json > Creating new 'Build' script for 'Module-Build' version '0.4004' > Building Module-Build > LEONT/Module-Build-0.4004.tar.gz > ./Build -- OK > 'YAML' not installed, will not store persistent state > Running Build test > t/00-compile.t ................. ok > t/PL_files.t ................... ok > t/actions/installdeps.t ........ ok > t/actions/manifest_skip.t ...... ok > t/add_property.t ............... ok > t/basic.t ...................... ok > t/bundle_inc.t ................. skipped: $ENV{MB_TEST_EXPERIMENTAL} is > not set > t/compat.t ..................... ok > t/compat/exit.t ................ ok > t/debug.t ...................... ok > t/destinations.t ............... ok > t/ext.t ........................ ok > t/extend.t ..................... ok > t/files.t ...................... ok > t/help.t ....................... ok > t/install.t .................... ok > t/install_extra_target.t ....... ok > t/manifypods.t ................. ok > t/metadata.t ................... ok > t/metadata2.t .................. ok > t/mymeta.t ..................... ok > t/new_from_context.t ........... ok > t/notes.t ...................... ok > t/par.t ........................ skipped: PAR::Dist 0.17 or up not > installed to check .par's. > t/parents.t .................... ok > t/perl_mb_opt.t ................ ok > t/pod_parser.t ................. ok > t/ppm.t ........................ ok > t/properties/dist_suffix.t ..... ok > t/properties/license.t ......... ok > t/properties/module_name.t ..... ok > t/properties/needs_compiler.t .. ok > t/properties/release_status.t .. ok > t/properties/requires.t ........ ok > t/properties/share_dir.t ....... ok > t/resume.t ..................... ok > t/runthrough.t ................. ok > t/sample.t ..................... ok > t/script_dist.t ................ ok > t/signature.t .................. ok > t/test_file_exts.t ............. ok > t/test_type.t .................. ok > t/test_types.t ................. ok > t/tilde.t ...................... ok > t/use_tap_harness.t ............ ok > t/versions.t ................... ok > t/write_default_maniskip.t ..... ok > t/xs.t ......................... ok > All tests successful. > Files=48, Tests=1155, 59 wallclock secs ( 0.54 usr 0.11 sys + 47.29 > cusr 10.15 csys = 58.09 CPU) > Result: PASS > LEONT/Module-Build-0.4004.tar.gz > ./Build test -- OK > Running Build install > Building Module-Build > LEONT/Module-Build-0.4004.tar.gz > ./Build install -- OK > ~ cpan -D Module::Build > Reading '/home/sillymoose/.cpan/Metadata' > Database was generated on Mon, 15 Apr 2013 01:41:03 GMT > Module::Build > ------------------------------------------------------------------------- > Build, test, and install Perl modules > L/LE/LEONT/Module-Build-0.4004.tar.gz > /home/sillymoose/perl5/perlbrew/perls/perl-5.16.3/lib/5.16.3/Module/Build.pm > Installed: 0.39_01 > CPAN: 0.4004 Not up to date > Ken Williams (KWILLIAMS) > kwilliams@cpan.org > > ~ perldoc -m Module::Build | grep VERSION > use vars qw($VERSION @ISA); > $VERSION = '0.39_01'; > $VERSION = eval $VERSION; > ~ which perl > ~/perl5/perlbrew/perls/perl-5.16.3/bin/perl > ~ which cpan > ~/perl5/perlbrew/perls/perl-5.16.3/bin/cpan > ~ which perldoc > ~/perl5/perlbrew/perls/perl-5.16.3/bin/perldoc > > >
Download (untitled) / with headers
text/plain 163b
I'm guessing cpan installed M::B in a different location than you expected it to. Maybe you can poke around & see whether there's a 0.4004 in a rogue spot? -Ken
Subject: Re: [rt.cpan.org #84648] Version bug with 4.004
Date: Sat, 20 Apr 2013 11:34:20 -0400
To: bug-Module-Build [...] rt.cpan.org
From: David Farrell <davidnmfarrell [...] gmail.com>
Download (untitled) / with headers
text/plain 1.1k
Hi, Thanks for your reply. I did the following and checked the versions of the files. find /home/sillymoose/perl5 -wholename '*Module/Build.pm' /home/sillymoose/perl5/perlbrew/build/perl-5.16.3/cpan/Module-Build/lib/Module/Build.pm /home/sillymoose/perl5/perlbrew/build/perl-5.16.3/lib/Module/Build.pm /home/sillymoose/perl5/perlbrew/perls/perl-5.16.3/lib/site_perl/5.16.3/Module/Build.pm /home/sillymoose/perl5/perlbrew/perls/perl-5.16.3/lib/5.16.3/Module/Build.pm What I found was that site_perl/Module/Build.pm is version .4004, but the others are version .3901. The issue I experience is a loop when trying to install any Perl module that requires M::B version 0.4004. As the M::B install 'succeeds', CPAN then checks for missing dependencies, finds M:B is only at version 0.3901, and proceeds to install it again, but never acknowledges that 0.4004 is installed. On 19 April 2013 11:57, Ken Williams via RT <bug-Module-Build@rt.cpan.org>wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=84648 > > > I'm guessing cpan installed M::B in a different location than you expected > it to. Maybe you can poke around & see whether there's a 0.4004 in a rogue > spot? > > -Ken >
Download (untitled) / with headers
text/plain 141b
Maybe this is a perlbrew thing? I haven't used it much myself, but it doesn't seem good that there end up being multiple versions installed.
Subject: Re: [rt.cpan.org #84648] Version bug with 4.004
Date: Sun, 21 Apr 2013 17:37:56 +0200
To: bug-Module-Build [...] rt.cpan.org
From: Leon Timmermans <fawaka [...] gmail.com>
Download (untitled) / with headers
text/plain 882b
On Sat, Apr 20, 2013 at 5:34 PM, David Farrell via RT < bug-Module-Build@rt.cpan.org> wrote: Show quoted text
> > /home/sillymoose/perl5/perlbrew/perls/perl-5.16.3/lib/site_perl/5.16.3/Module/Build.pm > > > /home/sillymoose/perl5/perlbrew/perls/perl-5.16.3/lib/5.16.3/Module/Build.pm > > What I found was that site_perl/Module/Build.pm is version .4004, but the > others are version .3901. >
Which is exactly what I'd expect. Show quoted text
> The issue I experience is a loop when trying to install any Perl module > that requires M::B version 0.4004.
As the M::B install 'succeeds', CPAN Show quoted text
> then checks for missing dependencies, finds M:B is only at version 0.3901, > and proceeds to install it again, but never acknowledges that 0.4004 is > installed. >
That shouldn't happen, and I can't reproduce it. Are you sure M::B is the only module having this problem? it sounds to me like a settings issue. Leon
Subject: Re: [rt.cpan.org #84648] Version bug with 4.004
Date: Sun, 21 Apr 2013 12:04:57 -0400
To: bug-Module-Build [...] rt.cpan.org
From: David Farrell <davidnmfarrell [...] gmail.com>
Download (untitled) / with headers
text/plain 1.2k
Hey Guys, Thanks for the pointer about settings - I found a rogue Perl env variable in my .bashrc. Once I unset it CPAN immediately recognised that 0.4004 was installed. This 'issue' can be closed. Thanks again David On 21 April 2013 11:38, Leon Timmermans via RT <bug-Module-Build@rt.cpan.org Show quoted text
> wrote:
Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=84648 > > > On Sat, Apr 20, 2013 at 5:34 PM, David Farrell via RT < > bug-Module-Build@rt.cpan.org> wrote: >
> > > >
> /home/sillymoose/perl5/perlbrew/perls/perl-5.16.3/lib/site_perl/5.16.3/Module/Build.pm
> > > > > >
> /home/sillymoose/perl5/perlbrew/perls/perl-5.16.3/lib/5.16.3/Module/Build.pm
> > > > What I found was that site_perl/Module/Build.pm is version .4004, but the > > others are version .3901. > >
> > Which is exactly what I'd expect. > >
> > The issue I experience is a loop when trying to install any Perl module > > that requires M::B version 0.4004.
> > > As the M::B install 'succeeds', CPAN
> > then checks for missing dependencies, finds M:B is only at version
> 0.3901,
> > and proceeds to install it again, but never acknowledges that 0.4004 is > > installed. > >
> > That shouldn't happen, and I can't reproduce it. Are you sure M::B is the > only module having this problem? it sounds to me like a settings issue. > > Leon > >


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.