This queue is for tickets about the JavaScript-V8 CPAN distribution.

Report information
The Basics
Id:
84478
Status:
open
Priority:
Low/Low
Queue:

People
Owner:
Nobody in particular
Requestors:
paul [...] seamons.com
Cc:
AdminCc:

BugTracker
Severity:
Important
Broken in:
0.07
Fixed in:
(no value)



I cannot get 0.07 to build a functional JavaScript::V8 on kubuntu. The build succeeds, but subsequent attempts at use generate this error: paul@paul-laptop:~$ perl -e 'use JavaScript::V8' Not a CODE reference at /usr/share/perl/5.14/XSLoader.pm line 95. END failed--call queue aborted at /usr/local/lib/perl/5.14.2/JavaScript/V8.pm line 95. Compilation failed in require at -e line 1. BEGIN failed--compilation aborted at -e line 1. I did go through a git-bisect on the tree and it appeared to have been introduced when the nice new object features were added in. I am interested what OSes this build is currently working for other people on. I have a 1.5 year old unreleased module based on JavaScript::V8 that I'd love to finally post, but I want to test it against the head 0.07 release. For note: paul@paul-laptop:~$ perl -v This is perl 5, version 14, subversion 2 (v5.14.2) built for i686-linux-gnu-thread-multi-64int
Is this still a problem that offers any hope of being solved, or can it be closed?


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.