This queue is for tickets about the Module-Install CPAN distribution.

Report information
The Basics
Id:
84272
Status:
new
Priority:
Low/Low

People
Owner:
Nobody in particular
Requestors:
dolmen [...] cpan.org
miyagawa [...] gmail.com
Cc:
AdminCc:

BugTracker
Severity:
Important
Broken in:
(no value)
Fixed in:
(no value)



Subject: Translate test_requires() to TEST_REQUIRES
Date: Thu, 28 Mar 2013 13:45:49 -0700
To: bug-Module-Install@rt.cpan.org
From: Tatsuhiko Miyagawa <miyagawa@gmail.com>
Since 6.63_03 ExtUtils::MakeMaker accepts TEST_REQUIRES parameters to dump into META spec 2.0. It would be nice if Module::Install can be upgraded to translate test_requires() into that, as the documentation has been written in the first place. This is my first stab to implement that, while some of the tests are failing because the test was expecting it to be merged with build_requires, or include() logic might have to be updated to reflect the change as well. Which I haven't got around to it yet. https://gist.github.com/miyagawa/5261788 Would be nice if someone can take a look and continue over to make it happen. -- Tatsuhiko Miyagawa


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.