Skip Menu |
 

This queue is for tickets about the Module-Build CPAN distribution.

Report information
The Basics
Id: 84271
Status: resolved
Priority: 0/
Queue: Module-Build

People
Owner: Nobody in particular
Requestors: listposter [...] gmail.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in:
  • 0.39_02
  • 0.40
  • 0.4001
  • 0.4002
  • 0.4003
Fixed in: (no value)



Subject: t/script_dist.t failure on CentOS 6.4 x64
Download (untitled) / with headers
text/plain 618b
I ran into this while trying to install the latest cpanm. I have perl-Module-Build-0.3500-130.el6_4.x86_64 installed, but > 0.36 is required. After encountering this error I tried 0.39_02, 0.40, 0.4001, and 0.4002 from source as well, and all had the same error. Perl: perl-5.10.1-130.el6_4.x86_64 --- # Failed test at t/script_dist.t line 77. # Structures begin differing at: # $got->{foo}{x_version} = '0.01' # $expected->{foo}{x_version} = Does not exist # Looks like you failed 1 test of 8. t/script_dist.t ................ Dubious, test returned 1 (wstat 256, 0x100) Failed 1/8 subtests ---
Subject: Re: [rt.cpan.org #84271] t/script_dist.t failure on CentOS 6.4 x64
Date: Fri, 29 Mar 2013 12:59:27 +0100
To: bug-Module-Build [...] rt.cpan.org
From: Leon Timmermans <leont [...] cpan.org>
Download (untitled) / with headers
text/plain 930b
On Thu, Mar 28, 2013 at 9:31 PM, List Poster via RT <bug-Module-Build@rt.cpan.org> wrote: Show quoted text
> I ran into this while trying to install the latest cpanm. I have perl-Module-Build-0.3500-130.el6_4.x86_64 installed, but > 0.36 is required. After encountering this error I tried 0.39_02, 0.40, 0.4001, and 0.4002 from source as well, and all had the same error. > > Perl: perl-5.10.1-130.el6_4.x86_64 > > --- > # Failed test at t/script_dist.t line 77. > # Structures begin differing at: > # $got->{foo}{x_version} = '0.01' > # $expected->{foo}{x_version} = Does not exist > # Looks like you failed 1 test of 8. > t/script_dist.t ................ > Dubious, test returned 1 (wstat 256, 0x100) > Failed 1/8 subtests
It seems that is caused by the latest release of CPAN::Meta. I'm not sure yet who is at fault though. We're looking at it, but in the mean time downgrading to CPAN::Meta 2.120921 will fix it for now.
Subject: Re: [rt.cpan.org #84271] t/script_dist.t failure on CentOS 6.4 x64
Date: Fri, 29 Mar 2013 15:03:58 +0100
To: bug-Module-Build [...] rt.cpan.org
From: Leon Timmermans <leont [...] cpan.org>
Download (untitled) / with headers
text/plain 417b
On Fri, Mar 29, 2013 at 12:59 PM, Leon Timmermans <leont@cpan.org> wrote: Show quoted text
> It seems that is caused by the latest release of CPAN::Meta. I'm not > sure yet who is at fault though. We're looking at it, but in the mean > time downgrading to CPAN::Meta 2.120921 will fix it for now.
Forget that, a new release of CPAN::Meta has just been made, fixing this issue. Upgrade to that and everything should work again. Leon
From: listposter [...] gmail.com
Download (untitled) / with headers
text/plain 310b
I don't see a means for me to 'comment' rather than 'reply', so at the risk of re-opening the ticket I just wanted to fully confirm that everything now works as expected - a cpanm install w/all of its autodependencies (including Meta and Module-Build) simply works. Thanks so much for running it up the chain!


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.