Skip Menu |
 
rt.cpan.org will be shut down on March 1st, 2021.

This queue is for tickets about the CGI-Application-Plugin-Apache CPAN distribution.

Report information
The Basics
Id: 8413
Status: resolved
Priority: 0/
Queue: CGI-Application-Plugin-Apache

People
Owner: Nobody in particular
Requestors: william [...] knowmad.com
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: 0.09
Fixed in: (no value)

Attachments


Subject: Apache::Request requisite in Build.PL
Download (untitled) / with headers
text/plain 560b
Hi Michael, I was testing on my laptop where I have not installed Apache::Request which caused the tests to fail. I have attached a patch for Build.PL to check for this module. Also, I don't see anywhere in the docs where you mention what version of mod_perl that this module works with. Did you test under both mp1 and mp2? That was my first thought as to why my tests were failing. As I'm sure you know, the API has changed rather considerably between these releases. The tests all passed for me under mp1 once I installed Apache::Request. Thanks, William
Download Build.PL.diff
text/x-diff 349b
--- Build.PL.orig 2004-11-13 07:32:21.000000000 -0500 +++ Build.PL 2004-11-13 07:32:41.000000000 -0500 @@ -11,6 +11,7 @@ 'Exporter' => 0, 'Apache' => 0, 'Test::More' => 0, + 'Apache::Request' => 0, }, create_makefile_pl => 'passthrough', create_readme => 1,


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.