Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the Module-CoreList CPAN distribution.

Report information
The Basics
Id: 83999
Status: open
Priority: 0/
Queue: Module-CoreList

People
Owner: Nobody in particular
Requestors: ANDK [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 2.84
Fixed in: (no value)



Subject: is_deprecated() returns wrong result for current blead
Download (untitled) / with headers
text/plain 458b
Current version 2.84 of MC gives: is_deprecated("Module::Pluggable","5.017009") # true is_deprecated("Module::Pluggable","5.017010") # false This hurts my smokers that are running with bleadperl because bleadperl already kind of *is* 5.017010. I think a viable solution for this problem would be that is_deprecated learns that there is a maximumperl configured and that it should treat all higher perl versions like the maximumperl. What do you think?
Subject: Re: [rt.cpan.org #83999] is_deprecated() returns wrong result for current blead
Date: Sun, 17 Mar 2013 10:56:12 -0400
To: Andreas Koenig via RT <bug-Module-CoreList [...] rt.cpan.org>
From: Ricardo Signes <rjbs [...] cpan.org>
Download (untitled) / with headers
text/plain 416b
* Andreas Koenig via RT <bug-Module-CoreList@rt.cpan.org> [2013-03-17T04:45:26] Show quoted text
> I think a viable solution for this problem would be that is_deprecated > learns that there is a maximumperl configured and that it should treat > all higher perl versions like the maximumperl.
I have pushed an implementation of that to http://perl5.git.perl.org/perl.git/shortlog/refs/heads/rjbs/corelist-max-deprecated -- rjbs
Download signature.asc
application/pgp-signature 490b

Message body not shown because it is not plain text.



This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.