Skip Menu |
 

This queue is for tickets about the Pod-SAX CPAN distribution.

Report information
The Basics
Id: 83869
Status: new
Priority: 0/
Queue: Pod-SAX

People
Owner: Nobody in particular
Requestors: BRIANC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 0.14
Fixed in: (no value)



Download (untitled) / with headers
text/plain 928b
Pod::SAX is missing support for numerous entities in the HTML 4.0 standard. In fact, comparing the list of entities supported in Pod::SAX with [0], it appears that Pod::SAX is only listing HTML 2.0 entities. Since the last release of Pod::SAX was in 2003, five years after the release of the HTML 4.0 standard, and the perlpod manpage says nothing about which version of HTML the list of entities is to come from, it seems reasonable to think that Pod::SAX should support all of the standard HTML 4.0 entities. With appropriate fixes for 83866 and 83867, the attached pod file should produce a set of 254 listitems with five instances of the same character on each line. The set of characters was produced by parsing the .ent files in /usr/share/xml/entities/xhtml/ in the Debian w3c-dtd- xhtml package using (what else?) a perl one-liner. [0] http://en.wikipedia.org/wiki/List_of_XML_and_HTML_character_entity_refer ences
Subject: pod-tm-0004.pod
Download pod-tm-0004.pod
text/x-pod 12k

Message body is not shown because it is too large.



This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.