Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the Perl-Dist-Strawberry CPAN distribution.

Report information
The Basics
Id:
83339
Status:
resolved
Priority:
Low/Low

People
Owner:
Nobody in particular
Requestors:
dperrett [...] cambridge.org
Cc:
AdminCc:

BugTracker
Severity:
(no value)
Broken in:
(no value)
Fixed in:
(no value)

Attachments


Subject: Upgrade PPM of DBIx::Class
Date: Fri, 15 Feb 2013 11:54:52 +0000
To: bug-Perl-Dist-Strawberry@rt.cpan.org
From: Daniel Perrett <dperrett@cambridge.org>
BACKGROUND

I've installed DBIx::Class 0.08123 on Strawberry perl 5.12.3 using ppm (OS: XP Pro). The install was successful, but, while trying to run a minimal app (attached), DBIx::Class failed with this message:

Can't locate Carp/Clan.pm in @INC (@INC contains: AudioDB/lib C:/strawberry/perl/site/lib C:/strawberry/perl/vendor/lib C:/strawberry/perl/lib .) at C:/strawberry/perl/site/lib/DBIx/Class/Exception.pm line 6.
BEGIN failed--compilation aborted at C:/strawberry/perl/site/lib/DBIx/Class/Exception.pm line 6.
Compilation failed in require at C:/strawberry/perl/site/lib/DBIx/Class/Schema.pm line 6.
BEGIN failed--compilation aborted at C:/strawberry/perl/site/lib/DBIx/Class/Schema.pm line 6.
Compilation failed in require at (eval 2) line 2.
        ...propagated at C:/strawberry/perl/lib/base.pm line 94.
BEGIN failed--compilation aborted at AudioDB/lib/AudioDB/Schema.pm line 4.
Compilation failed in require at adb-test.pl line 5.
BEGIN failed--compilation aborted at adb-test.pl line 5.

DBIx/Class/Exception.pm does indeed call Carp::Clan on line 6.

I'm sure I can fix it by installing Carp::Clan, but I presume it ought to have gone in the DBIx::Class dependencies, as it's not a core module. DBIx::Class has now switched to a home-grown solution.

(Oddly, I couldn't find any tests that guaranteed all the classes could be loaded ok, but the test suite is pretty big, so possibly I missed them - I'm filing a separate request with DBIx::Class.)

ACTION REQUESTED

Could strawberry upgrade its ppm package to a version of DBIx::Class with a good record on CPAN Testers such as 0.8206, as the current version does not work?

Daniel

Message body not shown because it is not plain text.

Subject: RE: [rt.cpan.org #83339] Upgrade PPM of DBIx::Class
Date: Fri, 15 Feb 2013 13:16:11 +0100
To: bug-Perl-Dist-Strawberry@rt.cpan.org
From: KMX <kmx@volny.cz>
The preffered way of installing new modules into strawberry perl is via cpan or cpanp utilities. Try: C:\> cpan DBIx::Class or C:\> cpanp -i DBIx::Class Also please consider upgrading your strawberry perl to the latest 5.16.x series (or at least 5.14.x). Strawberry 5.12.3 has some unfixed issues and is not maintained anymore. -- kmx


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.