Skip Menu |
 

This queue is for tickets about the XML-LibXML CPAN distribution.

Report information
The Basics
Id: 83322
Status: resolved
Priority: 0/
Queue: XML-LibXML

People
Owner: Nobody in particular
Requestors: SREZIC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Unimportant
Broken in: 2.0014
Fixed in: (no value)



Subject: Remove ExtUtils::MakeMaker from PREREQ_PM
Download (untitled) / with headers
text/plain 413b
There's no indication why EUMM 6.56 is required, and in fact, things seem to work fine with the EUMM which comes with perl 5.10.1 (6.55_02). So I vote for removal of the line from Makefile.PL. If you know why it's needed, then probably a comment should be added here. Anyway, in this case it's probably a configure requirement, not a build/runtime requirement, and should be marked as this. Regards, Slaven
Download (untitled) / with headers
text/plain 957b
Hi Slaven, thanks for the bug report. On Thu Feb 14 11:49:13 2013, SREZIC wrote: Show quoted text
> There's no indication why EUMM 6.56 is required, and in fact, things > seem to work fine with the EUMM which comes with perl 5.10.1 (6.55_02). > So I vote for removal of the line from Makefile.PL. > > If you know why it's needed, then probably a comment should be added here. > Anyway, in this case it's probably a configure requirement, not a > build/runtime requirement, and should be marked as this. > > Regards, > Slaven
I think I lately added some of the META_MERGE Stuff, which is only available there. Anyway, you can install a new version of EUMM on top of the perl as a dependency. We still support all perls starting from recent versions of 5.8.x, but may bump the dependency eventually. I've been thinking of converting XML::LibXML to use Alien::LibXML or maybe even Module::Build , anyway, but this would be more long-term. Regards, -- Shlomi Fish
Download (untitled) / with headers
text/plain 2.1k
On 2013-02-15 09:56:58, SHLOMIF wrote: Show quoted text
> Hi Slaven, > > thanks for the bug report. > > On Thu Feb 14 11:49:13 2013, SREZIC wrote:
> > There's no indication why EUMM 6.56 is required, and in fact, things > > seem to work fine with the EUMM which comes with perl 5.10.1 (6.55_02). > > So I vote for removal of the line from Makefile.PL. > > > > If you know why it's needed, then probably a comment should be added here. > > Anyway, in this case it's probably a configure requirement, not a > > build/runtime requirement, and should be marked as this. > > > > Regards, > > Slaven
> > I think I lately added some of the META_MERGE Stuff, which is only > available there.
If it's just META_MERGE: the META stuff is just needed for "make dist", that is, for a release manager, but not for a normal user installing the module. It's possible to lower the prerequisite version for a normal user using the following technique in Makefile.PL: my $eumm_recent_enough = $ExtUtils::MakeMaker::VERSION >= 6.54; if (!$eumm_recent_enough) { *MY::dist_core = sub { <<'EOF'; dist : $(NOECHO) $(ECHO) "Sorry, use a newer EUMM!" EOF }; } And later in the WriteMakefile argument hash (to prevent unnecessary warnings): ($eumm_recent_enough ? (META_MERGE => { resources => { repository => 'git://github.com/eserte/algorithm-googlepolylineencoding.git' }, no_index => { directory => [qw(xt)] }, }) : () ), So a normal user can do everything but "make dist", and a release manager has to upgrade his EUMM installation to create a release. Show quoted text
> Anyway, you can install a new version of EUMM on top of > the perl as a dependency.
There are situations like building a debian package using dh-make-perl, where having the extra dependency causes problems. It's definitively easier if the EUMM prerequisute version is as low as possible. Show quoted text
> We still support all perls starting from > recent versions of 5.8.x, but may bump the dependency eventually. > > I've been thinking of converting XML::LibXML to use Alien::LibXML or > maybe even Module::Build , anyway, but this would be more long-term. > > Regards, > > -- Shlomi Fish > >
Regards, Slaven
Download (untitled) / with headers
text/plain 2.1k
On Sun Oct 26 11:00:47 2014, SREZIC wrote: Show quoted text
> On 2013-02-15 09:56:58, SHLOMIF wrote:
> > Hi Slaven, > > > > thanks for the bug report. > > > > On Thu Feb 14 11:49:13 2013, SREZIC wrote:
> > > There's no indication why EUMM 6.56 is required, and in fact, > > > things > > > seem to work fine with the EUMM which comes with perl 5.10.1 > > > (6.55_02). > > > So I vote for removal of the line from Makefile.PL. > > > > > > If you know why it's needed, then probably a comment should be > > > added here. > > > Anyway, in this case it's probably a configure requirement, not a > > > build/runtime requirement, and should be marked as this. > > > > > > Regards, > > > Slaven
> > > > I think I lately added some of the META_MERGE Stuff, which is only > > available there.
> > If it's just META_MERGE: the META stuff is just needed for "make > dist", that is, for a release manager, but not for a normal user > installing the module. It's possible to lower the prerequisite version > for a normal user using the following technique in Makefile.PL: > > my $eumm_recent_enough = $ExtUtils::MakeMaker::VERSION >= 6.54; > if (!$eumm_recent_enough) { > *MY::dist_core = sub { > <<'EOF'; > dist : > $(NOECHO) $(ECHO) "Sorry, use a newer EUMM!" > > EOF > }; > } > > And later in the WriteMakefile argument hash (to prevent unnecessary > warnings): > > ($eumm_recent_enough > ? (META_MERGE => { resources => { repository => > 'git://github.com/eserte/algorithm-googlepolylineencoding.git' }, > no_index => { directory => [qw(xt)] }, > }) > : () > ), > > So a normal user can do everything but "make dist", and a release > manager has to upgrade his EUMM installation to create a release. >
> > Anyway, you can install a new version of EUMM on top of > > the perl as a dependency.
> > There are situations like building a debian package using dh-make- > perl, where having the extra dependency causes problems. It's > definitively easier if the EUMM prerequisute version is as low as > possible.
I applied a similar workaround in the new version of XML-LibXML. Please test. Regards, -- Shlomi Fish


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.