Skip Menu |
 

This queue is for tickets about the Hg-Lib CPAN distribution.

Report information
The Basics
Id: 83239
Status: new
Priority: 0/
Queue: Hg-Lib

People
Owner: djerius [...] cpan.org
Requestors: mmusgrove [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 0.01
Fixed in: (no value)



Subject: Tests hang on Windows
Download (untitled) / with headers
text/plain 2.8k
Strawberry Perl 5.12.3 on Windows 7 CPAN.pm: Building D/DJ/DJERIUS/Hg-Lib-0.01.tar.gz cp lib/Hg/Lib/Server.pm blib\lib\Hg\Lib\Server.pm cp lib/Hg/Lib/Server/Pipe.pm blib\lib\Hg\Lib\Server\Pipe.pm Skip blib\lib\Hg\Lib\Server.pm (unchanged) cp lib/Hg/Lib.pm blib\lib\Hg\Lib.pm Skip blib\lib\Hg\Lib.pm (unchanged) Skip blib\lib\Hg\Lib\Server\Pipe.pm (unchanged) (C:\strawberry\c\bin\dmake.EXE exited with 0) CPAN::Reporter: dmake result is 'pass', No errors. DJERIUS/Hg-Lib-0.01.tar.gz C:\strawberry\c\bin\dmake.EXE -- OK Running make test C:\strawberry\perl\bin\perl.exe "-MExtUtils::Command::MM" "-e" "test_harness(0, 'inc', 'blib\lib', 'blib\arch')" t/*.t t/Server/*.t t/Server/Pipe/*.t # Failed test 'hello, no args' # at t/Server.t line 15. # died: Your vendor has not defined POSIX macro WUNTRACED, used at C:\strawberry \cpan\build\Hg-Lib-0.01-sS1HJP\blib\lib/Hg/Lib/Server/Pipe.pm line 206. # at C:\strawberry\cpan\build\Hg-Lib-0.01-sS1HJP\blib\lib/Hg/Lib/Server/Pipe.pm line 122. # Failed test 'bad hello channel' # at t/Server.t line 18. # expecting: Regexp ((?-xism:incomplete hello message)) # found: Your vendor has not defined POSIX macro WUNTRACED, used at C:\strawberr y\cpan\build\Hg-Lib-0.01-sS1HJP\blib\lib/Hg/Lib/Server/Pipe.pm line 206. # at C:\strawberry\cpan\build\Hg-Lib-0.01-sS1HJP\blib\lib/Hg/Lib/Server/Pipe.pm line 122. # Failed test 'bad hello length' # at t/Server.t line 21. # expecting: Regexp ((?-xism:incomplete hello message)) # found: Your vendor has not defined POSIX macro WUNTRACED, used at C:\strawberr y\cpan\build\Hg-Lib-0.01-sS1HJP\blib\lib/Hg/Lib/Server/Pipe.pm line 206. # at C:\strawberry\cpan\build\Hg-Lib-0.01-sS1HJP\blib\lib/Hg/Lib/Server/Pipe.pm line 122. # Failed test 'missing capabilities' # at t/Server.t line 24. # expecting: Regexp ((?-xism:did not provide capabilities)) # found: Your vendor has not defined POSIX macro WUNTRACED, used at C:\strawberr y\cpan\build\Hg-Lib-0.01-sS1HJP\blib\lib/Hg/Lib/Server/Pipe.pm line 206. # at C:\strawberry\cpan\build\Hg-Lib-0.01-sS1HJP\blib\lib/Hg/Lib/Server/Pipe.pm line 122. # Failed test 'missing runcommand capability' # at t/Server.t line 27. # expecting: Regexp ((?-xism:missing runcommand capability)) # found: Your vendor has not defined POSIX macro WUNTRACED, used at C:\strawberr y\cpan\build\Hg-Lib-0.01-sS1HJP\blib\lib/Hg/Lib/Server/Pipe.pm line 206. # at C:\strawberry\cpan\build\Hg-Lib-0.01-sS1HJP\blib\lib/Hg/Lib/Server/Pipe.pm line 122. # Failed test 'missing encoding' # at t/Server.t line 30. # expecting: Regexp ((?-xism:did not provide encoding)) # found: Your vendor has not defined POSIX macro WUNTRACED, used at C:\strawberr y\cpan\build\Hg-Lib-0.01-sS1HJP\blib\lib/Hg/Lib/Server/Pipe.pm line 206. # at C:\strawberry\cpan\build\Hg-Lib-0.01-sS1HJP\blib\lib/Hg/Lib/Server/Pipe.pm line 122. # Looks like you failed 6 tests of 6.
Download (untitled) / with headers
text/plain 402b
On Sat Feb 09 11:33:54 2013, MMUSGROVE wrote: Show quoted text
> Strawberry Perl 5.12.3 on Windows 7
Show quoted text
> # Failed test 'hello, no args' > # at t/Server.t line 15. > # died: Your vendor has not defined POSIX macro WUNTRACED, used at
Thanks for the report. At what point do the tests hang? Right after the failed tests for t/Server.t? Could you run the t/Server/Pipe/check_on_child.t test manually? Thanks.
Download (untitled) / with headers
text/plain 698b
On Sat Feb 09 21:49:04 2013, DJERIUS wrote: Show quoted text
> On Sat Feb 09 11:33:54 2013, MMUSGROVE wrote:
> > Strawberry Perl 5.12.3 on Windows 7
>
> > # Failed test 'hello, no args' > > # at t/Server.t line 15. > > # died: Your vendor has not defined POSIX macro WUNTRACED, used at
> > Thanks for the report. At what point do the tests hang? Right after > the failed tests for t/Server.t? Could you run the > > t/Server/Pipe/check_on_child.t > > test manually? > > Thanks.
Yes, my smoker hung right after the report for t/Server.t. I don't have a Strawberry Perl 5.12.3 installation handy right now (I uninstalled it earlier today) but I'll try it manually on one of my other ones right now.
Download (untitled) / with headers
text/plain 3.8k
Under 5.16.2: t\Server.t outputs this: C:\strawberry\cpan\build\Hg-Lib-0.01-hNuodA>perl -I inc -I blib\lib -I blib\arch t\Server.t not ok 1 - hello, no args # Failed test 'hello, no args' # at t\Server.t line 15. # died: Your vendor has not defined POSIX macro WUNTRACED, used at blib\lib/Hg/L ib/Server/Pipe.pm line 206 # at blib\lib/Hg/Lib/Server/Pipe.pm line 122. not ok 2 - bad hello channel # Failed test 'bad hello channel' # at t\Server.t line 18. # expecting: Regexp ((?^:incomplete hello message)) # found: Your vendor has not defined POSIX macro WUNTRACED, used at blib\lib/Hg/ Lib/Server/Pipe.pm line 206 # at blib\lib/Hg/Lib/Server/Pipe.pm line 122. not ok 3 - bad hello length # Failed test 'bad hello length' # at t\Server.t line 21. # expecting: Regexp ((?^:incomplete hello message)) # found: Your vendor has not defined POSIX macro WUNTRACED, used at blib\lib/Hg/ Lib/Server/Pipe.pm line 206 # at blib\lib/Hg/Lib/Server/Pipe.pm line 122. not ok 4 - missing capabilities # Failed test 'missing capabilities' # at t\Server.t line 24. # expecting: Regexp ((?^:did not provide capabilities)) # found: Your vendor has not defined POSIX macro WUNTRACED, used at blib\lib/Hg/ Lib/Server/Pipe.pm line 206 # at blib\lib/Hg/Lib/Server/Pipe.pm line 122. not ok 5 - missing runcommand capability # Failed test 'missing runcommand capability' # at t\Server.t line 27. # expecting: Regexp ((?^:missing runcommand capability)) # found: Your vendor has not defined POSIX macro WUNTRACED, used at blib\lib/Hg/ Lib/Server/Pipe.pm line 206 # at blib\lib/Hg/Lib/Server/Pipe.pm line 122. not ok 6 - missing encoding # Failed test 'missing encoding' # at t\Server.t line 30. # expecting: Regexp ((?^:did not provide encoding)) # found: Your vendor has not defined POSIX macro WUNTRACED, used at blib\lib/Hg/ Lib/Server/Pipe.pm line 206 # at blib\lib/Hg/Lib/Server/Pipe.pm line 122. 1..6 # Looks like you failed 6 tests of 6. t\Server\Pipe.t outputs this: C:\strawberry\cpan\build\Hg-Lib-0.01-hNuodA>perl -I inc -I blib\lib -I blib\arch t\Server\Pipe.t not ok 1 - fake, no args # Failed test 'fake, no args' # at t\Server\Pipe.t line 15. # died: Your vendor has not defined POSIX macro WUNTRACED, used at blib\lib/Hg/L ib/Server/Pipe.pm line 206 # at blib\lib/Hg/Lib/Server/Pipe.pm line 122. not ok 2 - fake, fail # Failed test 'fake, fail' # at t\Server\Pipe.t line 30. # expecting: Regexp ((?^:unexpected exit of child)) # found: Your vendor has not defined POSIX macro WUNTRACED, used at blib\lib/Hg/ Lib/Server/Pipe.pm line 206 # at blib\lib/Hg/Lib/Server/Pipe.pm line 122. not ok 1 - open hg # Failed test 'open hg' # at t\Server\Pipe.t line 36. # died: Your vendor has not defined POSIX macro WUNTRACED, used at blib\lib/ Hg/Lib/Server/Pipe.pm line 206 # at blib\lib/Hg/Lib/Server/Pipe.pm line 122. not ok 2 - short data # Failed test 'short data' # at t\Server\Pipe.t line 39. # expecting: Regexp ((?^:end-of-file reading)) # found: Can't call method "get_chunk" on an undefined value at t\Server\Pip e.t line 39. 1..2 # Looks like you failed 2 tests of 2. not ok 3 - badlen # Failed test 'badlen' # at t\Server\Pipe.t line 41. 1..3 # Looks like you failed 3 tests of 3. t\Server\Pipe\check_on_child.t outputs this: C:\strawberry\cpan\build\Hg-Lib-0.01-hNuodA>perl -I inc -I blib\lib -I blib\arch t\Server\Pipe\check_on_child.t 1..0 # No tests run! not ok 1 - No tests run for subtest "fork_alive" # Failed test 'No tests run for subtest "fork_alive"' # at t\Server\Pipe\check_on_child.t line 67. 1..0 # No tests run! not ok 2 - No tests run for subtest "fork_exit" # Failed test 'No tests run for subtest "fork_exit"' # at t\Server\Pipe\check_on_child.t line 117. 1..2 # Looks like you failed 2 tests of 2. I'm not sure why running the tests through the harness causes it to hang.
Download (untitled) / with headers
text/plain 764b
On Sat Feb 09 22:30:43 2013, MMUSGROVE wrote: Show quoted text
> Under 5.16.2:
Thanks. It seems that most (all?) of the errors are due to the WUNTRACED problems. I've uploaded a "fixed" version to CPAN (tarball is also available here: https://bitbucket.org/djerius/hg-lib/downloads/Hg-Lib-0.01_01.tar.gz Show quoted text
> I'm not sure why running the tests through the harness causes it to hang.
Perhaps something to do with the tests spawning a process and communicating with it? Who knows what lurks in there. I'm completely clueless when it comes to Windows and handling child processes (I don't have access to that OS); I'm basing the code on what works on POSIXy systems like Linux (and sometimes Mac OS X) and what I can scrounge from CPAN. Any and all help is appreciated! Thanks.
Download (untitled) / with headers
text/plain 200b
I'm not sure how much help I'll be but willing to try. I don't know what you changed but when run manually, t\Server.t and t\Server\Pipe.t both hang now. I have to break out with ctrl-c (SIGINT).
Download (untitled) / with headers
text/plain 364b
On Sat Feb 09 23:31:15 2013, MMUSGROVE wrote: Show quoted text
> I'm not sure how much help I'll be but willing to try.
Thanks. Show quoted text
> I don't know what you changed but when run manually, t\Server.t and > t\Server\Pipe.t both hang now.
No error messages about WUNTRACED, though? Does t\Server\Pipe\check_on_child.t hang as well? Show quoted text
> I have to break out with ctrl-c (SIGINT). > >
Subject: Re: [rt.cpan.org #83239] Tests hang on Windows
Date: Sun, 10 Feb 2013 11:16:39 -0600
To: bug-Hg-Lib [...] rt.cpan.org
From: "Mr. Muskrat" <mmusgrove [...] cpan.org>
Download (untitled) / with headers
text/plain 589b
On Sun, Feb 10, 2013 at 11:15 AM, Diab Jerius via RT <bug-Hg-Lib@rt.cpan.org Show quoted text
> wrote:
Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=83239 > > > On Sat Feb 09 23:31:15 2013, MMUSGROVE wrote:
> > I'm not sure how much help I'll be but willing to try.
> > Thanks. >
> > I don't know what you changed but when run manually, t\Server.t and > > t\Server\Pipe.t both hang now.
> > No error messages about WUNTRACED, though? >
No Show quoted text
> > Does t\Server\Pipe\check_on_child.t hang as well? >
No, it behaved the same as before. Show quoted text
>
> > I have to break out with ctrl-c (SIGINT). > > > >
> > > >
Download (untitled) / with headers
text/plain 183b
I've replaced the IPC code with System::Command in version 0.001_04. Hopefully this makes things work on Windows. If you get a chance, could you please check this version? Thanks!
Subject: Re: [rt.cpan.org #83239] Tests hang on Windows
Date: Mon, 5 Aug 2013 01:11:25 -0500
To: bug-Hg-Lib [...] rt.cpan.org
From: "Mr. Muskrat" <mmusgrove [...] cpan.org>
Download (untitled) / with headers
text/plain 2.1k
Diab, Sorry that it took so long. When the tests are run during install, it looks like it is hanging inside of Server/Server.t but when the tests are run manually, we can see that it really is within Server/basic.t. Server/encoding.t is fine. Show quoted text
cpan> install D/DJ/DJERIUS/Hg-Lib-0.01_04.tar.gz
Running make for D/DJ/DJERIUS/Hg-Lib-0.01_04.tar.gz Checksum for C:\strawberry\cpan\sources\authors\id\D\DJ\DJERIUS\Hg-Lib-0.01_04.t ar.gz ok Scanning cache C:\strawberry\cpan\build for sizes ............................................................................DONE CPAN.pm: Building D/DJ/DJERIUS/Hg-Lib-0.01_04.tar.gz Created MYMETA.yml and MYMETA.json Creating new 'Build' script for 'Hg-Lib' version '0.01_04' (C:\strawberry\perl\bin\perl.exe Build.PL exited with 0) CPAN::Reporter: Build.PL result is 'pass', No errors. Building Hg-Lib (C:\strawberry\perl\bin\perl.exe ./Build exited with 0) CPAN::Reporter: Build result is 'pass', No errors. DJERIUS/Hg-Lib-0.01_04.tar.gz C:\strawberry\perl\bin\perl.exe ./Build -- OK Running Build test t/Server/Server.t .... ok Terminating on signal SIGINT(2) Terminating on signal SIGINT(2) Terminating on signal SIGINT(2) Terminating on signal SIGINT(2) Terminating on signal SIGINT(2) Terminate batch job (Y/N)? y C:\strawberry\cpan\build\Hg-Lib-0.01_04-4PXlNx>perl -I inc -I blib/lib -I blib/a rch t/Server/Server.t ok 1 - fake, no args ok 2 - fake, fail ok 1 - open hg ok 2 - short data 1..2 ok 3 - badlen 1..3 C:\strawberry\cpan\build\Hg-Lib-0.01_04-4PXlNx>perl -I inc -I blib/lib -I blib/a rch t/Server/basic.t ok 1 - hello, no args Terminating on signal SIGINT(2) Terminating on signal SIGINT(2) Terminating on signal SIGINT(2) Terminating on signal SIGINT(2) C:\strawberry\cpan\build\Hg-Lib-0.01_04-4PXlNx>perl -I inc -I blib/lib -I blib/a rch t/Server/encoding.t ok 1 - default encoding 1..1 On Tue, Apr 23, 2013 at 8:51 PM, Diab Jerius via RT <bug-Hg-Lib@rt.cpan.org>wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=83239 > > > I've replaced the IPC code with System::Command in version 0.001_04. > Hopefully this makes things work on Windows. > > If you get a chance, could you please check this version? Thanks! > >
Download (untitled) / with headers
text/plain 574b
On Mon Aug 05 02:12:01 2013, MMUSGROVE wrote: Show quoted text
> Diab, > Sorry that it took so long. When the tests are run during install, it > looks > like it is hanging inside of Server/Server.t but when the tests are > run > manually, we can see that it really is within Server/basic.t.
And I'm even more sorry that it took so long for my reply. There have been substantial modifications to the code in the meantime. I have just uploaded version 0.01_05 (metacpan sees it but CPAN is lagging a bit). Would you be so kind and try that version when you get a chance? Thanks! Diab
Download (untitled) / with headers
text/plain 1.5k
Diab, I don't have access to the smoker I used previously but I do have a Windows 7 laptop running Strawberry Perl 5.12.3. I have Mercurial installed but not the pre-requisite modules. I probably should have tried the install without Mercurial first. Maybe I can do that on a different system some other time. I kicked off a cpan install (cpan D/DJ/DJERIUS/Hg-Lib-0.01_05.tar.gz) and it started pulling the pre-requisites. It looks like something didn't work out the first time because it couldn't find Type::Utils. I kicked off a cpan install a second time and the list of missing prereqs was much smaller. I noticed that there was a problem with Module::Build and Test::Class. Running install for module 'Test::Class' Running make for R/RJ/RJBS/Test-Class-0.41.tar.gz Checksum for C:\strawberry\cpan\sources\authors\id\R\RJ\RJBS\Test-Class-0.41.tar.gz ok CPAN: Module::Build loaded ok (v0.38) CPAN.pm: Going to build R/RJ/RJBS/Test-Class-0.41.tar.gz Created MYMETA.yml and MYMETA.json Creating new 'Build' script for 'Test-Class' version '0.41' Module::Build version 0.42 required--this is only version 0.38 at ./Build line 41. RJBS/Test-Class-0.41.tar.gz C:\strawberry\perl\bin\perl.exe ./Build -- NOT OK Running Build test Can't test without successful make Running Build install Make had returned bad status, install seems impossible I installed Module::Build and Test::Class before trying the install a third time. See third-install.txt attachment. I then tried to manually run the failing tests. See look-testing.txt attachment.
Subject: look-testing.txt
Download look-testing.txt
text/plain 10.4k
C:\strawberry\cpan\build\Hg-Lib-0.01_05-Q35y4t>perl -Iblib -Ilib t/Hg/Lib/Server /Pipe/runcommand.t ok 1 - echo_error, no args # Child (echo error) exited without calling finalize() not ok 1 - echo error # Failed test 'echo error' # at C:/strawberry/perl/lib/Test/Builder.pm line 239. timed out waiting for data from server # Child (testing with Pipe::RunCommand) exited without calling finalize() not ok 1 - testing with Pipe::RunCommand # Failed test 'testing with Pipe::RunCommand' # at C:/strawberry/perl/lib/Test/Builder.pm line 252. # Tests were run but no plan was declared and done_testing() was not seen. C:\strawberry\cpan\build\Hg-Lib-0.01_05-Q35y4t>perl -Iblib -Ilib t/Hg/Lib/Server /Server.t false exception caught by Test::Fatal::exception at C:/strawberry/perl/site/lib/ Test/Fatal.pm line 51 Test::Fatal::__ANON__('') called at C:/strawberry/perl/site/lib/Try/Tiny .pm line 106 Try::Tiny::try('CODE(0x36e6cec)', 'Try::Tiny::Catch=REF(0x2ccf194)') cal led at C:/strawberry/perl/site/lib/Test/Fatal.pm line 52 Test::Fatal::exception('CODE(0x2cce654)') called at t/Hg/Lib/Server/Serv er.t line 19 main::__ANON__() called at C:/strawberry/perl/lib/Test/Builder.pm line 2 34 Test::Builder::__ANON__() called at C:/strawberry/perl/lib/Test/Builder. pm line 239 eval {...} called at C:/strawberry/perl/lib/Test/Builder.pm line 239 Test::Builder::subtest('Test::Builder=HASH(0x1fb6e24)', 'timeout', 'CODE (0x36e5b94)') called at C:/strawberry/perl/lib/Test/More.pm line 747 Test::More::subtest('timeout', 'CODE(0x36e5b94)') called at t/Hg/Lib/Ser ver/Server.t line 24 # Child (timeout) exited without calling finalize() not ok 1 - timeout # Failed test 'timeout' # at C:/strawberry/perl/lib/Test/Builder.pm line 252. # Tests were run but no plan was declared and done_testing() was not seen. C:\strawberry\cpan\build\Hg-Lib-0.01_05-Q35y4t>perl -Iblib -Ilib t/Hg/Lib/Server /basic.t ok 1 - hello, no args false exception caught by Test::Fatal::exception at C:/strawberry/perl/site/lib/ Test/Fatal.pm line 51 Test::Fatal::__ANON__('') called at C:/strawberry/perl/site/lib/Try/Tiny .pm line 106 Try::Tiny::try('CODE(0x384f5d4)', 'Try::Tiny::Catch=REF(0x384fb04)') cal led at C:/strawberry/perl/site/lib/Test/Fatal.pm line 52 Test::Fatal::exception('CODE(0x35442dc)') called at t/Hg/Lib/Server/basi c.t line 24 main::__ANON__() called at C:/strawberry/perl/lib/Test/Builder.pm line 2 34 Test::Builder::__ANON__() called at C:/strawberry/perl/lib/Test/Builder. pm line 239 eval {...} called at C:/strawberry/perl/lib/Test/Builder.pm line 239 Test::Builder::subtest('Test::Builder=HASH(0x2487634)', 'bad hello chann el', 'CODE(0x38457d4)') called at C:/strawberry/perl/lib/Test/More.pm line 747 Test::More::subtest('bad hello channel', 'CODE(0x38457d4)') called at t/ Hg/Lib/Server/basic.t line 29 # Child (bad hello channel) exited without calling finalize() not ok 2 - bad hello channel # Failed test 'bad hello channel' # at C:/strawberry/perl/lib/Test/Builder.pm line 252. # Tests were run but no plan was declared and done_testing() was not seen. C:\strawberry\cpan\build\Hg-Lib-0.01_05-Q35y4t>perl -Iblib -Ilib t/Hg/Lib/Server /connect.t # Child (no repo) exited without calling finalize() not ok 1 - no repo # Failed test 'no repo' # at C:/strawberry/perl/lib/Test/Builder.pm line 239. false exception caught by Test::Fatal::exception at C:/strawberry/perl/site/lib/ Test/Fatal.pm line 51 Test::Fatal::__ANON__('') called at C:/strawberry/perl/site/lib/Try/Tiny .pm line 106 Try::Tiny::try('CODE(0x39a381c)', 'Try::Tiny::Catch=REF(0x2f7eb44)') cal led at C:/strawberry/perl/site/lib/Test/Fatal.pm line 52 Test::Fatal::exception('CODE(0x250f3b4)') called at t/Hg/Lib/Server/conn ect.t line 18 main::__ANON__('main=HASH(0x39a1e04)') called at C:/strawberry/perl/site /lib/Test/Roo/Class.pm line 66 Test::Roo::Class::each_test('main=HASH(0x39a1e04)', 'CODE(0x3949424)') c alled at (eval 280) line 16 main::each_test('main=HASH(0x39a1e04)', 'CODE(0x3949424)') called at C:/ strawberry/perl/site/lib/Test/Roo.pm line 38 Test::Roo::__ANON__() called at C:/strawberry/perl/lib/Test/Builder.pm l ine 234 Test::Builder::__ANON__() called at C:/strawberry/perl/lib/Test/Builder. pm line 239 eval {...} called at C:/strawberry/perl/lib/Test/Builder.pm line 239 Test::Builder::subtest('Test::Builder=HASH(0x25472f4)', 'no repo', 'CODE (0x39a308c)') called at C:/strawberry/perl/lib/Test/More.pm line 747 Test::More::subtest('no repo', 'CODE(0x39a308c)') called at C:/strawberr y/perl/site/lib/Test/Roo.pm line 39 Test::Roo::__ANON__('main=HASH(0x39a1e04)') called at (eval 283) line 16 main::_do_tests('main=HASH(0x39a1e04)') called at C:/strawberry/perl/sit e/lib/Test/Roo/Class.pm line 51 Test::Roo::Class::__ANON__() called at C:/strawberry/perl/lib/Test/Build er.pm line 234 Test::Builder::__ANON__() called at C:/strawberry/perl/lib/Test/Builder. pm line 239 eval {...} called at C:/strawberry/perl/lib/Test/Builder.pm line 239 Test::Builder::subtest('Test::Builder=HASH(0x25472f4)', 'testing with ma in', 'CODE(0x39a2424)') called at C:/strawberry/perl/lib/Test/More.pm line 747 Test::More::subtest('testing with main', 'CODE(0x39a2424)') called at C: /strawberry/perl/site/lib/Test/Roo/Class.pm line 53 Test::Roo::Class::run_tests('main') called at C:/strawberry/perl/site/li b/Test/Roo.pm line 46 Test::Roo::run_me() called at t/Hg/Lib/Server/connect.t line 43 # Child (testing with main) exited without calling finalize() not ok 1 - testing with main # Failed test 'testing with main' # at C:/strawberry/perl/lib/Test/Builder.pm line 252. # Tests were run but no plan was declared and done_testing() was not seen. C:\strawberry\cpan\build\Hg-Lib-0.01_05-Q35y4t>perl -Iblib -Ilib t/Hg/Lib/Server /encoding.t ok 1 - default encoding ok 2 - requested encoding false exception caught by Test::Fatal::exception at C:/strawberry/perl/site/lib/ Test/Fatal.pm line 51 Test::Fatal::__ANON__('') called at C:/strawberry/perl/site/lib/Try/Tiny .pm line 106 Try::Tiny::try('CODE(0x34b87dc)', 'Try::Tiny::Catch=REF(0x3772d2c)') cal led at C:/strawberry/perl/site/lib/Test/Fatal.pm line 52 Test::Fatal::exception('CODE(0x3765994)') called at t/Hg/Lib/Server/enco ding.t line 24 main::__ANON__() called at C:/strawberry/perl/lib/Test/Builder.pm line 2 34 Test::Builder::__ANON__() called at C:/strawberry/perl/lib/Test/Builder. pm line 239 eval {...} called at C:/strawberry/perl/lib/Test/Builder.pm line 239 Test::Builder::subtest('Test::Builder=HASH(0x23372ec)', 'incorrect encod ing', 'CODE(0x36682ec)') called at C:/strawberry/perl/lib/Test/More.pm line 747 Test::More::subtest('incorrect encoding', 'CODE(0x36682ec)') called at t /Hg/Lib/Server/encoding.t line 29 # Child (incorrect encoding) exited without calling finalize() not ok 3 - incorrect encoding # Failed test 'incorrect encoding' # at C:/strawberry/perl/lib/Test/Builder.pm line 252. # Tests were run but no plan was declared and done_testing() was not seen. C:\strawberry\cpan\build\Hg-Lib-0.01_05-Q35y4t>perl -Iblib -Ilib t/Hg/Lib/Types/ Types.t ok 1 - StrList as arrayref ok 2 - StrList as scalar not ok 3 - The object isa Type::Exception::Assertion # Failed test 'The object isa Type::Exception::Assertion' # at t/Hg/Lib/Types/Types.t line 25. # The object isn't a 'Type::Exception::Assertion' it's a 'Error::TypeTiny::A ssertion' 1..3 # Looks like you failed 1 test of 3. C:\strawberry\cpan\build\Hg-Lib-0.01_05-Q35y4t>perl -Iblib -Ilib t/Hg/Lib/open.t # Child (no repo) exited without calling finalize() not ok 1 - no repo # Failed test 'no repo' # at C:/strawberry/perl/lib/Test/Builder.pm line 239. false exception caught by Test::Fatal::exception at C:/strawberry/perl/site/lib/ Test/Fatal.pm line 51 Test::Fatal::__ANON__('') called at C:/strawberry/perl/site/lib/Try/Tiny .pm line 106 Try::Tiny::try('CODE(0x396077c)', 'Try::Tiny::Catch=REF(0x2d335ac)') cal led at C:/strawberry/perl/site/lib/Test/Fatal.pm line 52 Test::Fatal::exception('CODE(0x2d3298c)') called at t/Hg/Lib/open.t line 19 main::__ANON__('main=HASH(0x395ed3c)') called at C:/strawberry/perl/site /lib/Test/Roo/Class.pm line 66 Test::Roo::Class::each_test('main=HASH(0x395ed3c)', 'CODE(0x2f408ac)') c alled at (eval 382) line 16 main::each_test('main=HASH(0x395ed3c)', 'CODE(0x2f408ac)') called at C:/ strawberry/perl/site/lib/Test/Roo.pm line 38 Test::Roo::__ANON__() called at C:/strawberry/perl/lib/Test/Builder.pm l ine 234 Test::Builder::__ANON__() called at C:/strawberry/perl/lib/Test/Builder. pm line 239 eval {...} called at C:/strawberry/perl/lib/Test/Builder.pm line 239 Test::Builder::subtest('Test::Builder=HASH(0x25d7154)', 'no repo', 'CODE (0x395ffc4)') called at C:/strawberry/perl/lib/Test/More.pm line 747 Test::More::subtest('no repo', 'CODE(0x395ffc4)') called at C:/strawberr y/perl/site/lib/Test/Roo.pm line 39 Test::Roo::__ANON__('main=HASH(0x395ed3c)') called at (eval 385) line 16 main::_do_tests('main=HASH(0x395ed3c)') called at C:/strawberry/perl/sit e/lib/Test/Roo/Class.pm line 51 Test::Roo::Class::__ANON__() called at C:/strawberry/perl/lib/Test/Build er.pm line 234 Test::Builder::__ANON__() called at C:/strawberry/perl/lib/Test/Builder. pm line 239 eval {...} called at C:/strawberry/perl/lib/Test/Builder.pm line 239 Test::Builder::subtest('Test::Builder=HASH(0x25d7154)', 'testing with ma in', 'CODE(0x395f384)') called at C:/strawberry/perl/lib/Test/More.pm line 747 Test::More::subtest('testing with main', 'CODE(0x395f384)') called at C: /strawberry/perl/site/lib/Test/Roo/Class.pm line 53 Test::Roo::Class::run_tests('main') called at C:/strawberry/perl/site/li b/Test/Roo.pm line 46 Test::Roo::run_me() called at t/Hg/Lib/open.t line 66 # Child (testing with main) exited without calling finalize() not ok 1 - testing with main # Failed test 'testing with main' # at C:/strawberry/perl/lib/Test/Builder.pm line 252. # Tests were run but no plan was declared and done_testing() was not seen.
Subject: third-install.txt
Download third-install.txt
text/plain 13.1k

Message body is not shown because it is too large.

Download (untitled) / with headers
text/plain 756b
On Thu Dec 19 13:51:27 2013, MMUSGROVE wrote: Show quoted text
> Diab, > I don't have access to the smoker I used previously but I do have a > Windows 7 laptop running Strawberry Perl 5.12.3. I have Mercurial > installed but not the pre-requisite modules. I probably should have > tried the install without Mercurial first. Maybe I can do that on a > different system some other time. > >
Sorry for the long wait; I've finally managed to get a WinXP VM up and running so that I can test under Windows. I didn't have any problems with the installation (but then I used cpanminus, which isn't what you did). I'm seeing the same errors that you have been, which is good news. The next step is to figure out what's going on. Thanks much for your patience and help. Diab
Download (untitled) / with headers
text/plain 244b
I've tracked the problem down to not using binary mode in communications with the child process on Win32. See https://rt.cpan.org/Ticket/Display.html?id=93056 for the gory details. Unfortunately I don't have a simple solution for this. Diab


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.