Skip Menu |
 

This queue is for tickets about the libwww-perl CPAN distribution.

Report information
The Basics
Id: 82988
Status: resolved
Priority: 0/
Queue: libwww-perl

People
Owner: Nobody in particular
Requestors: victor [...] vsespb.ru
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 6.04
Fixed in: (no value)



Subject: Deploy error checking
Download (untitled) / with headers
text/plain 384b
Today I had issue when LWP and IO::Socket::SSL - it was not verifying SSL Hostnames. (LWP 6.04 + IO::Socket::SSL 1.8) re-installing LWP::UserAgent (using cpan/cpanp) and IO::Socket::SSL was not helpful. I fixed it by re-installing LWP::Protocol::https I think such issue can be avoided by checking LWP::Protocol::https->VERSION() and/or by improving CPAN packages dependency list.
Download (untitled) / with headers
text/plain 795b
On Sun Jan 27 22:25:56 2013, vsespb wrote: Show quoted text
> Today I had issue when LWP and IO::Socket::SSL - it was not verifying > SSL Hostnames. (LWP 6.04 + IO::Socket::SSL 1.8) > > re-installing LWP::UserAgent (using cpan/cpanp) and IO::Socket::SSL was > not helpful. > > I fixed it by re-installing LWP::Protocol::https > > I think such issue can be avoided by checking > LWP::Protocol::https->VERSION() and/or by improving CPAN packages > dependency list.
Steps to reproduce: Uninstall LWP::UserAgent using CPANPlus (after that I still have libwww-perl / perl-libwww-perl OS package installed - on Ubuntu 10.04 or Centos 5.x, but version 5.x) Install LWP::Protocol::https using CPAN or CPANPlust both CPAN and CPAN plus won't install LWP::UserAgent 6.x again And we'll have broken installation.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.