Skip Menu |
 

This queue is for tickets about the IPC-Run-SafeHandles CPAN distribution.

Report information
The Basics
Id: 82987
Status: open
Priority: 0/
Queue: IPC-Run-SafeHandles

People
Owner: Nobody in particular
Requestors: CHORNY [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 0.04
Fixed in: (no value)



Subject: old Module::Install
Download (untitled) / with headers
text/plain 221b
Please update Module::Install to latest version (or remove auto_install). This version of Module::Install has useless question "Auto-install the 1 mandatory module(s) from CPAN?". -- Alexandr Ciornii, http://chorny.net
Subject: Re: [rt.cpan.org #82987] old Module::Install
Date: Sun, 27 Jan 2013 13:04:22 -0500
To: Alexandr Ciornii via RT <bug-IPC-Run-SafeHandles [...] rt.cpan.org>
From: Jesse Vincent <jesse [...] fsck.com>
Download (untitled) / with headers
text/plain 800b
Can you explain why Auto-install is a problem requiring a module re-release (other than finding the feature distasteful)? On Sun, Jan 27, 2013 at 12:27:38PM -0500, Alexandr Ciornii via RT wrote: Show quoted text
> Sun Jan 27 12:27:37 2013: Request 82987 was acted upon. > Transaction: Ticket created by CHORNY > Queue: IPC-Run-SafeHandles > Subject: old Module::Install > Broken in: 0.04 > Severity: Normal > Owner: Nobody > Requestors: CHORNY@cpan.org > Status: new > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=82987 > > > > Please update Module::Install to latest version (or remove auto_install). > This version of Module::Install has useless question "Auto-install the 1 > mandatory module(s) from CPAN?". > > -- > Alexandr Ciornii, http://chorny.net >
--
Download (untitled) / with headers
text/plain 428b
On Sun Jan 27 13:04:30 2013, jesse@fsck.com wrote: Show quoted text
> > Can you explain why Auto-install is a problem requiring a module > re-release (other than finding the feature distasteful)?
I'm not sure if this requires a release. This question requires human intervention and installation does not proceed before it is answered. Newer version of M::I do not ask it when run under CPAN/CPANPLUS. -- Alexandr Ciornii, http://chorny.net
Subject: Re: [rt.cpan.org #82987] old Module::Install
Date: Sun, 27 Jan 2013 13:15:56 -0500
To: Alexandr Ciornii via RT <bug-IPC-Run-SafeHandles [...] rt.cpan.org>
From: Jesse Vincent <jesse [...] fsck.com>
Download (untitled) / with headers
text/plain 681b
On Sun, Jan 27, 2013 at 01:10:04PM -0500, Alexandr Ciornii via RT wrote: Show quoted text
> Queue: IPC-Run-SafeHandles > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=82987 > > > On Sun Jan 27 13:04:30 2013, jesse@fsck.com wrote:
> > > > Can you explain why Auto-install is a problem requiring a module > > re-release (other than finding the feature distasteful)?
> > I'm not sure if this requires a release. This question requires human > intervention and installation does not proceed before it is answered. > Newer version of M::I do not ask it when run under CPAN/CPANPLUS.
Does it not honor PERL_MM_USE_DEFUALT? Show quoted text
> > -- > Alexandr Ciornii, http://chorny.net >
--
Download (untitled) / with headers
text/plain 291b
On Sun Jan 27 13:16:03 2013, jesse@fsck.com wrote: Show quoted text
> > Newer version of M::I do not ask it when run under CPAN/CPANPLUS.
> > Does it not honor PERL_MM_USE_DEFUALT?
It uses prompt from EU::MM, so it should. But not all CPAN users will have it set. -- Alexandr Ciornii, http://chorny.net
Subject: Re: [rt.cpan.org #82987] old Module::Install
Date: Sun, 27 Jan 2013 13:20:01 -0500
To: Alexandr Ciornii via RT <bug-IPC-Run-SafeHandles [...] rt.cpan.org>
From: Jesse Vincent <jesse [...] fsck.com>
Download (untitled) / with headers
text/plain 428b
Show quoted text
> On Sun Jan 27 13:16:03 2013, jesse@fsck.com wrote: >
> > > Newer version of M::I do not ask it when run under CPAN/CPANPLUS.
> > > > Does it not honor PERL_MM_USE_DEFUALT?
> > It uses prompt from EU::MM, so it should. But not all CPAN users will > have it set.
To be clear, are you asking us to re-release with a newer version of Module::Install with an updated AutoInstall or are you asking us to remove AutoInstall? --
Download (untitled) / with headers
text/plain 740b
On Sun Jan 27 13:20:08 2013, jesse@fsck.com wrote: Show quoted text
> > On Sun Jan 27 13:16:03 2013, jesse@fsck.com wrote: > >
> > > > Newer version of M::I do not ask it when run under CPAN/CPANPLUS.
> > > > > > Does it not honor PERL_MM_USE_DEFUALT?
> > > > It uses prompt from EU::MM, so it should. But not all CPAN users will > > have it set.
> > To be clear, are you asking us to re-release with a newer version of > Module::Install with an updated AutoInstall or are you asking us to > remove AutoInstall?
I'm asking you to update M::I before next release. In general, M::I has many improvements from version 0.68. Moving Test::More from requires into test_requires and adding META.* is also a good idea. -- Alexandr Ciornii, http://chorny.net


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.