Skip Menu |
 

This queue is for tickets about the AnyData CPAN distribution.

Report information
The Basics
Id: 82862
Status: resolved
Priority: 0/
Queue: AnyData

People
Owner: Nobody in particular
Requestors: Frank.Lichtenheld [...] Sophos.com
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: 0.11
Fixed in: (no value)



Subject: Makefile.PL not compatible with old perls
Download (untitled) / with headers
text/plain 1.2k
Fails with my perl 5.10: [ 17s] + /usr/bin/perl Makefile.PL INSTALLDIRS=site [ 18s] WARNING: AUTHOR takes a string/number not a ARRAY reference. [ 18s] Please inform the author. [ 18s] Warning: prerequisite Test::Output 0.01 not found. [ 18s] Checking if your kit is complete... [ 18s] Warning: the following files are missing in your kit: [ 18s] Debian_CPANTS.txt [ 18s] Please inform the author. [ 18s] only nested arrays of non-refs are supported at /usr/local/ap510/lib/ExtUtils/MakeMaker.pm line 664 [ 18s] error: Bad exit status from /var/tmp/rpm-tmp.47750 (%build) The following patch fixes the problem: Index: AnyData-0.11/Makefile.PL =================================================================== --- AnyData-0.11.orig/Makefile.PL +++ AnyData-0.11/Makefile.PL @@ -33,7 +33,7 @@ ExtUtils::MakeMaker::WriteMakefile( ( 'LICENSE' => 'perl', ) : () ), ( - $ExtUtils::MakeMaker::VERSION >= 5.43 + $ExtUtils::MakeMaker::VERSION >= 6.57_02 ? ( 'AUTHOR' => [ 'Jeff Zucker (jeff@vpservices.com)', 6.57_02 is the version that got multiple AUTHOR support according to changelog of ExtUtils::MakeMaker
Fixed in 0.12.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.