Skip Menu |
 

This queue is for tickets about the Perl-MinimumVersion CPAN distribution.

Report information
The Basics
Id: 82718
Status: resolved
Priority: 0/
Queue: Perl-MinimumVersion

People
Owner: Nobody in particular
Requestors: melo [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 1.31
Fixed in: (no value)



Subject: [PATCH] A sub named each, keys or values infers 5.014
Download (untitled) / with headers
text/plain 282b
Hello, one of my packages has a method named keys. This makes Perl::MinimumVersion report 5.014 as the minimal version. The attached file solves the problem, but my knowledge of PPI is pretty much non-existing so I don't know it is the correct fix. Thanks, -- Hi, how are you?
Subject: minimum-version.patch
--- MinimumVersion.pm.orig 2013-01-15 13:19:10.000000000 +0000 +++ MinimumVersion.pm 2013-01-15 13:18:44.000000000 +0000 @@ -633,6 +633,8 @@ } } elsif($next->isa('PPI::Token::Operator')) { # % $a return ''; + } elsif($_[1]->parent->isa('PPI::Statement::Sub')) { # sub each|keys|values + return ''; } else { # function call or other should be reference if(5.014 > ($version || 0)) { $version = 5.014;
Download (untitled) / with headers
text/plain 273b
On Tue Jan 15 08:23:22 2013, MELO wrote: Show quoted text
> Hello, > > one of my packages has a method named keys. This makes > Perl::MinimumVersion report 5.014 > as the minimal version. > > The attached file solves the problem
Applied in 1.32. -- Alexandr Ciornii, http://chorny.net
Subject: Re: [rt.cpan.org #82718] [PATCH] A sub named each, keys or values infers 5.014
Date: Wed, 16 Jan 2013 19:20:56 +0000
To: bug-Perl-MinimumVersion [...] rt.cpan.org
From: Pedro Melo <melo [...] simplicidade.org>
Download (untitled) / with headers
text/plain 608b
Thanks :) On Wed, Jan 16, 2013 at 7:14 PM, Alexandr Ciornii via RT < bug-Perl-MinimumVersion@rt.cpan.org> wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=82718 > > > On Tue Jan 15 08:23:22 2013, MELO wrote:
> > Hello, > > > > one of my packages has a method named keys. This makes > > Perl::MinimumVersion report 5.014 > > as the minimal version. > > > > The attached file solves the problem
> > Applied in 1.32. > > -- > Alexandr Ciornii, http://chorny.net > >
-- Pedro Melo @pedromelo http://www.simplicidade.org/ http://about.me/melo xmpp:melo@simplicidade.org mailto:melo@simplicidade.org


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.