This queue is for tickets about the Locale-SubCountry CPAN distribution.

Report information
The Basics
Id:
82717
Status:
resolved
Priority:
Low/Low

People
Owner:
kimryan [...] cpan.org
Requestors:
ppisar [...] redhat.com
Cc:
AdminCc:

BugTracker
Severity:
(no value)
Broken in:
1.57
Fixed in:
(no value)



Subject: Test::Pod version mismatch
META.yml requieres Test::Pod 1.44, but the only occurrence in t/pod.t checks for version 1.00. One of these two should be changed to match each other.
On Tue Jan 15 08:09:27 2013, ppisar wrote:
Show quoted text
> META.yml requieres Test::Pod 1.44, but the only occurrence in t/pod.t > checks for version 1.00. One of these two should be changed to match > each other.
Thanks for raising this issue. From my understanding when you create the Makefile, Module::Build (or some other module) works out the dependancies and versions and creates the META.yml file. I'm not sure why it is setting the Test::Pod version to 1.44 In my code in pod.t I use: eval "use Test::Pod 1.00"; which should only check that at least version 1.00 is installed, and not cause a problem if a later version is there. This line of code is taken straight from the Test::Pod doco http://search.cpan.org/~dwheeler/Test-Pod- 1.45/lib/Test/Pod.pm#SYNOPSIS. I ran this single line of code on my PC and it worked fine, even though 1.45 of Test::Pod was installed. I checked a few other CPAN modules and they have exactly the same situation as me. http://cpansearch.perl.org/src/RSAVAGE/DBIx-Tree- 1.96/META.yml . So not sure what steps to take to solve this.
Subject: Re: [rt.cpan.org #82717] Test::Pod version mismatch
Date: Thu, 17 Jan 2013 14:22:12 +0100
To: Kim Ryan via RT <bug-Locale-SubCountry@rt.cpan.org>
From: Petr Pisar <ppisar@redhat.com>
On Wed, Jan 16, 2013 at 09:26:06PM -0500, Kim Ryan via RT wrote:
Show quoted text
> On Tue Jan 15 08:09:27 2013, ppisar wrote:
> > META.yml requieres Test::Pod 1.44, but the only occurrence in t/pod.t > > checks for version 1.00. One of these two should be changed to match > > each other.
> > Thanks for raising this issue. From my understanding when you create > the Makefile, Module::Build (or some other module) works out the > dependancies and versions and creates the META.yml file.
I think ExtUtils::MakeMaker just copies data from Makefile.PL where you explicitly states 1.44 version. The same applies to Build.PL.
Show quoted text
> I'm not sure why it is setting the Test::Pod version to 1.44 >
So this is not an automatism, but wrong input.
Show quoted text
> In my code in pod.t I use: > eval "use Test::Pod 1.00"; > which should only check that at least version 1.00 is installed, and > not cause a problem if a later version is there.
Yes, but CPAN and all the tools consumes META files to create dependency tree. Then our package requires 1.44 effectivelly which is overkill.
Show quoted text
> This line of code is > taken straight from the Test::Pod doco > http://search.cpan.org/~dwheeler/Test-Pod- > 1.45/lib/Test/Pod.pm#SYNOPSIS. I ran this single line of code on my PC > and it worked fine, even though 1.45 of Test::Pod was installed. >
The code in test is fine. I would say Makefile.PL and Build.PL are wrong.
Show quoted text
> I checked a few other CPAN modules and they have exactly the same > situation as me. http://cpansearch.perl.org/src/RSAVAGE/DBIx-Tree- > 1.96/META.yml . >
A lot of people have the versions wrong. I recommend to decrease the versions in Makefile.PL and Build.PL to 1.00. -- Petr

Message body not shown because it is not plain text.

On Thu Jan 17 08:22:31 2013, ppisar wrote:
Show quoted text
> On Wed, Jan 16, 2013 at 09:26:06PM -0500, Kim Ryan via RT wrote:
> > On Tue Jan 15 08:09:27 2013, ppisar wrote:
> > > META.yml requieres Test::Pod 1.44, but the only occurrence in
> t/pod.t
> > > checks for version 1.00. One of these two should be changed to
> match
> > > each other.
> > > > Thanks for raising this issue. From my understanding when you create > > the Makefile, Module::Build (or some other module) works out the > > dependancies and versions and creates the META.yml file.
> > I think ExtUtils::MakeMaker just copies data from Makefile.PL where > you > explicitly states 1.44 version. > > The same applies to Build.PL. >
> > I'm not sure why it is setting the Test::Pod version to 1.44 > >
> So this is not an automatism, but wrong input. >
> > In my code in pod.t I use: > > eval "use Test::Pod 1.00"; > > which should only check that at least version 1.00 is installed, and > > not cause a problem if a later version is there.
> > Yes, but CPAN and all the tools consumes META files to create > dependency tree. > Then our package requires 1.44 effectivelly which is overkill. >
> > This line of code is > > taken straight from the Test::Pod doco > > http://search.cpan.org/~dwheeler/Test-Pod- > > 1.45/lib/Test/Pod.pm#SYNOPSIS. I ran this single line of code on my
> PC
> > and it worked fine, even though 1.45 of Test::Pod was installed. > >
> The code in test is fine. I would say Makefile.PL and Build.PL are > wrong. >
> > I checked a few other CPAN modules and they have exactly the same > > situation as me. http://cpansearch.perl.org/src/RSAVAGE/DBIx-Tree- > > 1.96/META.yml . > >
> A lot of people have the versions wrong. > > I recommend to decrease the versions in Makefile.PL and Build.PL to > 1.00. > > -- Petr
Hi Petr, had another look and you are correct. The 1.44 version requirement for Test::Pod was put in there in error. I am planning to set the versions in Makefile.PL and Build.PL to 1.04 which came out in Jan 2004. From here http://cpansearch.perl.org/src/DWHEELER/Test-Pod- 1.45/Changes it seems to be the oldest version that implements most of the core features and is the best one to define as a minimum requirement.
Fixed in 1.59. Minimum versions required for Test::Pod set to 1.04


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.