Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the ZMQ-LibZMQ2 CPAN distribution.

Report information
The Basics
Id: 82613
Status: resolved
Priority: 0/
Queue: ZMQ-LibZMQ2

People
Owner: Nobody in particular
Requestors: lamoz [...] adriver.ru
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: (no value)
Fixed in: (no value)



Subject: Tests fail due to localized error messages
Download (untitled) / with headers
text/plain 686b
tests fail on my russian gentoo box for example: <snip> t/100_basic.t ..... # Failed test at t/100_basic.t line 19. # 'В соединении отказано' # doesn't match '(?-xism:Connection refused)' # Looks like you failed 1 test of 2. </snip> zeromq v2.1.0 perl v5.10.1 (*) built for x86_64-linux $ locale LANG=ru_RU.UTF-8 LC_CTYPE="ru_RU.UTF-8" LC_NUMERIC=POSIX LC_TIME="ru_RU.UTF-8" LC_COLLATE="ru_RU.UTF-8" LC_MONETARY="ru_RU.UTF-8" LC_MESSAGES="ru_RU.UTF-8" LC_PAPER="ru_RU.UTF-8" LC_NAME="ru_RU.UTF-8" LC_ADDRESS="ru_RU.UTF-8" LC_TELEPHONE="ru_RU.UTF-8" LC_MEASUREMENT="ru_RU.UTF-8" LC_IDENTIFICATION="ru_RU.UTF-8" LC_ALL=
Download (untitled) / with headers
text/plain 184b
It would be nice if you could pinpoint which env var is the culprit. Or, I could just empty out All LC_*, but either way I'd love it you if you could verify in your environment first.
From: lamoz [...] adriver.ru
Download (untitled) / with headers
text/plain 157b
On Thu Jan 10 17:38:43 2013, DMAKI wrote: Show quoted text
> It would be nice if you could pinpoint which env var is the culprit.
tests pass with LC_MESSAGES="en_GB.UTF-8"
Download (untitled) / with headers
text/plain 162b
You rock. Can you check if this branch works? https://github.com/lestrrat/p5-ZMQ/tree/topic/lc-messages (Build instructions: https://github.com/lestrrat/p5-ZMQ)
From: lamoz [...] adriver.ru
Download (untitled) / with headers
text/plain 635b
On Fri Jan 11 04:16:47 2013, DMAKI wrote: Show quoted text
> You rock. Can you check if this branch works?
ZMQ::LibZMQ2 is not fixed. Same message happens. but >>LC_MESSAGES="en_GB.UTF-8" make test<< fixes the problem BTW, ZMQ::LibZMQ3 have the same problem in 100_basic.t Also LibZMQ3 prints "+ found libzmq 2.2.0" during perl Makefile.PL but links aganst zmq 3.2.2 I have actually strange setup, zmq3 and zmq2 are installed both in system paths so ZMQ::LibZMQ3 finds one lib and links against the other. And I have to hack Makefile for ZMQ::LibZMQ2 to compile and install. But I think it's ok since no normal civilian should have my setup.
On 2013-1月-11 金 05:42:52, lamoz wrote: Show quoted text
> On Fri Jan 11 04:16:47 2013, DMAKI wrote:
> > You rock. Can you check if this branch works?
> > ZMQ::LibZMQ2 is not fixed. Same message happens. > but >>LC_MESSAGES="en_GB.UTF-8" make test<< fixes the problem
Just to make sure, you did try the version from the git repo? Show quoted text
> BTW, ZMQ::LibZMQ3 have the same problem in 100_basic.t
Yeah, but I'd like to apply the same fix after I get LibZMQ2 right. Show quoted text
> Also LibZMQ3 prints "+ found libzmq 2.2.0" during perl Makefile.PL but > links aganst zmq 3.2.2 I have actually strange setup, zmq3 and zmq2 are > installed both in system paths so ZMQ::LibZMQ3 finds one lib and links > against the other. And I have to hack Makefile for ZMQ::LibZMQ2 to > compile and install. But I think it's ok since no normal civilian should > have my setup.
I get it's what I have at the https://github.com/lestrrat/p5-ZMQ README. I don't have a particularly elegant (automatic) solution, other than removing -L from LDDLFLAGS and LDDFLAGS and adding them to LDLOADLIBS and EXTRALIBS. I kinda feel it's too much, so I haven't committed it.
From: lamoz [...] adriver.ru
Download (untitled) / with headers
text/plain 417b
Show quoted text
> Just to make sure, you did try the version from the git repo?
yeap, double-checked. I did even try to place $ENV{} assignment into BEGIN block of 100_basic.t That did not solve the problem. Show quoted text
> I get it's what I have at the https://github.com/lestrrat/p5-ZMQ > README.
My problem occurs before linking. I have to rename -I option of gcc to - isystem. gcc discards -I since both zmq versions are in system path.
Download (untitled) / with headers
text/plain 657b
On 2013-1月-11 金 07:03:03, lamoz wrote: Show quoted text
> > Just to make sure, you did try the version from the git repo?
> yeap, double-checked. I did even try to place $ENV{} assignment into > BEGIN block of 100_basic.t That did not solve the problem.
Was that BEGIN block before the use ZMQ::LibZMQ2 statement? If that didn't work, I think the next step would be to use POSIX::setlocale() Show quoted text
> > I get it's what I have at the https://github.com/lestrrat/p5-ZMQ > > README.
> > My problem occurs before linking. I have to rename -I option of gcc to - > isystem. gcc discards -I since both zmq versions are in system path.
oh yikes, not going to touch that.... :)
From: lamoz [...] adriver.ru
Download (untitled) / with headers
text/plain 251b
Show quoted text
> Was that BEGIN block before the use ZMQ::LibZMQ2 statement?
yes Show quoted text
> If that didn't work, I think the next step would be to use > POSIX::setlocale()
Checked. The test is happy with setlocale: Show quoted text
> POSIX::setlocale( &POSIX::LC_MESSAGES, "en_GB.UTF-8" );
Download (untitled) / with headers
text/plain 187b
Show quoted text
> Checked. The test is happy with setlocale:
> > POSIX::setlocale( &POSIX::LC_MESSAGES, "en_GB.UTF-8" );
Cool, so this works? https://github.com/lestrrat/p5-ZMQ/tree/topic/lc-messages
From: lamoz [...] adriver.ru
Download (untitled) / with headers
text/plain 101b
Show quoted text
works for me
closing.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.