This queue is for tickets about the HTTP-Daemon-SSL CPAN distribution.

Report information
The Basics
Id:
81932
Status:
open
Priority:
Low/Low

People
Owner:
Nobody in particular
Requestors:
CHORNY [...] cpan.org
terry.harple [...] gamil.com
Cc:
jquelin [...] cpan.org
rsrchboy [...] cpan.org
AdminCc:

BugTracker
Severity:
Critical
Broken in:
  • 1.04
  • 1.05_01
Fixed in:
(no value)



Subject: HTTP-Daemon-SSL fails to install - testmodule.t
CPAN.pm: Building A/AU/AUFFLICK/HTTP-Daemon-SSL-1.04.tar.gz Checking if your kit is complete... Looks good Writing Makefile for HTTP::Daemon::SSL Writing MYMETA.yml and MYMETA.json CPAN: Module::CoreList loaded ok (v2.76) cp SSL.pm blib\lib\HTTP\Daemon\SSL.pm AUFFLICK/HTTP-Daemon-SSL-1.04.tar.gz C:\strawberry\c\bin\dmake.exe -- OK Running make test C:\strawberry\perl\bin\perl.exe "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib\lib', 'blib\arch')" t/*.t t/loadmodule.t .. ok t/testmodule.t .. 1/9 Not a HASH reference at C:/strawberry/perl/vendor/lib/IO/Socket/SSL.pm line 600. Terminating on signal SIGINT(2) Clean Install of http://strawberry-perl.googlecode.com/files/strawberry- perl-5.16.2.1-64bit.msi Clean Install of Modules: AppConfig CGI CGI::Ajax Compress::Zlib Crypt::OpenSSL::RSA Crypt::OpenSSL::Random Cwd Data::Dumper Data::UUID Digest::HMAC_SHA1 Digest::SHA1 HTTP::Request::Common HTTP::Request IO::Select IO::Socket IPC::Run3 LWP::ConnCache LWP::Protocol::http LWP::UserAgent List::Util MIME::Base64 Math::BaseCalc Net::Ping SVG Socket Storable Template::Declare Thread::Queue::Any Thread::Semaphore Time::HiRes Win32::Process Win32 XML::LibXML::XPathContext XML::LibXML XML::Simple Net::SSH2 OpenSSL fix: http://www.perlmonks.org/?node_id=978326 IO::Sockets::SSL works w/o issue. I tried debugging but w/o success. So many other modules depend on this I hope you or someone has the chance to look into and fix this. TIA tharple
If this is still an issue for you, try downgrading IO::Socket:SSL to version 1.80 or earlier. 1.81 appears to have introduced some issue with HTTP::Daemon:SSL, which is still present as of the latest version, 1.88. I've opened ticket #85278 with the IO::Socket::SSL folks.
Am Di 14. Mai 2013, 03:43:58, MORTY schrieb:
Show quoted text
> If this is still an issue for you, try downgrading IO::Socket:SSL to > version 1.80 or earlier. 1.81 appears to have introduced some > issue with HTTP::Daemon:SSL, which is still present as of the > latest version, 1.88. I've opened ticket #85278 with the > IO::Socket::SSL folks.
There are two bugs. The bug initially described here is fixed by installing at least IO::Socket::IP version 0.20, or by using IO::Socket::SSL version 1.89, which will not use older IO::Socket::IP versions. The other one is a bug in the test, where it spcifies the SSL_cert_file but not the SSL_key_file. Up to IO::Socket::SSL 1.80 it would use a default, which happened to work in this case. With 1.81 it requires to specify cert and key and will use builtin defaults only if neither key nor cert is specified. Fix for the test: --- t/testmodule.t.orig 2013-05-14 15:46:10.261542061 +0200 +++ t/testmodule.t 2013-05-14 15:31:49.959313848 +0200 @@ -59,7 +59,8 @@ ReuseAddr => 1, SSL_verify_mode => 0x00, SSL_ca_file => "certs/test-ca.pem", - SSL_cert_file => "certs/server-cert.pem"); + SSL_cert_file => "certs/server-cert.pem", + SSL_key_file => "certs/server-key.pem");


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.