Skip Menu |
 

This queue is for tickets about the Wx CPAN distribution.

Report information
The Basics
Id: 81416
Status: stalled
Priority: 0/
Queue: Wx

People
Owner: Nobody in particular
Requestors: aduitsis [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 0.9914
Fixed in: (no value)



Subject: build broken on macosx - perl 5.14 - wx2.9.4
Download (untitled) / with headers
text/plain 917b
Hi, I have a 5.14 perl on mac os x 10.6 and I am trying to build wx 0.9914. My Alien::wxWidgets says: perl -MAlien::wxWidgets=:dump -e 42 $VAR1 = { 'compiler_kind' => 'gcc', 'version' => '2.009004', 'build' => 'multi', 'key' => 'mac_2_9_4_uni_gcc_3_4', 'package' => Alien::wxWidgets::Config::mac_2_9_4_uni_gcc_3_4', 'compiler_version' => '3.4', 'mslu' => 0, 'unicode' => 1, 'toolkit' => 'mac', 'debug' => 0 }; (wxcocoa was installed via fink) and my build breaks when trying to compile Wx.c at that point: cpp/app.h: In member function 'virtual void wxPliApp::MacOpenFiles(const wxArrayString&)': cpp/app.h:73: error: expected primary-expression before ',' token This has to do with wxwidgets and not your module, right ? If so, please close the bug report straight away. Kind regards, Athanasios
Subject: Re: [rt.cpan.org #81416] build broken on macosx - perl 5.14 - wx2.9.4
Date: Sat, 24 Nov 2012 22:05:59 +0000
To: bug-Wx [...] rt.cpan.org
From: Mark Dootson <mark.dootson [...] znix.com>
Download (untitled) / with headers
text/plain 411b
Hi, On 24/11/2012 21:21, athanasios douitsis via RT wrote: Show quoted text
> This has to do with wxwidgets and not your module, right ? If so, please > close the bug report straight away. >
Err - no, Wx is completely broken on Mac for wxWidgets 2.9.4. I think the attached patch should work - though I haven't tested it yet. I'm just puzzled how I've managed to build my own Mac Wx versions. Thanks for the report Mark
Download app.patch
text/x-diff 2.1k

Message body is not shown because sender requested not to inline it.

Download (untitled) / with headers
text/plain 613b
On Sat Nov 24 17:06:24 2012, mark.dootson@znix.com wrote: Show quoted text
> Hi, > > On 24/11/2012 21:21, athanasios douitsis via RT wrote: >
> > This has to do with wxwidgets and not your module, right ? If so, please > > close the bug report straight away. > >
> > Err - no, Wx is completely broken on Mac for wxWidgets 2.9.4. I think > the attached patch should work - though I haven't tested it yet. > > I'm just puzzled how I've managed to build my own Mac Wx versions. > > Thanks for the report > > Mark
Hi Mark, Yes, that worked, build completed. Many thanks. Closing the ticket now. Kind regards, Athanasios
CC: MDOOTSON [...] cpan.org
Subject: Re: [rt.cpan.org #81416] build broken on macosx - perl 5.14 - wx2.9.4
Date: Sun, 25 Nov 2012 01:00:42 +0200
To: bug-Wx [...] rt.cpan.org
From: Athanasios Douitsis <aduitsis [...] cpan.org>
Download (untitled) / with headers
text/plain 3.3k
Btw, 01load.t fails with segfault. So the prove output is not too helpful. I think it dies after the use_ok 'Wx'. What's interesting, the test succeeds, but then perl segfaults right away. Rest of the tests go ok, oddly enough :) Kind regards, Athanasios prove -v -b t/01_load.t t/01_load.t .. 1..6 ok 1 - use Wx; Failed 5/6 subtests Test Summary Report ------------------- t/01_load.t (Wstat: 10 Tests: 1 Failed: 0) Non-zero wait status: 10 Parse errors: Bad plan. You planned 6 tests but ran 1. Files=1, Tests=1, 0 wallclock secs ( 0.04 usr 0.01 sys + 0.15 cusr 0.03 csys = 0.23 CPU) Result: FAIL On Sun, Nov 25, 2012 at 12:06 AM, Mark Dootson via RT <bug-Wx@rt.cpan.org>wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=81416 > > > Hi, > > On 24/11/2012 21:21, athanasios douitsis via RT wrote: >
> > This has to do with wxwidgets and not your module, right ? If so, please > > close the bug report straight away. > >
> > Err - no, Wx is completely broken on Mac for wxWidgets 2.9.4. I think > the attached patch should work - though I haven't tested it yet. > > I'm just puzzled how I've managed to build my own Mac Wx versions. > > Thanks for the report > > Mark > > > --- cpp/app.h 2012-09-26 15:23:47.349000000 +0100 > +++ cpp/app.h 2012-11-24 21:53:04.922000000 +0000 > @@ -70,7 +70,7 @@ > { > AV* files; > files = wxPli_stringarray_2_av( aTHX_ fileNames ); > - wxPliCCback( aTHX, &m_callback, G_DISCARD|G_SCALAR, > + wxPliCCback( aTHX_ &m_callback, G_DISCARD|G_SCALAR, > "S", sv_2mortal( newRV_noinc( (SV*)files ) ) ); > } else > wxApp::MacOpenFiles( fileNames ); > @@ -81,7 +81,7 @@ > dTHX; > if( wxPliFCback( aTHX_ &m_callback, "MacOpenFile" ) ) > { > - wxPliCCback( aTHX, &m_callback, G_DISCARD|G_SCALAR, "P", > &fileName ); > + wxPliCCback( aTHX_ &m_callback, G_DISCARD|G_SCALAR, "P", > &fileName ); > } else > wxApp::MacOpenFile( fileName ); > } > @@ -91,7 +91,7 @@ > dTHX; > if( wxPliFCback( aTHX_ &m_callback, "MacOpenURL" ) ) > { > - wxPliCCback( aTHX, &m_callback, G_DISCARD|G_SCALAR, "P", &url > ); > + wxPliCCback( aTHX_ &m_callback, G_DISCARD|G_SCALAR, "P", &url > ); > } else > wxApp::MacOpenURL( url ); > } > @@ -101,7 +101,7 @@ > dTHX; > if( wxPliFCback( aTHX_ &m_callback, "MacPrintFile" ) ) > { > - wxPliCCback( aTHX, &m_callback, G_DISCARD|G_SCALAR, "P", > &fileName ); > + wxPliCCback( aTHX_ &m_callback, G_DISCARD|G_SCALAR, "P", > &fileName ); > } else > wxApp::MacPrintFile( fileName ); > } > @@ -111,7 +111,7 @@ > dTHX; > if( wxPliFCback( aTHX_ &m_callback, "MacNewFile" ) ) > { > - wxPliCCback( aTHX, &m_callback, G_DISCARD|G_SCALAR, NULL ); > + wxPliCCback( aTHX_ &m_callback, G_DISCARD|G_SCALAR, NULL ); > } else > wxApp::MacNewFile(); > } > @@ -121,7 +121,7 @@ > dTHX; > if( wxPliFCback( aTHX_ &m_callback, "MacReopenApp" ) ) > { > - wxPliCCback( aTHX, &m_callback, G_DISCARD|G_SCALAR, NULL ); > + wxPliCCback( aTHX_ &m_callback, G_DISCARD|G_SCALAR, NULL ); > } else > wxApp::MacReopenApp(); > } > >
Subject: Re: [rt.cpan.org #81416] build broken on macosx - perl 5.14 - wx2.9.4
Date: Sun, 25 Nov 2012 04:39:58 +0000
To: bug-Wx [...] rt.cpan.org
From: Mark Dootson <mark.dootson [...] znix.com>
Download (untitled) / with headers
text/plain 914b
Hi, On 24/11/2012 23:00, athanasios douitsis via RT wrote: Show quoted text
> Queue: Wx > Ticket<URL: https://rt.cpan.org/Ticket/Display.html?id=81416> > > Btw, 01load.t fails with segfault. So the prove output is not too helpful. > I think it dies after the use_ok 'Wx'. What's interesting, the test > succeeds, but then perl segfaults right away. > > Rest of the tests go ok, oddly enough :)
You need to build wxWidgets using Alien::wxWidgets which patches version 2.9.4. The error in wxWidgets 2.9.4 is fixed in the trunk of that project, but the released 2.9.4 is broken. see http://trac.wxwidgets.org/ticket/14483 The wxWidgets bug only appears in applications like wxPerl that load the wxWidgets libraries as plugins. It will be a couple of days before I can test a re-release of Wx fixing the issues in app.h for MacOSX but it will not work anyway on a none patched version of wxWidgets. Regards Mark
Subject: Re: [rt.cpan.org #81416] build broken on macosx - perl 5.14 - wx2.9.4
Date: Mon, 26 Nov 2012 07:56:24 +0200
To: bug-Wx [...] rt.cpan.org
From: Athanasios Douitsis <aduitsis [...] cpan.org>
Download (untitled) / with headers
text/plain 1.3k
Hi, Thanks for the info, unfortunately I am using wxwidgets from fink. Oh well, maybe I'll try to uninstall and have Alien::Wx install it for me. Or, I could try and take the patch from Alien and apply it to the fink source before rebuilding. Thanks a lot, Athanasios On Sun, Nov 25, 2012 at 6:40 AM, Mark Dootson via RT <bug-Wx@rt.cpan.org>wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=81416 > > > Hi, > > On 24/11/2012 23:00, athanasios douitsis via RT wrote:
> > Queue: Wx > > Ticket<URL: https://rt.cpan.org/Ticket/Display.html?id=81416> > > > > Btw, 01load.t fails with segfault. So the prove output is not too
> helpful.
> > I think it dies after the use_ok 'Wx'. What's interesting, the test > > succeeds, but then perl segfaults right away. > > > > Rest of the tests go ok, oddly enough :)
> > You need to build wxWidgets using Alien::wxWidgets which patches version > 2.9.4. The error in wxWidgets 2.9.4 is fixed in the trunk of that > project, but the released 2.9.4 is broken. > > see http://trac.wxwidgets.org/ticket/14483 > > The wxWidgets bug only appears in applications like wxPerl that load the > wxWidgets libraries as plugins. > > It will be a couple of days before I can test a re-release of Wx fixing > the issues in app.h for MacOSX but it will not work anyway on a none > patched version of wxWidgets. > > Regards > > Mark > > >
Subject: Re: [rt.cpan.org #81416] build broken on macosx - perl 5.14 - wx2.9.4
Date: Mon, 26 Nov 2012 04:42:17 -0200
To: bug-Wx [...] rt.cpan.org
From: breno <oainikusama [...] gmail.com>
Download (untitled) / with headers
text/plain 2.5k
Hey guys, just so you know, I'm also having trouble installing Wx on OS X. Might be the same issue, sadly I don't have enough time right now to poke at it, so I figured I should at least let you know :) In case it helps, I'm using blead perl from within perlbrew. My "perl -V" is: http://paste.scsys.co.uk/215360 Alien::wxWidgets 0.62 installed successfully from CPAN. I didn't have wxWidgets installed before (at least not that I can tell). This is the output I get when trying perl Makefile.PL && make: http://paste.scsys.co.uk/215361 and this is what I get after "make test": http://paste.scsys.co.uk/215362 Cheers! garu On Mon, Nov 26, 2012 at 3:56 AM, athanasios douitsis via RT <bug-Wx@rt.cpan.org> wrote: Show quoted text
> Mon Nov 26 00:56:37 2012: Request 81416 was acted upon. > Transaction: Correspondence added by ADUITSIS > Queue: Wx > Subject: Re: [rt.cpan.org #81416] build broken on macosx - perl 5.14 - wx2.9.4 > Broken in: 0.9914 > Severity: (no value) > Owner: Nobody > Requestors: aduitsis@cpan.org > Status: open > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=81416 > > > > Hi, > > Thanks for the info, unfortunately I am using wxwidgets from fink. Oh well, > maybe I'll try to uninstall and have Alien::Wx install it for me. Or, I > could try and take the patch from Alien and apply it to the fink source > before rebuilding. > > Thanks a lot, > Athanasios > > On Sun, Nov 25, 2012 at 6:40 AM, Mark Dootson via RT <bug-Wx@rt.cpan.org>wrote: >
>> <URL: https://rt.cpan.org/Ticket/Display.html?id=81416 > >> >> Hi, >> >> On 24/11/2012 23:00, athanasios douitsis via RT wrote:
>> > Queue: Wx >> > Ticket<URL: https://rt.cpan.org/Ticket/Display.html?id=81416> >> > >> > Btw, 01load.t fails with segfault. So the prove output is not too
>> helpful.
>> > I think it dies after the use_ok 'Wx'. What's interesting, the test >> > succeeds, but then perl segfaults right away. >> > >> > Rest of the tests go ok, oddly enough :)
>> >> You need to build wxWidgets using Alien::wxWidgets which patches version >> 2.9.4. The error in wxWidgets 2.9.4 is fixed in the trunk of that >> project, but the released 2.9.4 is broken. >> >> see http://trac.wxwidgets.org/ticket/14483 >> >> The wxWidgets bug only appears in applications like wxPerl that load the >> wxWidgets libraries as plugins. >> >> It will be a couple of days before I can test a re-release of Wx fixing >> the issues in app.h for MacOSX but it will not work anyway on a none >> patched version of wxWidgets. >> >> Regards >> >> Mark >> >> >>
>
Download (untitled) / with headers
text/plain 107b
The main issue here is with wxWidgets 2.9.4. Marked ticket as stalled waithing for wxWidgets 2.9.5 release


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.