Skip Menu |
 

This queue is for tickets about the XML-Twig CPAN distribution.

Report information
The Basics
Id: 8138
Status: resolved
Priority: 0/
Queue: XML-Twig

People
Owner: MIROD [...] cpan.org
Requestors: francis [...] flourish.org
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: 3.15
Fixed in: 3.16



Subject: Undefined subroutine &XML::Twig::encode
Download (untitled) / with headers
text/plain 374b
When I use Twig from my script I get the following error: Undefined subroutine &XML::Twig::encode called at /usr/local/lib/perl5/site_perl/5.8.5/XML/Twig.pm line 3343. If I alter eval "use Encode qw( :fallback_all)"; in Twig.m to say eval "use Encode qw(encode :fallback_all)"; It works fine. I'm running Twig 3.15 on Perl 5.8.5, both installed using FreeBSD ports.
Download (untitled) / with headers
text/plain 109b
Hi, Thanks, I will apply it the fix, test it tonight and post a new development version tomorrow. __ Mirod
Download (untitled) / with headers
text/plain 560b
[guest - Wed Oct 27 10:36:32 2004]: Show quoted text
> When I use Twig from my script I get the following error: > > Undefined subroutine &XML::Twig::encode called at > /usr/local/lib/perl5/site_perl/5.8.5/XML/Twig.pm line 3343. > > If I alter > eval "use Encode qw( :fallback_all)"; > in Twig.m to say > eval "use Encode qw(encode :fallback_all)"; > It works fine. > > I'm running Twig 3.15 on Perl 5.8.5, both installed using FreeBSD > ports.
The development version at http://xmltwig.com/xmltwig/ should be fixed, let me know if it works for you. Thanks __ Mirod


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.