Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the Config-Model-OpenSsh CPAN distribution.

Report information
The Basics
Id:
81346
Status:
resolved
Priority:
Low/Low

People
Owner:
Nobody in particular
Requestors:
dolmen [...] cpan.org
Cc:
AdminCc:

BugTracker
Severity:
Normal
Broken in:
1.225
Fixed in:
1.226



Subject: Support for OpenSSH 5.9 options
"cme edit ssh" crashes badly if my ~/.ssh/config contains OpenSSH 5.9 option "RequestTTY". Could you: - report unsupported options in a nicer way - add support for OpenSSH 5.9 -- Olivier Mengué - http://perlresume.org/DOLMEN
On Thu Nov 22 16:24:12 2012, DOLMEN wrote:
Show quoted text
> > "cme edit ssh" crashes badly if my ~/.ssh/config contains OpenSSH 5.9 > option "RequestTTY". > > Could you: > - report unsupported options in a nicer way > - add support for OpenSSH 5.9
Ack. What do you mean by "crashes badly" ? IIRC, an error message is generated reporting the unsupported parameter. What's wrong with it ? Anyway, I acknowledge that I have some trouble following ssh features. I'm writing a wiki page so user can help improve the model to add missing parameters (https://github.com/dod38fr/config-model/wiki/New-parameter-for-openssh-example). I'll properly announce this page, once I'm done with it. Feel free to try it (and suggest improvements). All the best
Error message were improved in Config::Model 2.028 Added ControlPersist and RequestTty parameters in OpenSsh model 1.226 All the best


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.