Skip Menu |

This queue is for tickets about the Module-Install CPAN distribution.

Report information
The Basics
Id: 81331
Status: open
Priority: 0/
Queue: Module-Install

Owner: Nobody in particular
Requestors: dolmen [...]
kjetilk [...]

Bug Information
Severity: Wishlist
Broken in: (no value)
Fixed in: (no value)

Subject: Support for advanced version ranges
It seems like Test::RDF has breakage for Scalar::Util 1.23 and only for that version. So, I'd like to express that in makefile.ttl somehow, and it seems like I should be able to do that: I tried this: but it failed: *** Module::AutoInstall version 1.06 *** Checking for Perl dependencies... [Core Features] - Test::Tester ...loaded. (0.107) - RDF::Trine ...loaded. (1.002 >= 0.134) - Test::More ...loaded. (0.98) - Scalar::Util ...loaded. (1.25) - !=1.23 ...missing. - Test::Builder::Module ...loaded. (0.98) I assume that the problem may be rather deep in the stack, since putting requires 'Scalar::Util' => '!= 1.23'; in Makefile.PL fails similarly. I suppose I'd need to stuff a hash with a version key in there, but I also suppose this module can't do that. So, my question is if this is something that this module could support? It would be nice to be able to not force more than necessary in the prereqs. Best, Kjetil
Download (untitled) / with headers
text/plain 505b
I've moved this ticket to Module-Install, as the it seems to Module- Install doesn't support advanced version ranges. Module-Package-RDF is built on Module-Install. In the mean time I'd suggest doing something like this in your Makefile.PL use Scalar::Util; warn <<'OPENHANDLE' if Scalar::Util->VERSION == 1.23; **** **** Scalar::Util 1.23 has a broken implementation of openhandle(). **** Please upgrade your Scalar::Util. **** OPENHANDLE You could be even more forceful and die instead of warning.

This service is sponsored and maintained by Best Practical Solutions and runs on infrastructure.

Please report any issues with to