Skip Menu |
 

This queue is for tickets about the XML-LibXML CPAN distribution.

Report information
The Basics
Id: 81291
Status: resolved
Priority: 0/
Queue: XML-LibXML

People
Owner: Nobody in particular
Requestors: lxp [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 2.0012
Fixed in: (no value)



Subject: tests fail due to "undefined symbol: xmlMemMalloc" errors
Attempting to install XML::LibXML v2.0012 into a Perlbrew environment running Perl v5.12.3 on a 64-bit Ubuntu Linux Desktop machine fails with these errors (one per test): Can't load '.../XML-LibXML-2.0012/blib/arch/auto/XML/LibXML/LibXML.so' for module XML::LibXML: .../XML-LibXML- 2.0012/blib/arch/auto/XML/LibXML/LibXML.so: undefined symbol: xmlMemMalloc at .../perl-5.12.3/lib/5.12.3/x86_64-linux/DynaLoader.pm line 200. at .../perl-5.12.3/lib/5.12.3/x86_64-linux/DynaLoader.pm line 154. BEGIN failed--compilation aborted at .../XML-LibXML- 2.0012/blib/lib/XML/LibXML.pm line 154. Debian packages libxml2 and libxml2-dev are both installed on the system. These earlier "configure" warnings seem relevant (and contradictory): Checking for ability to link against xml2...yes Checking if your kit is complete... Looks good Note (probably harmless): No library found for -lxml2 Note (probably harmless): No library found for -lz Attached files provide a complete log of the module installation attempt, Perl installation details and libxml2 Debian package details.
Subject: cpanm.txt
Download cpanm.txt
text/plain 71.3k

Message body is not shown because it is too large.

Subject: perl-V.txt
Download perl-V.txt
text/plain 2.3k
Summary of my perl5 (revision 5 version 12 subversion 3) configuration: Platform: osname=linux, osvers=2.6.35-28-generic, archname=x86_64-linux uname='linux pluto 2.6.35-28-generic #49-ubuntu smp tue mar 1 14:39:03 utc 2011 x86_64 gnulinux ' config_args='-de -Dprefix=/home/lx/perl5/perlbrew/perls/perl-5.12.3' hint=recommended, useposix=true, d_sigaction=define useithreads=undef, usemultiplicity=undef useperlio=define, d_sfio=undef, uselargefiles=define, usesocks=undef use64bitint=define, use64bitall=define, uselongdouble=undef usemymalloc=n, bincompat5005=undef Compiler: cc='cc', ccflags ='-fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64', optimize='-O2', cppflags='-fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include' ccversion='', gccversion='4.4.5', gccosandvers='' intsize=4, longsize=8, ptrsize=8, doublesize=8, byteorder=12345678 d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16 ivtype='long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8 alignbytes=8, prototype=define Linker and Libraries: ld='cc', ldflags =' -fstack-protector -L/usr/local/lib' libpth=/usr/local/lib /lib /usr/lib /lib64 /usr/lib64 libs=-lnsl -ldl -lm -lcrypt -lutil -lc perllibs=-lnsl -ldl -lm -lcrypt -lutil -lc libc=/lib/libc-2.12.1.so, so=so, useshrplib=false, libperl=libperl.a gnulibc_version='2.12.1' Dynamic Linking: dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-Wl,-E' cccdlflags='-fPIC', lddlflags='-shared -O2 -L/usr/local/lib -fstack-protector' Characteristics of this binary (from libperl): Compile-time options: PERL_DONT_CREATE_GVSV PERL_MALLOC_WRAP USE_64_BIT_ALL USE_64_BIT_INT USE_LARGE_FILES USE_PERLIO USE_PERL_ATOF Built under linux Compiled at Mar 24 2011 16:07:42 %ENV: PERLBREW_PATH="/home/lx/perl5/perlbrew/bin:/home/lx/perl5/perlbrew/perls/current/bin" PERLBREW_PERL="perl-5.12.3" PERLBREW_ROOT="/home/lx/perl5/perlbrew" PERLBREW_VERSION="0.18" @INC: /home/lx/perl5/perlbrew/perls/perl-5.12.3/lib/site_perl/5.12.3/x86_64-linux /home/lx/perl5/perlbrew/perls/perl-5.12.3/lib/site_perl/5.12.3 /home/lx/perl5/perlbrew/perls/perl-5.12.3/lib/5.12.3/x86_64-linux /home/lx/perl5/perlbrew/perls/perl-5.12.3/lib/5.12.3 .
Subject: libxml2.txt
Download libxml2.txt
text/plain 6k
$ apt-cache show libxml2 libxml2-dev Package: libxml2 Priority: optional Section: libs Installed-Size: 1757 Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com> Original-Maintainer: Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org> Architecture: amd64 Version: 2.8.0+dfsg1-5ubuntu2 Depends: libc6 (>= 2.15), liblzma5 (>= 5.1.1alpha+20120614), zlib1g (>= 1:1.2.3.3) Pre-Depends: multiarch-support Recommends: xml-core Filename: pool/main/libx/libxml2/libxml2_2.8.0+dfsg1-5ubuntu2_amd64.deb Size: 679486 MD5sum: 528a0d939a70fbf6c14d384fc08efffb SHA1: 930e55f8d0609b489885a205c4e55a04c20c6d8f SHA256: b65cdbb8992e0309fcb4686e98ba7f4fd5c0e838806eeffdf1fd7b98e4687711 Description-en: GNOME XML library XML is a metalanguage to let you design your own markup language. A regular markup language defines a way to describe information in a certain class of documents (eg HTML). XML lets you define your own customized markup languages for many classes of document. It can do this because it's written in SGML, the international standard metalanguage for markup languages. . This package provides a library providing an extensive API to handle such XML data files. Multi-Arch: same Homepage: http://xmlsoft.org/ Description-md5: 6771e66f557fa0f71e6955303e1d8f8d Bugs: https://bugs.launchpad.net/ubuntu/+filebug Origin: Ubuntu Supported: 18m Task: virt-host, ubuntu-desktop, ubuntu-usb, print-server, postgresql-server, lamp-server, kubuntu-desktop, kubuntu-active-desktop, kubuntu-active, edubuntu-desktop, edubuntu-usb, xubuntu-desktop, mythbuntu-frontend, mythbuntu-frontend, mythbuntu-desktop, mythbuntu-backend-slave, mythbuntu-backend-slave, mythbuntu-backend-master, mythbuntu-backend-master, lubuntu-core, ubuntustudio-desktop Package: libxml2-dev Priority: optional Section: libdevel Installed-Size: 2797 Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com> Original-Maintainer: Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org> Architecture: amd64 Source: libxml2 Version: 2.8.0+dfsg1-5ubuntu2 Depends: libxml2 (= 2.8.0+dfsg1-5ubuntu2) Filename: pool/main/libx/libxml2/libxml2-dev_2.8.0+dfsg1-5ubuntu2_amd64.deb Size: 845548 MD5sum: 49b3e131585beb85581c57a4effcab9f SHA1: 57a2b5ec16e39fe51ed8c87bd8880971dc258037 SHA256: de286671d66493bdf5297fae9081c425aded786c31caa4c217260e7e8fc8541b Description-en: Development files for the GNOME XML library XML is a metalanguage to let you design your own markup language. A regular markup language defines a way to describe information in a certain class of documents (eg HTML). XML lets you define your own customized markup languages for many classes of document. It can do this because it's written in SGML, the international standard metalanguage for markup languages. . Install this package if you wish to develop your own programs using the GNOME XML library. Multi-Arch: same Homepage: http://xmlsoft.org/ Description-md5: 3fc5da551079ce5d27e8aae047e7a888 Bugs: https://bugs.launchpad.net/ubuntu/+filebug Origin: Ubuntu Supported: 18m $ dpkg -L libxml2 libxml2-dev /. /usr /usr/lib /usr/lib/x86_64-linux-gnu /usr/lib/x86_64-linux-gnu/libxml2.so.2.8.0 /usr/share /usr/share/lintian /usr/share/lintian/overrides /usr/share/lintian/overrides/libxml2 /usr/share/doc /usr/share/doc/libxml2 /usr/share/doc/libxml2/README /usr/share/doc/libxml2/README.Debian /usr/share/doc/libxml2/TODO.gz /usr/share/doc/libxml2/copyright /usr/share/doc/libxml2/NEWS.gz /usr/share/doc/libxml2/AUTHORS /usr/share/doc/libxml2/changelog.Debian.gz /usr/lib/x86_64-linux-gnu/libxml2.so.2 /. /usr /usr/lib /usr/lib/x86_64-linux-gnu /usr/lib/x86_64-linux-gnu/xml2Conf.sh /usr/lib/x86_64-linux-gnu/libxml2.a /usr/lib/x86_64-linux-gnu/pkgconfig /usr/lib/x86_64-linux-gnu/pkgconfig/libxml-2.0.pc /usr/include /usr/include/libxml2 /usr/include/libxml2/libxml /usr/include/libxml2/libxml/DOCBparser.h /usr/include/libxml2/libxml/xmlIO.h /usr/include/libxml2/libxml/xmlreader.h /usr/include/libxml2/libxml/nanohttp.h /usr/include/libxml2/libxml/encoding.h /usr/include/libxml2/libxml/parser.h /usr/include/libxml2/libxml/parserInternals.h /usr/include/libxml2/libxml/xmlexports.h /usr/include/libxml2/libxml/xmlerror.h /usr/include/libxml2/libxml/chvalid.h /usr/include/libxml2/libxml/entities.h /usr/include/libxml2/libxml/xpath.h /usr/include/libxml2/libxml/valid.h /usr/include/libxml2/libxml/xmlversion.h /usr/include/libxml2/libxml/catalog.h /usr/include/libxml2/libxml/xlink.h /usr/include/libxml2/libxml/schemasInternals.h /usr/include/libxml2/libxml/HTMLparser.h /usr/include/libxml2/libxml/uri.h /usr/include/libxml2/libxml/xmlunicode.h /usr/include/libxml2/libxml/pattern.h /usr/include/libxml2/libxml/list.h /usr/include/libxml2/libxml/xinclude.h /usr/include/libxml2/libxml/xmlmemory.h /usr/include/libxml2/libxml/tree.h /usr/include/libxml2/libxml/xmlautomata.h /usr/include/libxml2/libxml/HTMLtree.h /usr/include/libxml2/libxml/debugXML.h /usr/include/libxml2/libxml/schematron.h /usr/include/libxml2/libxml/xmlregexp.h /usr/include/libxml2/libxml/xmlsave.h /usr/include/libxml2/libxml/xmlmodule.h /usr/include/libxml2/libxml/threads.h /usr/include/libxml2/libxml/xmlwriter.h /usr/include/libxml2/libxml/xmlstring.h /usr/include/libxml2/libxml/xmlschemastypes.h /usr/include/libxml2/libxml/xmlschemas.h /usr/include/libxml2/libxml/SAX.h /usr/include/libxml2/libxml/globals.h /usr/include/libxml2/libxml/xpathInternals.h /usr/include/libxml2/libxml/xpointer.h /usr/include/libxml2/libxml/SAX2.h /usr/include/libxml2/libxml/dict.h /usr/include/libxml2/libxml/nanoftp.h /usr/include/libxml2/libxml/c14n.h /usr/include/libxml2/libxml/hash.h /usr/include/libxml2/libxml/relaxng.h /usr/share /usr/share/aclocal /usr/share/aclocal/libxml2.m4 /usr/share/man /usr/share/man/man3 /usr/share/man/man3/libxml.3.gz /usr/share/man/man1 /usr/share/man/man1/xml2-config.1.gz /usr/share/doc /usr/share/doc/libxml2-dev /usr/share/doc/libxml2-dev/copyright /usr/bin /usr/bin/xml2-config /usr/lib/x86_64-linux-gnu/libxml2.so /usr/share/doc/libxml2-dev/README /usr/share/doc/libxml2-dev/TODO.gz /usr/share/doc/libxml2-dev/NEWS.gz /usr/share/doc/libxml2-dev/AUTHORS /usr/share/doc/libxml2-dev/changelog.Debian.gz
Download (untitled) / with headers
text/plain 1.5k
On Mon Nov 19 22:52:36 2012, LXP wrote: Show quoted text
> Attempting to install XML::LibXML v2.0012 into a Perlbrew environment > running Perl v5.12.3 on a 64-bit Ubuntu Linux Desktop machine fails with > these errors (one per test): > > Can't load '.../XML-LibXML-2.0012/blib/arch/auto/XML/LibXML/LibXML.so' > for module XML::LibXML: .../XML-LibXML- > 2.0012/blib/arch/auto/XML/LibXML/LibXML.so: undefined symbol: > xmlMemMalloc at .../perl-5.12.3/lib/5.12.3/x86_64-linux/DynaLoader.pm > line 200. > at .../perl-5.12.3/lib/5.12.3/x86_64-linux/DynaLoader.pm line 154. > BEGIN failed--compilation aborted at .../XML-LibXML- > 2.0012/blib/lib/XML/LibXML.pm line 154. > > Debian packages libxml2 and libxml2-dev are both installed on the > system. > > These earlier "configure" warnings seem relevant (and contradictory): > > Checking for ability to link against xml2...yes > Checking if your kit is complete... > Looks good > Note (probably harmless): No library found for -lxml2 > Note (probably harmless): No library found for -lz > > Attached files provide a complete log of the module installation > attempt, Perl installation details and libxml2 Debian package details.
First of all, I should note that perl-5.12.3 is old and unsupported and you should upgrade. Otherwise, it should work fine on this perl and on Ubuntu 64-bit. I can try setting up a VM with it, but since would be time consuming, I am tempted to say it is just either an Ubuntu bug (not unheard of) or a SNAFU (= Situation Normal All F***ed up) on your system. Regards, -- Shlomi Fish
Download (untitled) / with headers
text/plain 706b
On Mon Nov 26 05:01:08 2012, SHLOMIF wrote: Show quoted text
> First of all, I should note that perl-5.12.3 is old and unsupported and > you should upgrade. Otherwise, it should work fine on this perl and on > Ubuntu 64-bit. I can try setting up a VM with it, but since would be > time consuming, I am tempted to say it is just either an Ubuntu bug (not > unheard of) or a SNAFU (= Situation Normal All F***ed up) on your system.
I'm seeing this issue as well. I'm also using perlbrew. I've seen it with both perl-5.10.1 and perl-5.16.3 on both Debian squeeze as well as Debian wheezy. I was able to fix it by brewing perl with the -fPIC flag: perlbrew install -n 5.16.3 -A ccflags=-fPIC --as perl-5.16.3-pic Mike
Download (untitled) / with headers
text/plain 881b
On Fri May 17 00:01:17 2013, DIZ wrote: Show quoted text
> On Mon Nov 26 05:01:08 2012, SHLOMIF wrote:
> > First of all, I should note that perl-5.12.3 is old and unsupported
> and
> > you should upgrade. Otherwise, it should work fine on this perl and
> on
> > Ubuntu 64-bit. I can try setting up a VM with it, but since would be > > time consuming, I am tempted to say it is just either an Ubuntu bug
> (not
> > unheard of) or a SNAFU (= Situation Normal All F***ed up) on your
> system. > > I'm seeing this issue as well. I'm also using perlbrew. I've seen it > with both perl-5.10.1 and perl-5.16.3 on both Debian squeeze as well > as Debian wheezy. > > I was able to fix it by brewing perl with the -fPIC flag: > > perlbrew install -n 5.16.3 -A ccflags=-fPIC --as perl-5.16.3-pic > > Mike
OK, in this case, I'm resolving this bug as a dependency problem. Regards, -- Shlomi Fish


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.