Skip Menu |
 

This queue is for tickets about the TAP-Harness-Archive CPAN distribution.

Report information
The Basics
Id: 81075
Status: rejected
Priority: 0/
Queue: TAP-Harness-Archive

People
Owner: schwigon [...] cpan.org
Requestors: MJD [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Critical
Broken in: 0.14
Fixed in: (no value)



Subject: Build.PL won't run under Perl 5.10.1
Download (untitled) / with headers
text/plain 473b
% perl Build.PL Creating new 'MYMETA.yml' with configuration results Can't locate Module/Build/ConfigData.pm in @INC (@INC contains: …) at /usr/lib/perl5/5.10.0/Module/Build/Base.pm line 672. It seems that Module::Build::ConfigData didn't exist until 5.11. There's no separate install for it, so there's no easy way to acquire it for use with 5.10. So this dependency precludes me from using the --archive feature of "prove" with 5.10, seemingly unnecessarily.
Also, I don't see anything in the META.yml about this dependency.
Download (untitled) / with headers
text/plain 520b
Upgrading Module::Build to 0.4003 fixed the problem. But Module::Build's META.yml does not mention that it provides such a module as Module::Build::ConfigData. ( https://metacpan.org/source/LEONT/Module-Build- 0.4003/META.yml ) If this omission is correct, then TAP::Harness::Archive's Build.PL file should not be depending on it. I think you should contact LEONT and confirm that this is part of Module::Build's published interface. If so, he should be advertising it; if not, you should fix your Build.PL file.
Download (untitled) / with headers
text/plain 1.2k
Years later, yet billions of years before the final sun set, I investigated this a bit and think it is not really an issue in this lib. I did: - read about ::ConfigData in Module::Build's Changelog, - found a Module/Build/ConfigData in 5.10.1 https://metacpan.org/source/DAPM/perl-5.10.1/lib/Module/Build/ConfigData.pm - successfully tried to Build.PL/Build/Build test it with a fresh 5.10.1 using its shipped Module::Build 0.340201 - found a CPANTESTERS report using Module::Build 0.32 So I respectfully dare to close this ticket. Please re-open if you don't agree. Kind regards, Steffen On Fri Nov 09 11:35:43 2012, MJD wrote: Show quoted text
> Upgrading Module::Build to 0.4003 fixed the problem. > > But Module::Build's META.yml does not mention that it provides such a > module as > Module::Build::ConfigData. ( > https://metacpan.org/source/LEONT/Module-Build- > 0.4003/META.yml ) If this omission is correct, then > TAP::Harness::Archive's Build.PL file should > not be depending on it. > > I think you should contact LEONT and confirm that this is part of > Module::Build's published > interface. If so, he should be advertising it; if not, you should fix > your Build.PL file.
-- Steffen Schwigon <ss5@renormalist.net> Dresden Perl Mongers <http://dresden-pm.org/>


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.