Skip Menu |
 

This queue is for tickets about the Perl-Dist-Strawberry CPAN distribution.

Report information
The Basics
Id: 80599
Status: resolved
Priority: 0/
Queue: Perl-Dist-Strawberry

People
Owner: Nobody in particular
Requestors: JDS [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Wishlist
Broken in: 3.004
Fixed in: (no value)



Subject: Please support DBD::Pg 2.19.3 in the next Strawberry release
Download (untitled) / with headers
text/plain 577b
Strawberry Perl version 5.16.1.1 includes DBD::Pg version 2.19.2, but this version does not play well together with PostgreSQL version 9.2.x. The reason is that the PostgreSQL developers broke backward compatibility by removing the column pg_tablespace.spclocation, causing problems e.g. when using DBIx::Class::Schema::Loader. DBD::Pg version 2.19.3 works around this bad decision. DBD::Pg version 2.19.3 cannot be installed (without forcing) with Strawberry 5.16.1.1, so I would like to express the wish that DBD::Pg 2.19.3 be included in the next Strawberry release.
Subject: Re: [rt.cpan.org #80599] Please support DBD::Pg 2.19.3 in the next Strawberry release
Date: Sat, 03 Nov 2012 13:11:50 +0100
To: bug-Perl-Dist-Strawberry [...] rt.cpan.org
From: kmx <kmx [...] volny.cz>
Download (untitled) / with headers
text/plain 208b
Strawberry Perl 5.16.2.1 comes with DBD::Pg version 2.19.3 + postgresql client library postgresql-9.2.1 you can check http://strawberryperl.com/download/5.16.2.1/strawberry-perl-5.16.2.1-32bit.msi -- kmx
Download (untitled) / with headers
text/plain 175b
Thank you for the quick reply, that's great! I could not find the installer for 5.16.2.1 via the home page, now I know where to find the beta releases. Best regards José
Subject: Re: [rt.cpan.org #80599] Please support DBD::Pg 2.19.3 in the next Strawberry release
Date: Sat, 03 Nov 2012 17:42:12 +0100
To: bug-Perl-Dist-Strawberry [...] rt.cpan.org
From: kmx <kmx [...] volny.cz>
Download (untitled) / with headers
text/plain 260b
Show quoted text
> Thank you for the quick reply, that's great! I could not find the > installer for 5.16.2.1 via the home page, now I know where to find the > beta releases.
It is because the 5.16.2.1 was built yesterday - I am gonna release it during this weekend -- kmx


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.