Skip Menu |
 

This queue is for tickets about the Gitalist CPAN distribution.

Report information
The Basics
Id: 80081
Status: new
Priority: 0/
Queue: Gitalist

People
Owner: Nobody in particular
Requestors: kwilliams [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Difficulty installing dependencies
Download (untitled) / with headers
text/plain 1.1k
I heard about this project from the p5p summary this week and I wanted to check it out. But I've had a heck of a time installing the bootstrap dependencies. It seems that local::lib doesn't like to install when the version of CPAN.pm is low (on this machine I have CPAN 1.76_02, bundled with perl 5.8.8). So I manually installed CPAN to local-lib5/ using the CPAN.pm client, then installed local::lib from its tarball, then went back to CPAN.pm and installed the other 4 dependencies mentioned in script/bootstrap.pl (which of course nearly downloads the whole internet, at least when using perl 5.8.8). It would be great if the bootstrap.pl script would skip trying to install things if the prerequisite is already met. Then I could run that a few times and make incremental progress when I have to intervene manually. Incidentally, it looks like MooseX-Daemonize (which is required by somethingorother) needs a newer version of File::Path than 1.08, but it doesn't declare the version dependency. So I had to figure that out, & upgrade File::Path explicitly. Anyway, I mostly wanted to report the troubles/solutions for others in the same situation.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.