Skip Menu |
 

This queue is for tickets about the Compress-Raw-Zlib CPAN distribution.

Report information
The Basics
Id: 79812
Status: resolved
Priority: 0/
Queue: Compress-Raw-Zlib

People
Owner: Nobody in particular
Requestors: rs [...] 474.at
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: 2.057

Attachments


Subject: Install to 'site' instead of 'perl' when perl version is 5.11+
Download (untitled) / with headers
text/plain 420b
Hello, According to [1] since perl 5.11 it is no longer necessary to set INSTALLDIRS to 'perl' instead of 'site'. The attached patch amends the version check in Makefile.PL to set it to 'site' if the perl version is at 5.11 or above. Note: I filed a similar patch (RT#79811) for Compress-Raw-Bzip2. regards, Robert Sedlacek [1] https://github.com/rjbs/perltodo/blob/master/Supply-Patches-to-Fix-Install-Location.mkdn
Subject: install_to_site_post_5011.patch
--- Makefile.PL.orig 2012-09-23 20:43:45.520605757 +0200 +++ Makefile.PL 2012-09-23 20:44:12.528739686 +0200 @@ -82,7 +82,7 @@ : (LIBS => [ "-L$ZLIB_LIB -lz " ]) ), - INSTALLDIRS => ($] >= 5.009 ? 'perl' : 'site'), + INSTALLDIRS => (($] >= 5.009 and $] < 5.011) ? 'perl' : 'site'), META_MERGE => { no_index => {


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.