Skip Menu |
 

This queue is for tickets about the Unicode-Normalize CPAN distribution.

Report information
The Basics
Id: 79801
Status: resolved
Priority: 0/
Queue: Unicode-Normalize

People
Owner: Nobody in particular
Requestors: rs [...] 474.at
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: 1.15

Attachments


Subject: Install to 'site' instead of 'perl' when perl version is 5.11+
Download (untitled) / with headers
text/plain 564b
Hello, Currently, when the installing perl version is 5.7.2 or above, the Makefile.PL will set INSTALLDIRS to 'perl' instead of 'site'. According to [1], since 5.11 it is no longer necessary to do this to avoid the core version shadowing the CPAN-installed version. The included patch amends the INSTALLDIRS check to only set it to 'perl' when the version is also below 5.11. Note: I also filed an equal patch for Unicode-Collate (#79800). regards, Robert Sedlacek [1] https://github.com/rjbs/perlto do/blob/master/Supply-Patches- to-Fix-Install-Location.mkdn
Subject: install_to_site_post_5011.patch
--- Makefile.PL.orig 2012-09-23 01:16:20.657152703 +0200 +++ Makefile.PL 2012-09-23 01:17:36.733529946 +0200 @@ -14,7 +14,7 @@ WriteMakefile( 'AUTHOR' => 'SADAHIRO Tomoyuki <SADAHIRO@cpan.org>', 'ABSTRACT' => 'Unicode Normalization Forms', - 'INSTALLDIRS' => $] >= 5.007002 ? 'perl' : 'site', + 'INSTALLDIRS' => ($] >= 5.007002 and $] < 5.011) ? 'perl' : 'site', 'LICENSE' => 'perl', 'NAME' => 'Unicode::Normalize', 'VERSION_FROM' => 'Normalize.pm', # finds $VERSION
Subject: Re: [rt.cpan.org #79801] Install to 'site' instead of 'perl' when perl version is 5.11+
Date: Sun, 23 Sep 2012 13:27:18 +0900
To: bug-Unicode-Normalize [...] rt.cpan.org
From: SADAHIRO Tomoyuki <bqw10602 [...] nifty.com>
Download (untitled) / with headers
text/plain 886b
On Sat, 22 Sep 2012 19:22:07 -0400 "Robert 'phaylon' Sedlacek via RT" <bug-Unicode-Normalize@rt.cpan.org> wrote: Show quoted text
> Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=79801 > > > > Hello, > > Currently, when the installing perl version is 5.7.2 or above, the > Makefile.PL will set INSTALLDIRS to 'perl' instead of 'site'. According > to [1], since 5.11 it is no longer necessary to do this to avoid the > core version shadowing the CPAN-installed version. > > The included patch amends the INSTALLDIRS check to only set it to 'perl' > when the version is also below 5.11. > > Note: I also filed an equal patch for Unicode-Collate (#79800). > > regards, > Robert Sedlacek > > [1] https://github.com/rjbs/perlto do/blob/master/Supply-Patches- > to-Fix-Install-Location.mkdn
Thank you for your report! It should be applied to the next release. Regards, SADAHIRO Tomoyuki
Released. Thank you. Sadahiro Tomoyuki


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.