This queue is for tickets about the Parse-CPAN-Meta CPAN distribution.

Report information
The Basics
Id:
79392
Status:
rejected
Priority:
Low/Low

People
Owner:
Nobody in particular
Requestors:
WORR [...] cpan.org
Cc:
AdminCc:

BugTracker
Severity:
Critical
Broken in:
1.4404
Fixed in:
(no value)

Attachments
Parse-CPAN-Meta-JSON::PP-version.patch



Subject: Version check when loading JSON files fails, because JSON::PP has updated
JSON::PP is version 2.27200 instead of the expected version of 2.27103. Here's the patch I'm adding to the Exherbo dist of the Perl module.
Subject: Parse-CPAN-Meta-JSON::PP-version.patch
--- Parse-CPAN-Meta-1.4404/lib/Parse/CPAN/Meta.pm 2012-04-05 17:01:57.000000000 -0400 +++ Parse-CPAN-Meta-1.4404-new/lib/Parse/CPAN/Meta.pm 2012-09-04 03:59:58.327073820 -0400 @@ -71,8 +71,8 @@ sub json_backend { local $Module::Load::Conditional::CHECK_INC_HASH = 1; if (! $ENV{PERL_JSON_BACKEND} or $ENV{PERL_JSON_BACKEND} eq 'JSON::PP') { - _can_load( 'JSON::PP' => 2.27103 ) - or croak "JSON::PP 2.27103 is not available\n"; + _can_load( 'JSON::PP' => 2.27200 ) + or croak "JSON::PP 2.27200 is not available\n"; return 'JSON::PP'; } else {
On Tue Sep 04 04:03:20 2012, WORR wrote:
Show quoted text
> JSON::PP is version 2.27200 instead of the expected version of 2.27103. > Here's the patch I'm adding to the Exherbo dist of the Perl module.
Well, this was really just do to the move of JSON::PP to JSON::backportPP breaking some things in Perl 5.12 and older. Disregard.


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.