Skip Menu |
 

This queue is for tickets about the ex-lib CPAN distribution.

Report information
The Basics
Id: 79304
Status: open
Priority: 0/
Queue: ex-lib

People
Owner: MONS [...] cpan.org
Requestors: ambs [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Critical
Broken in: 0.90
Fixed in: (no value)



Subject: ex-lib doesn't pass tests
Hello I know you say not to use this module, but I am trying to use your Test::More::UTF8 that uses it, thus, I need to install it. But it fails tests. [ambs@stravinski ex-lib-0.90]$ make test cp lib/ex/lib.pm blib/lib/ex/lib.pm PERL_DL_NONLAZY=1 /opt/perl/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'inc', 'blib/lib', 'blib/arch')" t/00-load.t t/01-check.t t/90-examples.t t/98-fixme.t t/99-kwalitee.t t/pod-coverage.t t/pod.t t/00-load.t ....... 1/6 # Testing ex::lib/lib::abs 0.90 using Cwd 3.39_02, Perl 5.016001, /opt/perl/bin/perl t/00-load.t ....... ok t/01-check.t ...... # Testing ex::lib 0.90 using Cwd 3.39_02, Perl 5.016001, /opt/perl/bin/perl t/01-check.t ...... 1/25 # Bin = `/Users/ambs/tmp/ex-lib-0.90/t' ;. is `/Users/ambs/tmp/ex-lib-0.90/t' # Failed test 'absolute path stay unchanged' # at t/01-check.t line 102. # got: '///opt/perl/lib/5.16.1/darwin-thread-multi-2level' # expected: '///opt/perl/lib' # Failed test 'absolute path stay unchanged' # at t/01-check.t line 103. # got: '///opt/perl/lib/5.16.1' # expected: '//opt/perl/lib' # Failed test 'absolute path stay unchanged' # at t/01-check.t line 104. # got: '///opt/perl/lib' # expected: '/opt/perl/lib' # Failed test './// => .' # at t/01-check.t line 105. # got: '//opt/perl/lib/5.16.1/darwin-thread-multi-2level' # expected: '/Users/ambs/tmp/ex-lib-0.90/t' # Failed test '.// => .' # at t/01-check.t line 108. # got: '//opt/perl/lib/5.16.1' # expected: '/Users/ambs/tmp/ex-lib-0.90/t' # Failed test './ => .' # at t/01-check.t line 109. # got: '//opt/perl/lib' # expected: '/Users/ambs/tmp/ex-lib-0.90/t' # Failed test '. => .' # at t/01-check.t line 110. # got: '/opt/perl/lib/5.16.1/darwin-thread-multi-2level' # expected: '/Users/ambs/tmp/ex-lib-0.90/t' # ex::lib::path('.')=/Users/ambs/tmp/ex-lib-0.90/t # Looks like you failed 7 tests of 25. t/01-check.t ...... Dubious, test returned 7 (wstat 1792, 0x700) Failed 7/25 subtests t/90-examples.t ... ok t/98-fixme.t ...... skipped: $ENV{TEST_AUTHOR} not set t/99-kwalitee.t ... skipped: $ENV{TEST_AUTHOR} not set t/pod-coverage.t .. ok t/pod.t ........... ok Test Summary Report ------------------- t/01-check.t (Wstat: 1792 Tests: 25 Failed: 7) Failed tests: 10-16 Non-zero exit status: 7 Files=7, Tests=34, 0 wallclock secs ( 0.04 usr 0.02 sys + 0.20 cusr 0.03 csys = 0.29 CPU) Result: FAIL Failed 1/7 test programs. 7/34 subtests failed. make: *** [test_dynamic] Error 255 This is perl [ambs@stravinski ex-lib-0.90]$ perl -V Summary of my perl5 (revision 5 version 16 subversion 1) configuration: Platform: osname=darwin, osvers=12.0.0, archname=darwin-thread-multi-2level uname='darwin stravinski.lan 12.0.0 darwin kernel version 12.0.0: sun jun 24 23:00:16 pdt 2012; root:xnu-2050.7.9~1release_x86_64 x86_64 ' config_args='-Dprefix=/opt/perl' hint=recommended, useposix=true, d_sigaction=define useithreads=define, usemultiplicity=define useperlio=define, d_sfio=undef, uselargefiles=define, usesocks=undef use64bitint=define, use64bitall=define, uselongdouble=undef usemymalloc=n, bincompat5005=undef Compiler: cc='cc', ccflags ='-fno-common -DPERL_DARWIN -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include', optimize='-O3', cppflags='-fno-common -DPERL_DARWIN -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include' ccversion='', gccversion='4.2.1 Compatible Apple Clang 4.0 ((tags/Apple/clang-421.0.60))', gccosandvers='' intsize=4, longsize=8, ptrsize=8, doublesize=8, byteorder=12345678 d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16 ivtype='long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8 alignbytes=8, prototype=define Linker and Libraries: ld='env MACOSX_DEPLOYMENT_TARGET=10.3 cc', ldflags =' -fstack-protector -L/usr/local/lib' libpth=/usr/local/lib /usr/lib libs=-ldbm -ldb -ldl -lm -lutil -lc perllibs=-ldl -lm -lutil -lc libc=, so=dylib, useshrplib=true, libperl=libperl.dylib gnulibc_version='' Dynamic Linking: dlsrc=dl_dlopen.xs, dlext=bundle, d_dlsymun=undef, ccdlflags=' ' cccdlflags=' ', lddlflags=' -bundle -undefined dynamic_lookup -L/usr/local/lib -fstack-protector' Characteristics of this binary (from libperl): Compile-time options: HAS_TIMES MULTIPLICITY PERLIO_LAYERS PERL_DONT_CREATE_GVSV PERL_IMPLICIT_CONTEXT PERL_MALLOC_WRAP PERL_PRESERVE_IVUV USE_64_BIT_ALL USE_64_BIT_INT USE_ITHREADS USE_LARGE_FILES USE_LOCALE USE_LOCALE_COLLATE USE_LOCALE_CTYPE USE_LOCALE_NUMERIC USE_PERLIO USE_PERL_ATOF Built under darwin Compiled at Aug 23 2012 20:54:01 %ENV: PERL_AUTOINSTALL_PREFER_CPAN="1" @INC: /opt/perl/lib/site_perl/5.16.1/darwin-thread-multi-2level /opt/perl/lib/site_perl/5.16.1 /opt/perl/lib/5.16.1/darwin-thread-multi-2level /opt/perl/lib/5.16.1 . Thank you
Download (untitled) / with headers
text/plain 172b
I've removed dependency from T:M::UTF8. Also this is not a bug itself in the ex::lib, it's bad test. I'll think of it's fix, but ex::lib was deprecated in favor of lib::abs


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.