Skip Menu |
 

This queue is for tickets about the Module-Install CPAN distribution.

Report information
The Basics
Id: 7921
Status: resolved
Priority: 0/
Queue: Module-Install

People
Owner: Nobody in particular
Requestors: steve.hay [...] uk.radan.com
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 0.36
Fixed in: (no value)

Attachments


Subject: Name "Module::Install::AUTOLOAD" used only once: possible typo
Download (untitled) / with headers
text/plain 562b
When running "perl Makefile.PL" in the attached sample "Foo" module, I get this warning produced under Perl 5.6.x: Name "Module::Install::AUTOLOAD" used only once: possible typo at inc/Module/Install.pm - C:/perl5/site/lib/Module/Install.pm line 172. I can't figure out any way to silence this warning from my Makefile.PL other than removing "use warnings;" from it, which I don't want to do. It doesn't happen under Perl 5.8.x, but since my module supports earlier Perls, I'd like it to behave under 5.6.x. This is using Module-Instal-0.36. Thanks, - Steve
Download Foo-0.01.tar.gz
application/x-gzip 4.9k

Message body not shown because it is not plain text.

Download (untitled) / with headers
text/plain 265b
You should not be using "use warnings" in your Makefile.PL, as it only works >= Perl 5.6. This means an older Perl cannot even run the installer long enough to know that it can't install the module. Aside from that, do you get the warnings with a similar perl -w
Download (untitled) / with headers
text/plain 652b
On Thu Feb 23 04:28:08 2006, ADAMK wrote: Show quoted text
> You should not be using "use warnings" in your Makefile.PL, as it only > works >= Perl 5.6. > > This means an older Perl cannot even run the installer long enough to > know that it can't install the module. > > Aside from that, do you get the warnings with a similar perl -w
You seem to have lost the plot there. "use warnings" does indeed only work >= 5.6, but 5.6 is precisely what I had reported was generating a warning! Anyway, you can close this bug now because after having retried the sample module updated with Module-Install-0.56 I no longer get the warning from perl-5.6.0 that I used to get.
Subject: Re: [rt.cpan.org #7921] Name "Module::Install::AUTOLOAD" used only once: possible typo
Date: Thu, 23 Feb 2006 21:02:08 +1100
To: bug-Module-Install [...] rt.cpan.org
From: Adam Kennedy <adam [...] phase-n.com>
Download (untitled) / with headers
text/plain 929b
Call it a comment on the side. Even if the module isn't compatible with < 5.6, the Makefile.PL should try to be compatible. Thanks for checking, I'm resolving this. Adam K via RT wrote: Show quoted text
> <URL: http://rt.cpan.org/Ticket/Display.html?id=7921 > > > On Thu Feb 23 04:28:08 2006, ADAMK wrote:
>> You should not be using "use warnings" in your Makefile.PL, as it only >> works >= Perl 5.6. >> >> This means an older Perl cannot even run the installer long enough to >> know that it can't install the module. >> >> Aside from that, do you get the warnings with a similar perl -w
> > You seem to have lost the plot there. "use warnings" does indeed only > work >= 5.6, but 5.6 is precisely what I had reported was generating a > warning! > > Anyway, you can close this bug now because after having retried the > sample module updated with Module-Install-0.56 I no longer get the > warning from perl-5.6.0 that I used to get.
Download (untitled) / with headers
text/plain 381b
On Thu Feb 23 05:05:36 2006, adam@phase-n.com wrote: Show quoted text
> Call it a comment on the side. > > Even if the module isn't compatible with < 5.6, the Makefile.PL should > try to be compatible.
The Makefile.PL in my real world module actually has use 5.006000; before the use warnings; so this isn't a problem, although I realize that the "Foo" sample module didn't contain that.
Download (untitled) / with headers
text/plain 172b
Grr. Why did that comment cause the ticket to be "opened" again? The "Status:" field on the form said "resolved (Unchanged)" when I submitted it. Looks like a bug in RT.
Subject: Re: [rt.cpan.org #7921] Name "Module::Install::AUTOLOAD" used only once: possible typo
Date: Thu, 23 Feb 2006 22:37:04 +1100
To: bug-Module-Install [...] rt.cpan.org
From: Adam Kennedy <adam [...] phase-n.com>
Download (untitled) / with headers
text/plain 483b
The idea is that resolving a ticket means the ticket is over. If someone says "yeah, fixed" and it isn't and the report emails back to say "oh no it isn't" the ticket opens again. Adam K And please don't reply this time :) via RT wrote: Show quoted text
> <URL: http://rt.cpan.org/Ticket/Display.html?id=7921 > > > Grr. Why did that comment cause the ticket to be "opened" again? The > "Status:" field on the form said "resolved (Unchanged)" when I submitted > it. Looks like a bug in RT.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.