Skip Menu |
 

This queue is for tickets about the MooseX-Daemonize CPAN distribution.

Report information
The Basics
Id: 79169
Status: resolved
Priority: 0/
Queue: MooseX-Daemonize

People
Owner: ether [...] cpan.org
Requestors: jsailor-cpan [...] jesnetplus.com
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: 0.15
Fixed in: 0.16



Subject: [PATCH] undeclared dependency on File::Path >= 2.06_08
Download (untitled) / with headers
text/plain 927b
MooseX::Daemonize imports make_path from File::Path (Daemonize.pm, line 5), but make_path was only added in File::Path 2.06_08. Some systems (*cough*CentOS*cough*) ship older versions of File::Path, which causes MooseX::Daemonize to faile to build. The patch below is the trivial fix: declare a dependency on a sufficiently new version of File::Path. Note that 2.08 (latest on CPAN) is newer than necessary, but I think it's fair given that 2.08 was released in 2009 and has no non-core deps. :) Cheers, ~jon. --- MooseX-Daemonize-0.15/Makefile.PL 2012-05-31 07:36:44.000000000 -0700 +++ MooseX-Daemonize-0.15.mod/Makefile.PL 2012-08-23 12:23:35.056801000 -0700 @@ -12,6 +12,7 @@ requires 'Moose' => 0.33; requires 'MooseX::Getopt' => 0.07; requires 'MooseX::Types::Path::Class' => 0; +requires 'File::Path' => 2.08; no_index 'directory' => 'examples';
thanks, v0.16 will be released shortly.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.